Bug 352849 - window decoration
Summary: window decoration
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-09-17 18:27 UTC by bndr
Modified: 2015-09-23 14:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bndr 2015-09-17 18:27:22 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-28-generic i686
Distribution: Ubuntu 15.04

-- Information about the crash:
window decorator always crash when triying to select decoration

The crash can be reproduced every time.

-- Backtrace:
Application: إعدادات النظام (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb2989700 (LWP 1691))]

Thread 4 (Thread 0xb2583b40 (LWP 1692)):
#0  0xb775cbe0 in __kernel_vsyscall ()
#1  0xb5d1d3db in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb4fd63a8 in ?? () from /usr/lib/i386-linux-gnu/libxcb.so.1
#3  0xb4fd8394 in xcb_wait_for_event () from /usr/lib/i386-linux-gnu/libxcb.so.1
#4  0xb26db7d3 in QXcbEventReader::run (this=0x9dddcc0) at qxcbconnection.cpp:1105
#5  0xb5f787eb in QThreadPrivate::start (arg=0x9dddcc0) at thread/qthread_unix.cpp:337
#6  0xb4be11aa in start_thread (arg=0xb2583b40) at pthread_create.c:333
#7  0xb5d27fde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 3 (Thread 0xae941b40 (LWP 1705)):
#0  0xb775cbe0 in __kernel_vsyscall ()
#1  0xb5d1d3db in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb4aac120 in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4a9d014 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4a9d156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb61ff9fc in QEventDispatcherGlib::processEvents (this=0xae000468, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#6  0xb61a0d93 in QEventLoop::processEvents (this=0xae9412d4, flags=...) at kernel/qeventloop.cpp:128
#7  0xb61a11fa in QEventLoop::exec (this=0xae9412d4, flags=...) at kernel/qeventloop.cpp:204
#8  0xb5f7340d in QThread::exec (this=0xa14d0c8) at thread/qthread.cpp:503
#9  0xb58dc50f in ?? () from /usr/lib/i386-linux-gnu/libQt5Qml.so.5
#10 0xb5f787eb in QThreadPrivate::start (arg=0xa14d0c8) at thread/qthread_unix.cpp:337
#11 0xb4be11aa in start_thread (arg=0xae941b40) at pthread_create.c:333
#12 0xb5d27fde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 2 (Thread 0xace3fb40 (LWP 1706)):
#0  0xb4a9c959 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb4a9cfaa in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4a9d156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb61ff9fc in QEventDispatcherGlib::processEvents (this=0xac500468, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#4  0xb61a0d93 in QEventLoop::processEvents (this=0xace3f2d4, flags=...) at kernel/qeventloop.cpp:128
#5  0xb61a11fa in QEventLoop::exec (this=0xace3f2d4, flags=...) at kernel/qeventloop.cpp:204
#6  0xb5f7340d in QThread::exec (this=0xa41b068) at thread/qthread.cpp:503
#7  0xb58dc50f in ?? () from /usr/lib/i386-linux-gnu/libQt5Qml.so.5
#8  0xb5f787eb in QThreadPrivate::start (arg=0xa41b068) at thread/qthread_unix.cpp:337
#9  0xb4be11aa in start_thread (arg=0xace3fb40) at pthread_create.c:333
#10 0xb5d27fde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 1 (Thread 0xb2989700 (LWP 1691)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0xb5301f0a in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#9  0xb53014c7 in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#10 0xb51f6188 in ManagedTextureNode::setTexture(QSharedPointer<QSGTexture>) () from /usr/lib/i386-linux-gnu/libKF5QuickAddons.so.5
#11 0xad541a5e in Plasma::FrameSvgItem::updatePaintNode (this=0xbc05a98, oldNode=0xbff6c80) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#12 0xb53598e5 in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#13 0xb535a7dd in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#14 0xb535b0c3 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#15 0xb5327667 in ?? () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#16 0xb53282a8 in ?? () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#17 0xb6c2582a in QApplicationPrivate::notify_helper (this=0x9dcc390, receiver=0xa108de8, e=0xbf89df2c) at kernel/qapplication.cpp:3720
#18 0xb6c2b081 in QApplication::notify (this=0xbf89e230, receiver=0xa108de8, e=0xbf89df2c) at kernel/qapplication.cpp:3503
#19 0xb61a3b8a in QCoreApplication::notifyInternal (this=0xbf89e230, receiver=0xa108de8, event=0xbf89df2c) at kernel/qcoreapplication.cpp:935
#20 0xb61fe808 in sendEvent (event=0xbf89df2c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#21 QTimerInfoList::activateTimers (this=0x9dfd46c) at kernel/qtimerinfo_unix.cpp:635
#22 0xb61fecd9 in timerSourceDispatch (source=0x9dfd438) at kernel/qeventdispatcher_glib.cpp:177
#23 0xb4a9cd64 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0xb4a9d089 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0xb4a9d156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#26 0xb61ff9e4 in QEventDispatcherGlib::processEvents (this=0x9dfb490, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#27 0xb2708611 in QPAEventDispatcherGlib::processEvents (this=0x9dfb490, flags=...) at eventdispatchers/qeventdispatcher_glib.cpp:115
#28 0xb61a0d93 in QEventLoop::processEvents (this=0xbf89e168, flags=...) at kernel/qeventloop.cpp:128
#29 0xb61a11fa in QEventLoop::exec (this=0xbf89e168, flags=...) at kernel/qeventloop.cpp:204
#30 0xb61a9315 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#31 0xb665ca41 in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#32 0xb6c20da4 in QApplication::exec () at kernel/qapplication.cpp:2956
#33 0x08053f85 in main (argc=1, argv=0xbf89e304) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-09-23 14:44:13 UTC

*** This bug has been marked as a duplicate of bug 345675 ***