Bug 346842 - Ustawienia systemowe/styl programów/wystrój okien
Summary: Ustawienia systemowe/styl programów/wystrój okien
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-28 13:19 UTC by Peter
Modified: 2015-05-03 00:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2015-04-28 13:19:16 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic i686
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
trying to change window look after downloading one from Get Hot New Stuff'

-- Backtrace:
Application: Ustawienia systemowe (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb296d700 (LWP 4845))]

Thread 5 (Thread 0xb2437b40 (LWP 4846)):
#0  0xb7745be0 in __kernel_vsyscall ()
#1  0xb5d003db in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb4fb93a8 in ?? () from /usr/lib/i386-linux-gnu/libxcb.so.1
#3  0xb4fbb394 in xcb_wait_for_event () from /usr/lib/i386-linux-gnu/libxcb.so.1
#4  0xb258d7d3 in QXcbEventReader::run (this=0x87bec30) at qxcbconnection.cpp:1105
#5  0xb5f5b7eb in QThreadPrivate::start (arg=0x87bec30) at thread/qthread_unix.cpp:337
#6  0xb4bc41aa in start_thread (arg=0xb2437b40) at pthread_create.c:333
#7  0xb5d0afde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 4 (Thread 0xab7ffb40 (LWP 5094)):
#0  0xb7745996 in __vdso_clock_gettime ()
#1  0xb5d18740 in __GI___clock_gettime (clock_id=1, tp=0xab7ff044) at ../sysdeps/unix/clock_gettime.c:115
#2  0xb5ffc498 in qt_clock_gettime (ts=0xab7ff044, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0xb61e0321 in QTimerInfoList::updateCurrentTime (this=0x8d5efc4) at kernel/qtimerinfo_unix.cpp:84
#6  0xb61e0834 in QTimerInfoList::timerWait (this=0x8d5efc4, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0xb61e1db9 in timerSourcePrepareHelper (timeout=0xab7ff138, src=0x8d5ef90) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=0x8d5ef90, timeout=0xab7ff138) at kernel/qeventdispatcher_glib.cpp:160
#9  0xb4a7f41b in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb4a7ff24 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#11 0xb4a80156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#12 0xb61e29fc in QEventDispatcherGlib::processEvents (this=0x8d70628, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#13 0xb6183d93 in QEventLoop::processEvents (this=0xab7ff2d4, flags=...) at kernel/qeventloop.cpp:128
#14 0xb61841fa in QEventLoop::exec (this=0xab7ff2d4, flags=...) at kernel/qeventloop.cpp:204
#15 0xb5f5640d in QThread::exec (this=0x8d66bb8) at thread/qthread.cpp:503
#16 0xb5f564e8 in QThread::run (this=0x8d66bb8) at thread/qthread.cpp:570
#17 0xb5f5b7eb in QThreadPrivate::start (arg=0x8d66bb8) at thread/qthread_unix.cpp:337
#18 0xb4bc41aa in start_thread (arg=0xab7ffb40) at pthread_create.c:333
#19 0xb5d0afde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 3 (Thread 0xaa03ab40 (LWP 7065)):
#0  0xb4ac6a48 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb4a7feaa in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4a80156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb61e29fc in QEventDispatcherGlib::processEvents (this=0xab800de0, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#4  0xb6183d93 in QEventLoop::processEvents (this=0xaa03a2d4, flags=...) at kernel/qeventloop.cpp:128
#5  0xb61841fa in QEventLoop::exec (this=0xaa03a2d4, flags=...) at kernel/qeventloop.cpp:204
#6  0xb5f5640d in QThread::exec (this=0x8d69048) at thread/qthread.cpp:503
#7  0xb58bf50f in ?? () from /usr/lib/i386-linux-gnu/libQt5Qml.so.5
#8  0xb5f5b7eb in QThreadPrivate::start (arg=0x8d69048) at thread/qthread_unix.cpp:337
#9  0xb4bc41aa in start_thread (arg=0xaa03ab40) at pthread_create.c:333
#10 0xb5d0afde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 2 (Thread 0xa873fb40 (LWP 7066)):
#0  0xb7745996 in __vdso_clock_gettime ()
#1  0xb5d18740 in __GI___clock_gettime (clock_id=1, tp=0xa873f044) at ../sysdeps/unix/clock_gettime.c:115
#2  0xb5ffc498 in qt_clock_gettime (ts=0xa873f044, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0xb61e0321 in QTimerInfoList::updateCurrentTime (this=0xb1b0718c) at kernel/qtimerinfo_unix.cpp:84
#6  0xb61e0834 in QTimerInfoList::timerWait (this=0xb1b0718c, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0xb61e1db9 in timerSourcePrepareHelper (timeout=0xa873f138, src=0xb1b07158) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=0xb1b07158, timeout=0xa873f138) at kernel/qeventdispatcher_glib.cpp:160
#9  0xb4a7f41b in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb4a7ff24 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#11 0xb4a80156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#12 0xb61e29fc in QEventDispatcherGlib::processEvents (this=0xb1b03460, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#13 0xb6183d93 in QEventLoop::processEvents (this=0xa873f2d4, flags=...) at kernel/qeventloop.cpp:128
#14 0xb61841fa in QEventLoop::exec (this=0xa873f2d4, flags=...) at kernel/qeventloop.cpp:204
#15 0xb5f5640d in QThread::exec (this=0x90138c0) at thread/qthread.cpp:503
#16 0xb58bf50f in ?? () from /usr/lib/i386-linux-gnu/libQt5Qml.so.5
#17 0xb5f5b7eb in QThreadPrivate::start (arg=0x90138c0) at thread/qthread_unix.cpp:337
#18 0xb4bc41aa in start_thread (arg=0xa873fb40) at pthread_create.c:333
#19 0xb5d0afde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 1 (Thread 0xb296d700 (LWP 4845)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0xb52e4f0a in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#9  0xb52e44c7 in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#10 0xb51d9188 in ManagedTextureNode::setTexture(QSharedPointer<QSGTexture>) () from /usr/lib/i386-linux-gnu/libKF5QuickAddons.so.5
#11 0xa8e3ba5e in Plasma::FrameSvgItem::updatePaintNode (this=0xa6f3dc8, oldNode=0xa7a92e0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#12 0xb533c8e5 in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#13 0xb533d7dd in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#14 0xb533e0c3 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#15 0xb530a667 in ?? () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#16 0xb530b2a8 in ?? () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#17 0xb6c0882a in QApplicationPrivate::notify_helper (this=0x87aa390, receiver=0x8c590b0, e=0xbfd15e5c) at kernel/qapplication.cpp:3720
#18 0xb6c0e081 in QApplication::notify (this=0xbfd16160, receiver=0x8c590b0, e=0xbfd15e5c) at kernel/qapplication.cpp:3503
#19 0xb6186b8a in QCoreApplication::notifyInternal (this=0xbfd16160, receiver=0x8c590b0, event=0xbfd15e5c) at kernel/qcoreapplication.cpp:935
#20 0xb61e1808 in sendEvent (event=0xbfd15e5c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#21 QTimerInfoList::activateTimers (this=0x87e3e24) at kernel/qtimerinfo_unix.cpp:635
#22 0xb61e1cd9 in timerSourceDispatch (source=0x87e3df0) at kernel/qeventdispatcher_glib.cpp:177
#23 0xb4a7fd64 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0xb4a80089 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0xb4a80156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#26 0xb61e29e4 in QEventDispatcherGlib::processEvents (this=0x87e1050, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#27 0xb25ba611 in QPAEventDispatcherGlib::processEvents (this=0x87e1050, flags=...) at eventdispatchers/qeventdispatcher_glib.cpp:115
#28 0xb6183d93 in QEventLoop::processEvents (this=0xbfd16098, flags=...) at kernel/qeventloop.cpp:128
#29 0xb61841fa in QEventLoop::exec (this=0xbfd16098, flags=...) at kernel/qeventloop.cpp:204
#30 0xb618c315 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#31 0xb663fa41 in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#32 0xb6c03da4 in QApplication::exec () at kernel/qapplication.cpp:2956
#33 0x08053f85 in main (argc=1, argv=0xbfd16234) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Peter 2015-04-29 09:46:51 UTC
Crash was because one of Aurorae decorations from Get Hot Stuff. New user created in system don't generate this bug. To repair, all decorations from .local/share/aurorae/themes must be deleted. Now all works fine.
Beware of screwed up junk at GHS ;)
Comment 2 Christoph Feck 2015-05-03 00:39:28 UTC

*** This bug has been marked as a duplicate of bug 345675 ***