Bug 346832 - systemsettings5 always crash in applications style>windows decorations after a theme installation (Yosewhiten)
Summary: systemsettings5 always crash in applications style>windows decorations after ...
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-28 11:34 UTC by Settimo
Modified: 2015-05-02 23:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Settimo 2015-04-28 11:34:34 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.16.7-21-desktop x86_64
Distribution: "openSUSE 13.2 (Harlequin) (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I was looking for nice themes for my windows because i had just installed plasma5 (reboot done).
I can prevent its crash by scrolling on installed themes very very rapidly after the click on windows decorations.

The crash can be reproduced every time.

-- Backtrace:
Application: Impostazioni di sistema (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe76c21b780 (LWP 1475))]

Thread 5 (Thread 0x7fe75b847700 (LWP 1478)):
#0  0x00007fe76807dc3d in poll () at /lib64/libc.so.6
#1  0x00007fe76698c322 in  () at /usr/lib64/libxcb.so.1
#2  0x00007fe76698ddef in xcb_wait_for_event () at /usr/lib64/libxcb.so.1
#3  0x00007fe75dd97bd9 in  () at /usr/lib64/qt5/plugins/platforms/libqxcb.so
#4  0x00007fe7686f775f in  () at /usr/lib64/libQt5Core.so.5
#5  0x00007fe76520a0a4 in start_thread () at /lib64/libpthread.so.0
#6  0x00007fe76808606d in clone () at /lib64/libc.so.6

Thread 4 (Thread 0x7fe748cdb700 (LWP 1551)):
#0  0x00007fe76520e05f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fe74e54c933 in  () at /usr/lib64/dri/r600_dri.so
#2  0x00007fe74e54c2c7 in  () at /usr/lib64/dri/r600_dri.so
#3  0x00007fe76520a0a4 in start_thread () at /lib64/libpthread.so.0
#4  0x00007fe76808606d in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7fe743cdb700 (LWP 1789)):
#0  0x00007fe764d308e9 in g_mutex_lock () at /usr/lib64/libglib-2.0.so.0
#1  0x00007fe764ceebca in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fe764ceecec in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fe7689290bb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007fe7688cfccb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007fe7686f2b3a in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007fe7443cd3f8 in  () at /usr/lib64/libQt5Qml.so.5
#7  0x00007fe7686f775f in  () at /usr/lib64/libQt5Core.so.5
#8  0x00007fe76520a0a4 in start_thread () at /lib64/libpthread.so.0
#9  0x00007fe76808606d in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7fe73bb20700 (LWP 1790)):
#0  0x00007fe76807dc3d in poll () at /lib64/libc.so.6
#1  0x00007fe764ceebe4 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fe764ceecec in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fe7689290bb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007fe7688cfccb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007fe7686f2b3a in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007fe7443cd3f8 in  () at /usr/lib64/libQt5Qml.so.5
#7  0x00007fe7686f775f in  () at /usr/lib64/libQt5Core.so.5
#8  0x00007fe76520a0a4 in start_thread () at /lib64/libpthread.so.0
#9  0x00007fe76808606d in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7fe76c21b780 (LWP 1475)):
[KCrash Handler]
#5  0x0000000000650000 in  ()
#6  0x00007fe744d10828 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () at /usr/lib64/libQt5Quick.so.5
#7  0x00007fe744d0ff8c in QSGSimpleTextureNode::setTexture(QSGTexture*) () at /usr/lib64/libQt5Quick.so.5
#8  0x00007fe7421281b2 in  () at /usr/lib64/qt5/qml/org/kde/plasma/core/libcorebindingsplugin.so
#9  0x00007fe744d5fd70 in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () at /usr/lib64/libQt5Quick.so.5
#10 0x00007fe744d608fc in QQuickWindowPrivate::updateDirtyNodes() () at /usr/lib64/libQt5Quick.so.5
#11 0x00007fe744d60e90 in QQuickWindowPrivate::syncSceneGraph() () at /usr/lib64/libQt5Quick.so.5
#12 0x00007fe744d32e78 in  () at /usr/lib64/libQt5Quick.so.5
#13 0x00007fe744d33885 in  () at /usr/lib64/libQt5Quick.so.5
#14 0x00007fe769cf0b5c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#15 0x00007fe769cf5a26 in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#16 0x00007fe7688d1d65 in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
#17 0x00007fe768928aad in QTimerInfoList::activateTimers() () at /usr/lib64/libQt5Core.so.5
#18 0x00007fe768928dd1 in  () at /usr/lib64/libQt5Core.so.5
#19 0x00007fe764ceea04 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#20 0x00007fe764ceec48 in  () at /usr/lib64/libglib-2.0.so.0
#21 0x00007fe764ceecec in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#22 0x00007fe7689290bb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#23 0x00007fe7688cfccb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#24 0x00007fe7688d7336 in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
#25 0x0000000000410130 in main ()

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-02 23:49:49 UTC

*** This bug has been marked as a duplicate of bug 345675 ***