Bug 351764 - Awaria Plasmy po wejściu w ustawienia wystroju okien.
Summary: Awaria Plasmy po wejściu w ustawienia wystroju okien.
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-08-25 19:09 UTC by pakosik
Modified: 2015-09-03 09:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pakosik 2015-08-25 19:09:45 UTC
Application: systemsettings5 (5.3.0)
 (Compiled from sources)
Qt Version: 5.4.1
Operating System: Linux 3.19.0-26-generic x86_64
Distribution: Netrunner 16

-- Information about the crash:
- What I was doing when the application crashed:
I was looking trough window styles, I think, ,,Plastik" stayle mayy be a problem

The crash can be reproduced every time.

-- Backtrace:
Application: Ustawienia systemowe (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8b01b93780 (LWP 4135))]

Thread 4 (Thread 0x7f8af11e6700 (LWP 4136)):
#0  0x00007f8afe3038dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f8afc61cb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f8afc61e64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f8af3731099 in QXcbEventReader::run (this=0x113f6d0) at qxcbconnection.cpp:1105
#4  0x00007f8afe984b0e in QThreadPrivate::start (arg=0x113f6d0) at thread/qthread_unix.cpp:337
#5  0x00007f8afb5366aa in start_thread (arg=0x7f8af11e6700) at pthread_create.c:333
#6  0x00007f8afe30eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f8adb7fe700 (LWP 4185)):
#0  0x00007f8afe3038dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f8afb017ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8afb017fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8afec1bc6c in QEventDispatcherGlib::processEvents (this=0x7f8acc01bc00, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f8afebc03e2 in QEventLoop::exec (this=this@entry=0x7f8adb7fde20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f8afe97fb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f8afd949f75 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f8afe984b0e in QThreadPrivate::start (arg=0x24d3d50) at thread/qthread_unix.cpp:337
#8  0x00007f8afb5366aa in start_thread (arg=0x7f8adb7fe700) at pthread_create.c:333
#9  0x00007f8afe30eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f8adbfff700 (LWP 4186)):
#0  0x00007f8afe3038dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f8afb017ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8afb017fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8afec1bc6c in QEventDispatcherGlib::processEvents (this=0x7f8ad0003120, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f8afebc03e2 in QEventLoop::exec (this=this@entry=0x7f8adbffee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f8afe97fb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f8afd949f75 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f8afe984b0e in QThreadPrivate::start (arg=0x29a59b0) at thread/qthread_unix.cpp:337
#8  0x00007f8afb5366aa in start_thread (arg=0x7f8adbfff700) at pthread_create.c:333
#9  0x00007f8afe30eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f8b01b93780 (LWP 4135)):
[KCrash Handler]
#6  0x0000006500000065 in ?? ()
#7  0x00007f8afd3ce628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f8afd3cdd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f8ac3c45c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x656d090, oldNode=0x668fa10) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f8afd4214bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f8afd4224cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f8afd422d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f8afd3f1f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f8afd3f2979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f8aff9aeb2c in QApplicationPrivate::notify_helper (this=0x1128b10, receiver=0x24d23f0, e=0x7ffec099c590) at kernel/qapplication.cpp:3720
#16 0x00007f8aff9b4000 in QApplication::notify (this=0x7ffec099c900, receiver=0x24d23f0, e=0x7ffec099c590) at kernel/qapplication.cpp:3503
#17 0x00007f8afebc2c2b in QCoreApplication::notifyInternal (this=0x7ffec099c900, receiver=0x24d23f0, event=event@entry=0x7ffec099c590) at kernel/qcoreapplication.cpp:935
#18 0x00007f8afec1aae5 in sendEvent (event=0x7ffec099c590, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x1180660) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f8afec1af61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f8afb017c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f8afb017f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f8afb017fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f8afec1bc57 in QEventDispatcherGlib::processEvents (this=0x1162d80, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f8afebc03e2 in QEventLoop::exec (this=this@entry=0x7ffec099c7e0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f8afebc802c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f8aff3e931c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f8aff9aa7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040ef5b in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:55

Reported using DrKonqi
Comment 1 Christoph Feck 2015-09-03 09:13:40 UTC

*** This bug has been marked as a duplicate of bug 345675 ***