Bug 349153 - KDE Window Decorations crash
Summary: KDE Window Decorations crash
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-06-14 15:45 UTC by r.altieri357
Modified: 2015-06-16 17:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description r.altieri357 2015-06-14 15:45:47 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-20-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:

Installed some Window Decorations for KDE, specifically from results found while searching for "glow" and "neon" in the "Get New Decorations" menu for Window Decorations. It crashed when I scrolled to see more of the Window Decorations I installed, so I uninstalled a few Window Decorations and now it doesn't crash anymore. It also crashed if I had the system settings window maximized, therefore viewing more of the Window Decorations available.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f012f4a0780 (LWP 3365))]

Thread 4 (Thread 0x7f011ec24700 (LWP 3366)):
#0  0x00007f012bc0f8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f0129f29b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f0129f2b64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f012116f099 in QXcbEventReader::run (this=0x137c620) at qxcbconnection.cpp:1105
#4  0x00007f012c290b0e in QThreadPrivate::start (arg=0x137c620) at thread/qthread_unix.cpp:337
#5  0x00007f0128e436aa in start_thread (arg=0x7f011ec24700) at pthread_create.c:333
#6  0x00007f012bc1aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f010e3ee700 (LWP 3368)):
#0  0x00007f012bc0f8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f0128924ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0128924fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f012c527c6c in QEventDispatcherGlib::processEvents (this=0x7f01080008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f012c4cc3e2 in QEventLoop::exec (this=this@entry=0x7f010e3ede20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f012c28bb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f012b256f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f012c290b0e in QThreadPrivate::start (arg=0x1de1cf0) at thread/qthread_unix.cpp:337
#8  0x00007f0128e436aa in start_thread (arg=0x7f010e3ee700) at pthread_create.c:333
#9  0x00007f012bc1aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f0106eb6700 (LWP 3369)):
#0  0x00007ffe697f0cee in clock_gettime ()
#1  0x00007f012bc2938d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f012c346cb6 in qt_clock_gettime (ts=0x7f0106eb5b80, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0x00007f012c525639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f0100002cd0) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007f012c525ba5 in QTimerInfoList::timerWait (this=0x7f0100002cd0, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0x00007f012c52703e in timerSourcePrepareHelper (timeout=0x7f0106eb5c54, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7f0106eb5c54) at kernel/qeventdispatcher_glib.cpp:160
#9  0x00007f01289243fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f0128924de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f0128924fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f012c527c6c in QEventDispatcherGlib::processEvents (this=0x7f01000008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007f012c4cc3e2 in QEventLoop::exec (this=this@entry=0x7f0106eb5e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007f012c28bb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007f012b256f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007f012c290b0e in QThreadPrivate::start (arg=0x211c160) at thread/qthread_unix.cpp:337
#17 0x00007f0128e436aa in start_thread (arg=0x7f0106eb6700) at pthread_create.c:333
#18 0x00007f012bc1aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f012f4a0780 (LWP 3365)):
[KCrash Handler]
#6  0x0000006500000065 in ?? ()
#7  0x00007f012acdb628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f012acdad3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f010c8b2c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x5ca6ea0, oldNode=0x53e4140) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f012ad2e4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f012ad2f4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f012ad2fd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f012acfef05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f012acff979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f012d2bab2c in QApplicationPrivate::notify_helper (this=0x1365b10, receiver=0x1d9d6f0, e=0x7ffe697cc420) at kernel/qapplication.cpp:3720
#16 0x00007f012d2c0000 in QApplication::notify (this=0x7ffe697cc790, receiver=0x1d9d6f0, e=0x7ffe697cc420) at kernel/qapplication.cpp:3503
#17 0x00007f012c4cec2b in QCoreApplication::notifyInternal (this=0x7ffe697cc790, receiver=0x1d9d6f0, event=event@entry=0x7ffe697cc420) at kernel/qcoreapplication.cpp:935
#18 0x00007f012c526ae5 in sendEvent (event=0x7ffe697cc420, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x13a91f0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f012c526f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f0128924c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f0128924f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f0128924fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f012c527c57 in QEventDispatcherGlib::processEvents (this=0x13a8b40, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f012c4cc3e2 in QEventLoop::exec (this=this@entry=0x7ffe697cc670, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f012c4d402c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f012ccf531c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f012d2b67a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-06-16 17:23:42 UTC

*** This bug has been marked as a duplicate of bug 345675 ***