Bug 346981 - systemeinstellungen --> Fensterdekoration crasht
Summary: systemeinstellungen --> Fensterdekoration crasht
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-30 20:07 UTC by Ulrich.Grün
Modified: 2015-05-02 23:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich.Grün 2015-04-30 20:07:56 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic i686
Distribution: Ubuntu 15.04

-- Information about the crash:
I was opening the Fensterdekoration, then it crashed after a few seconds (every time) since i installed the Fensterdekoration called OS X.

The crash can be reproduced every time.

-- Backtrace:
Application: Systemeinstellungen (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb2960700 (LWP 2633))]

Thread 6 (Thread 0xb23eab40 (LWP 2634)):
#0  0xb772ebe0 in __kernel_vsyscall ()
#1  0xb5cf43db in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb4fad3a8 in ?? () from /usr/lib/i386-linux-gnu/libxcb.so.1
#3  0xb4faf394 in xcb_wait_for_event () from /usr/lib/i386-linux-gnu/libxcb.so.1
#4  0xb25407d3 in QXcbEventReader::run (this=0x9cd51d0) at qxcbconnection.cpp:1105
#5  0xb5f4f7eb in QThreadPrivate::start (arg=0x9cd51d0) at thread/qthread_unix.cpp:337
#6  0xb4bb81aa in start_thread (arg=0xb23eab40) at pthread_create.c:333
#7  0xb5cfefde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 5 (Thread 0xad5c8b40 (LWP 2635)):
#0  0xb772ebe0 in __kernel_vsyscall ()
#1  0xb4bbd25c in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb5d0bcf6 in __pthread_cond_wait (cond=0x9e1355c, mutex=0x9e13544) at forward.c:149
#3  0xafe7158a in ?? () from /usr/lib/i386-linux-gnu/dri/swrast_dri.so
#4  0xafe70d45 in ?? () from /usr/lib/i386-linux-gnu/dri/swrast_dri.so
#5  0xb4bb81aa in start_thread (arg=0xad5c8b40) at pthread_create.c:333
#6  0xb5cfefde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 4 (Thread 0xacdc7b40 (LWP 2636)):
#0  0xb772ebe0 in __kernel_vsyscall ()
#1  0xb4bbd25c in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb5d0bcf6 in __pthread_cond_wait (cond=0x9e13654, mutex=0x9e1363c) at forward.c:149
#3  0xafe7158a in ?? () from /usr/lib/i386-linux-gnu/dri/swrast_dri.so
#4  0xafe70d45 in ?? () from /usr/lib/i386-linux-gnu/dri/swrast_dri.so
#5  0xb4bb81aa in start_thread (arg=0xacdc7b40) at pthread_create.c:333
#6  0xb5cfefde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 3 (Thread 0xab30eb40 (LWP 2637)):
#0  0xb4a70d01 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb4a7387b in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4a73faa in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4a74156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb61d69fc in QEventDispatcherGlib::processEvents (this=0xaaa00468, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#5  0xb6177d93 in QEventLoop::processEvents (this=0xab30e2d4, flags=...) at kernel/qeventloop.cpp:128
#6  0xb61781fa in QEventLoop::exec (this=0xab30e2d4, flags=...) at kernel/qeventloop.cpp:204
#7  0xb5f4a40d in QThread::exec (this=0x9fc0b98) at thread/qthread.cpp:503
#8  0xb58b350f in ?? () from /usr/lib/i386-linux-gnu/libQt5Qml.so.5
#9  0xb5f4f7eb in QThreadPrivate::start (arg=0x9fc0b98) at thread/qthread_unix.cpp:337
#10 0xb4bb81aa in start_thread (arg=0xab30eb40) at pthread_create.c:333
#11 0xb5cfefde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 2 (Thread 0xa97beb40 (LWP 2638)):
#0  0xb772ebe0 in __kernel_vsyscall ()
#1  0xb5cee75b in read () at ../sysdeps/unix/syscall-template.S:81
#2  0xb4ab9515 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4a73a82 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4a73faa in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4a74156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb61d69fc in QEventDispatcherGlib::processEvents (this=0xa8e00468, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#7  0xb6177d93 in QEventLoop::processEvents (this=0xa97be2d4, flags=...) at kernel/qeventloop.cpp:128
#8  0xb61781fa in QEventLoop::exec (this=0xa97be2d4, flags=...) at kernel/qeventloop.cpp:204
#9  0xb5f4a40d in QThread::exec (this=0xa19fb78) at thread/qthread.cpp:503
#10 0xb58b350f in ?? () from /usr/lib/i386-linux-gnu/libQt5Qml.so.5
#11 0xb5f4f7eb in QThreadPrivate::start (arg=0xa19fb78) at thread/qthread_unix.cpp:337
#12 0xb4bb81aa in start_thread (arg=0xa97beb40) at pthread_create.c:333
#13 0xb5cfefde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 1 (Thread 0xb2960700 (LWP 2633)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0xb52d8f0a in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#9  0xb52d84c7 in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#10 0xb51cd188 in ManagedTextureNode::setTexture(QSharedPointer<QSGTexture>) () from /usr/lib/i386-linux-gnu/libKF5QuickAddons.so.5
#11 0xaa00ba5e in Plasma::FrameSvgItem::updatePaintNode (this=0xbbb3c58, oldNode=0xbc72680) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#12 0xb53308e5 in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#13 0xb53317dd in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#14 0xb53320c3 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#15 0xb52fe667 in ?? () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#16 0xb52ff2a8 in ?? () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#17 0xb6bfc82a in QApplicationPrivate::notify_helper (this=0x9cc2390, receiver=0x9f285a8, e=0xbfc3d92c) at kernel/qapplication.cpp:3720
#18 0xb6c02081 in QApplication::notify (this=0xbfc3dc30, receiver=0x9f285a8, e=0xbfc3d92c) at kernel/qapplication.cpp:3503
#19 0xb617ab8a in QCoreApplication::notifyInternal (this=0xbfc3dc30, receiver=0x9f285a8, event=0xbfc3d92c) at kernel/qcoreapplication.cpp:935
#20 0xb61d5808 in sendEvent (event=0xbfc3d92c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#21 QTimerInfoList::activateTimers (this=0x9cf9f9c) at kernel/qtimerinfo_unix.cpp:635
#22 0xb61d5cd9 in timerSourceDispatch (source=0x9cf9f68) at kernel/qeventdispatcher_glib.cpp:177
#23 0xb4a73d64 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0xb4a74089 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0xb4a74156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#26 0xb61d69e4 in QEventDispatcherGlib::processEvents (this=0x9cf4ee8, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#27 0xb256d611 in QPAEventDispatcherGlib::processEvents (this=0x9cf4ee8, flags=...) at eventdispatchers/qeventdispatcher_glib.cpp:115
#28 0xb6177d93 in QEventLoop::processEvents (this=0xbfc3db68, flags=...) at kernel/qeventloop.cpp:128
#29 0xb61781fa in QEventLoop::exec (this=0xbfc3db68, flags=...) at kernel/qeventloop.cpp:204
#30 0xb6180315 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#31 0xb6633a41 in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#32 0xb6bf7da4 in QApplication::exec () at kernel/qapplication.cpp:2956
#33 0x08053f85 in main (argc=1, argv=0xbfc3dd04) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-02 23:51:41 UTC

*** This bug has been marked as a duplicate of bug 345675 ***