Bug 349674 - Appliation Style crashes
Summary: Appliation Style crashes
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-06-28 00:13 UTC by rhinobird
Modified: 2015-07-10 14:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rhinobird 2015-06-28 00:13:00 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-22-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
Appliation Style crashes when going into Window Decoration

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa601800780 (LWP 9073))]

Thread 5 (Thread 0x7fa5f0f84700 (LWP 9076)):
#0  0x00007fa5fdf6f8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa5fc289b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fa5fc28b64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fa5f34cf099 in QXcbEventReader::run (this=0x17d0af0) at qxcbconnection.cpp:1105
#4  0x00007fa5fe5f0b0e in QThreadPrivate::start (arg=0x17d0af0) at thread/qthread_unix.cpp:337
#5  0x00007fa5fb1a36aa in start_thread (arg=0x7fa5f0f84700) at pthread_create.c:333
#6  0x00007fa5fdf7aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fa5e19d7700 (LWP 9077)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fa5e4a144fb in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#2  0x00007fa5e4a13c87 in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#3  0x00007fa5fb1a36aa in start_thread (arg=0x7fa5e19d7700) at pthread_create.c:333
#4  0x00007fa5fdf7aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fa5ddb05700 (LWP 9080)):
#0  0x00007fa5fdf6f8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa5fac84ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa5fac84fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa5fe887c6c in QEventDispatcherGlib::processEvents (this=0x7fa5d80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fa5fe82c3e2 in QEventLoop::exec (this=this@entry=0x7fa5ddb04e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fa5fe5ebb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fa5fd5b6f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fa5fe5f0b0e in QThreadPrivate::start (arg=0x1de0680) at thread/qthread_unix.cpp:337
#8  0x00007fa5fb1a36aa in start_thread (arg=0x7fa5ddb05700) at pthread_create.c:333
#9  0x00007fa5fdf7aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fa5d64d1700 (LWP 9081)):
#0  0x00007fa5fac84a4a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fa5fac84f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa5fac84fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa5fe887c6c in QEventDispatcherGlib::processEvents (this=0x7fa5d00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fa5fe82c3e2 in QEventLoop::exec (this=this@entry=0x7fa5d64d0e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fa5fe5ebb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fa5fd5b6f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fa5fe5f0b0e in QThreadPrivate::start (arg=0x205dab0) at thread/qthread_unix.cpp:337
#8  0x00007fa5fb1a36aa in start_thread (arg=0x7fa5d64d1700) at pthread_create.c:333
#9  0x00007fa5fdf7aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fa601800780 (LWP 9073)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007fa5fd03b628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fa5fd03ad3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fa5d7dd9c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x2373030, oldNode=0x31231b0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007fa5fd08e4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fa5fd08f4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fa5fd08fd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fa5fd05ef05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fa5fd060016 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fa5ff0667b5 in QWindow::event (this=0x1d2f4a0, ev=<optimized out>) at kernel/qwindow.cpp:2051
#16 0x00007fa5fd099dd3 in QQuickWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#17 0x00007fa5ff61ab2c in QApplicationPrivate::notify_helper (this=0x17b5b10, receiver=0x1d2f4a0, e=0x7fffd35b65d0) at kernel/qapplication.cpp:3720
#18 0x00007fa5ff620000 in QApplication::notify (this=0x7fffd35b69d0, receiver=0x1d2f4a0, e=0x7fffd35b65d0) at kernel/qapplication.cpp:3503
#19 0x00007fa5fe82ec2b in QCoreApplication::notifyInternal (this=0x7fffd35b69d0, receiver=receiver@entry=0x1d2f4a0, event=event@entry=0x7fffd35b65d0) at kernel/qcoreapplication.cpp:935
#20 0x00007fa5ff05ee86 in sendSpontaneousEvent (event=0x7fffd35b65d0, receiver=0x1d2f4a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#21 QGuiApplicationPrivate::processExposeEvent (e=0x1cdfa30) at kernel/qguiapplication.cpp:2613
#22 0x00007fa5ff05fbbd in QGuiApplicationPrivate::processWindowSystemEvent (e=e@entry=0x1cdfa30) at kernel/qguiapplication.cpp:1638
#23 0x00007fa5ff04434f in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:572
#24 0x00007fa5f34f9590 in userEventSourceDispatch (source=<optimized out>) at eventdispatchers/qeventdispatcher_glib.cpp:70
#25 0x00007fa5fac84c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fa5fac84f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007fa5fac84fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fa5fe887c57 in QEventDispatcherGlib::processEvents (this=0x17fc6b0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#29 0x00007fa5fe82c3e2 in QEventLoop::exec (this=this@entry=0x7fffd35b68b0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#30 0x00007fa5fe83402c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#31 0x00007fa5ff05531c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#32 0x00007fa5ff6167a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#33 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-07-10 14:15:57 UTC

*** This bug has been marked as a duplicate of bug 345675 ***