Bug 346572 - FATAL: Systemsettings - Application Style crashes (segmentation fault) on most installable styles
Summary: FATAL: Systemsettings - Application Style crashes (segmentation fault) on mos...
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-24 14:39 UTC by Patrick Tanz
Modified: 2015-04-25 08:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Tanz 2015-04-24 14:39:40 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- installed some of the most favorite and most often downloaded styles (maybe 5 or 6 ones)
- scrolled in preview window to choose one of the previously installed styles
- instant crash while rendering previews...
- now I am unable to change ANY style setting, because this systemsessings-modul crashes instantly on startup... -> fatal bug!!!

The crash can be reproduced every time.

-- Backtrace:
Application: Systemeinstellungen (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff82c0d0780 (LWP 5564))]

Thread 4 (Thread 0x7ff81b6d7700 (LWP 5565)):
#0  0x00007ff8288368dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007ff826b50b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007ff826b5264f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007ff81dc22099 in QXcbEventReader::run (this=0x13c2600) at qxcbconnection.cpp:1105
#4  0x00007ff828eb7b0e in QThreadPrivate::start (arg=0x13c2600) at thread/qthread_unix.cpp:337
#5  0x00007ff825a6a6aa in start_thread (arg=0x7ff81b6d7700) at pthread_create.c:333
#6  0x00007ff828841eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7ff80ae09700 (LWP 5566)):
#0  0x00007ff82554b3b3 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ff82554bde8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff82554bfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff82914ec6c in QEventDispatcherGlib::processEvents (this=0x7ff8040008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007ff8290f33e2 in QEventLoop::exec (this=this@entry=0x7ff80ae08e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007ff828eb2b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007ff827e7df65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007ff828eb7b0e in QThreadPrivate::start (arg=0x1ffb7e0) at thread/qthread_unix.cpp:337
#8  0x00007ff825a6a6aa in start_thread (arg=0x7ff80ae09700) at pthread_create.c:333
#9  0x00007ff828841eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7ff803830700 (LWP 5567)):
#0  0x00007ff8288368dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007ff82554bebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff82554bfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff82914ec6c in QEventDispatcherGlib::processEvents (this=0x7ff7fc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007ff8290f33e2 in QEventLoop::exec (this=this@entry=0x7ff80382fe20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007ff828eb2b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007ff827e7df65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007ff828eb7b0e in QThreadPrivate::start (arg=0x22caf20) at thread/qthread_unix.cpp:337
#8  0x00007ff825a6a6aa in start_thread (arg=0x7ff803830700) at pthread_create.c:333
#9  0x00007ff828841eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7ff82c0d0780 (LWP 5564)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007ff827902628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007ff827901d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007ff8097f3c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x561ce80, oldNode=0x57f9490) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007ff8279554bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007ff8279564cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007ff827956d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007ff827925f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007ff827926979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007ff829ee1b2c in QApplicationPrivate::notify_helper (this=0x13abb10, receiver=0x1ff8fe0, e=0x7ffeb23fbed0) at kernel/qapplication.cpp:3720
#16 0x00007ff829ee7000 in QApplication::notify (this=0x7ffeb23fc240, receiver=0x1ff8fe0, e=0x7ffeb23fbed0) at kernel/qapplication.cpp:3503
#17 0x00007ff8290f5c2b in QCoreApplication::notifyInternal (this=0x7ffeb23fc240, receiver=0x1ff8fe0, event=event@entry=0x7ffeb23fbed0) at kernel/qcoreapplication.cpp:935
#18 0x00007ff82914dae5 in sendEvent (event=0x7ffeb23fbed0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x13f5ea0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007ff82914df61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007ff82554bc3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007ff82554bf20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007ff82554bfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007ff82914ec6c in QEventDispatcherGlib::processEvents (this=0x13ee060, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007ff8290f33e2 in QEventLoop::exec (this=this@entry=0x7ffeb23fc120, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007ff8290fb02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007ff82991c31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007ff829edd7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-04-25 08:34:06 UTC

*** This bug has been marked as a duplicate of bug 345675 ***