Bug 346977 - impostazione sistema
Summary: impostazione sistema
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-30 19:33 UTC by makoz
Modified: 2015-05-02 23:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description makoz 2015-04-30 19:33:17 UTC
Application: systemsettings5 (5.3.0)
 (Compiled from sources)
Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
errore nell inseerire i vari temi su stile delle applicazioni nelle decorazioni delle finestre

The crash can be reproduced every time.

-- Backtrace:
Application: Impostazioni di sistema (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2d50e55780 (LWP 1994))]

Thread 7 (Thread 0x7f2d30fdc700 (LWP 1996)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f2d340194fb in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#2  0x00007f2d34018c87 in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#3  0x00007f2d4a7f06aa in start_thread (arg=0x7f2d30fdc700) at pthread_create.c:333
#4  0x00007f2d4d5c7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 6 (Thread 0x7f2d2caa8700 (LWP 1998)):
#0  0x00007f2d4a316789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f2d4a2d0f38 in g_main_context_release () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2d4a2d1e76 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2d4a2d2242 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f2d2cfb0ae6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#5  0x00007f2d4a2f8955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f2d4a7f06aa in start_thread (arg=0x7f2d2caa8700) at pthread_create.c:333
#7  0x00007f2d4d5c7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f2d27fff700 (LWP 2099)):
#0  __libc_disable_asynccancel () at ../sysdeps/unix/sysv/linux/x86_64/cancellation.S:94
#1  0x00007f2d4d5bc8e9 in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0x00007f2d4a2d1ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2d4a2d1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f2d4ded4c6c in QEventDispatcherGlib::processEvents (this=0x7f2d20055bf0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f2d4de793e2 in QEventLoop::exec (this=this@entry=0x7f2d27ffee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f2d4dc38b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f2d4cc03f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f2d4dc3db0e in QThreadPrivate::start (arg=0x2f4de40) at thread/qthread_unix.cpp:337
#9  0x00007f2d4a7f06aa in start_thread (arg=0x7f2d27fff700) at pthread_create.c:333
#10 0x00007f2d4d5c7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f2d15447700 (LWP 2100)):
#0  0x00007f2d4a316789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f2d4a2d1409 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2d4a2d1de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2d4a2d1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f2d4ded4c6c in QEventDispatcherGlib::processEvents (this=0x7f2d100008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f2d4de793e2 in QEventLoop::exec (this=this@entry=0x7f2d15446e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f2d4dc38b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f2d4cc03f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f2d4dc3db0e in QThreadPrivate::start (arg=0x2d4ddf0) at thread/qthread_unix.cpp:337
#9  0x00007f2d4a7f06aa in start_thread (arg=0x7f2d15447700) at pthread_create.c:333
#10 0x00007f2d4d5c7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f2d05a22700 (LWP 2119)):
#0  0x00007f2d4a2d13de in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f2d4a2d1de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2d4a2d1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2d4ded4c6c in QEventDispatcherGlib::processEvents (this=0x7f2cec018fe0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f2d4de793e2 in QEventLoop::exec (this=this@entry=0x7f2d05a21e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f2d4dc38b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f2d4cc03f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f2d4dc3db0e in QThreadPrivate::start (arg=0x34a9cb0) at thread/qthread_unix.cpp:337
#8  0x00007f2d4a7f06aa in start_thread (arg=0x7f2d05a22700) at pthread_create.c:333
#9  0x00007f2d4d5c7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f2d06882700 (LWP 2120)):
#0  0x00007f2d4d5bc8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f2d4a2d1ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2d4a2d1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2d4ded4c6c in QEventDispatcherGlib::processEvents (this=0x7f2cf401dce0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f2d4de793e2 in QEventLoop::exec (this=this@entry=0x7f2d06881e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f2d4dc38b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f2d4cc03f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f2d4dc3db0e in QThreadPrivate::start (arg=0x1b3b5e0) at thread/qthread_unix.cpp:337
#8  0x00007f2d4a7f06aa in start_thread (arg=0x7f2d06882700) at pthread_create.c:333
#9  0x00007f2d4d5c7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f2d50e55780 (LWP 1994)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f2d4c688628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f2d4c687d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f2d169d3c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x6518380, oldNode=0x662e900) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f2d4c6db4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f2d4c6dc4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f2d4c6dcd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f2d4c6abf05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f2d4c6ac979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f2d4ec67b2c in QApplicationPrivate::notify_helper (this=0xa46b10, receiver=0x30c2430, e=0x7fff1a6ba030) at kernel/qapplication.cpp:3720
#16 0x00007f2d4ec6d000 in QApplication::notify (this=0x7fff1a6ba3a0, receiver=0x30c2430, e=0x7fff1a6ba030) at kernel/qapplication.cpp:3503
#17 0x00007f2d4de7bc2b in QCoreApplication::notifyInternal (this=0x7fff1a6ba3a0, receiver=0x30c2430, event=event@entry=0x7fff1a6ba030) at kernel/qcoreapplication.cpp:935
#18 0x00007f2d4ded3ae5 in sendEvent (event=0x7fff1a6ba030, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0xa911b0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f2d4ded3f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f2d4a2d1c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f2d4a2d1f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f2d4a2d1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f2d4ded4c57 in QEventDispatcherGlib::processEvents (this=0xa97260, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f2d4de793e2 in QEventLoop::exec (this=this@entry=0x7fff1a6ba280, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f2d4de8102c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f2d4e6a231c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f2d4ec637a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040ef5b in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:55

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-02 23:51:19 UTC

*** This bug has been marked as a duplicate of bug 345675 ***