Bug 347464 - systemsettings segmentation fault when installing/applying window decorations
Summary: systemsettings segmentation fault when installing/applying window decorations
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-09 11:41 UTC by flowwolf
Modified: 2015-05-09 19:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description flowwolf 2015-05-09 11:41:32 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.6-031906-lowlatency x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
I was installing window decorations and when I closed the decoration installation window system settings crashed.
I can reproduce this bug every time.
The following themes were installed: Air-black, airglass-black-deco, chrome, FormaN, glowglass-deco, PlasmaNext-windowdecoration-ideas, transparent-oxygen-deco.
If I remove some of the themes from '~/.local/share/aurorae/themes/' systemsettings won't crash. 3 or 4 themes don't cause system settings to crash, but 7 or more.
However, the whole system freezed completely when tried to apply the chrome theme. Only 3 themes were installed that time. The theme were automatically applied at restart.

'lspci | grep vga' gives nothing, no discrete graphics card installed
'lspci -vnn | grep -i VGA'
 00:02.0 VGA compatible controller [0300]: Intel Corporation 82Q33 Express Integrated Graphics Controller [8086:29d2] (rev 02) (prog-if 00 [VGA controller])

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb237c3b780 (LWP 1969))]

Thread 4 (Thread 0x7fb227250700 (LWP 1970)):
#0  0x00007fb2343ae8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb2326c8b72 in  () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fb2326ca64f in xcb_wait_for_event () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fb22979b099 in  () at /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so
#4  0x00007fb234a2fb0e in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fb2315e26aa in start_thread (arg=0x7fb227250700) at pthread_create.c:333
#6  0x00007fb2343b9eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fb216af0700 (LWP 1972)):
#0  0x00007ffc31bf2c66 in clock_gettime ()
#1  0x00007fb2343c838d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007fb234ae5cb6 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007fb234cc4639 in QTimerInfoList::updateCurrentTime() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007fb234cc4ba5 in QTimerInfoList::timerWait(timespec&) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fb234cc603e in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fb2310c33fd in g_main_context_prepare (context=context@entry=0x7fb210000990, priority=priority@entry=0x7fb216aefce0) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3410
#7  0x00007fb2310c3de8 in g_main_context_iterate (context=context@entry=0x7fb210000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3788
#8  0x00007fb2310c3fcc in g_main_context_iteration (context=0x7fb210000990, may_block=1) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3869
#9  0x00007fb234cc6c6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007fb234c6b3e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007fb234a2ab44 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007fb2339f5f65 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#13 0x00007fb234a2fb0e in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007fb2315e26aa in start_thread (arg=0x7fb216af0700) at pthread_create.c:333
#15 0x00007fb2343b9eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fb20f5f8700 (LWP 1973)):
#0  0x00007fb2343ae8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb2310c3ebc in g_main_context_iterate (priority=2147483647, n_fds=1, fds=0x7fb208002e70, timeout=-1, context=0x7fb208000990) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:4103
#2  0x00007fb2310c3ebc in g_main_context_iterate (context=context@entry=0x7fb208000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3803
#3  0x00007fb2310c3fcc in g_main_context_iteration (context=0x7fb208000990, may_block=1) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3869
#4  0x00007fb234cc6c6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fb234c6b3e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fb234a2ab44 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fb2339f5f65 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007fb234a2fb0e in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007fb2315e26aa in start_thread (arg=0x7fb20f5f8700) at pthread_create.c:333
#10 0x00007fb2343b9eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fb237c3b780 (LWP 1969)):
[KCrash Handler]
#6  0x0000006500000065 in  ()
#7  0x00007fb23347a628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fb233479d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fb21551ac9a in  () at /usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/plasma/core/libcorebindingsplugin.so
#10 0x00007fb2334cd4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fb2334ce4cb in QQuickWindowPrivate::updateDirtyNodes() () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fb2334ced80 in QQuickWindowPrivate::syncSceneGraph() () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fb23349df05 in  () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fb23349e979 in  () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fb235a59b2c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#16 0x00007fb235a5f000 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#17 0x00007fb234c6dc2b in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#18 0x00007fb234cc5ae5 in QTimerInfoList::activateTimers() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#19 0x00007fb234cc5f61 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007fb2310c3c3d in g_main_context_dispatch (context=0x7fb2200016f0) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3122
#21 0x00007fb2310c3c3d in g_main_context_dispatch (context=context@entry=0x7fb2200016f0) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3737
#22 0x00007fb2310c3f20 in g_main_context_iterate (context=context@entry=0x7fb2200016f0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3808
#23 0x00007fb2310c3fcc in g_main_context_iteration (context=0x7fb2200016f0, may_block=1) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3869
#24 0x00007fb234cc6c57 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#25 0x00007fb234c6b3e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007fb234c7302c in QCoreApplication::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x000000000040eebc in main ()

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-09 19:12:47 UTC

*** This bug has been marked as a duplicate of bug 345675 ***