Bug 360601

Summary: [INTEL] Various issues caused by buggy Intel drivers.
Product: krita Reporter: Dimi <dimimiha>
Component: OpenGL CanvasAssignee: Krita Bugs <krita-bugs-null>
Status: RESOLVED FIXED    
Severity: major CC: 1spag00ter, akiyamka, alexstudyvin, ali.capron.artist, alvin, annateather, archtan11, artvluster, Arzamol5, ashu.dada, atkitty2388, brandonrobinson105, choco333, claspectresource, dharokaston, dhisturbo, dimimiha, edangros, elbrough, elfiethedonutqueen, elliotuk2014, ernestotrejo2010, estebandawson08, fvig2001, garbi75, gchen94555, griffinvalley, gundemaro5, halla, hernandezzugeilys, heybruh1212333, huang_marcella, ivanx507, jonna.hanhisuanto, jrod8902, k.regel, Kate.fregoso10, killebrew34, lamentisimo, lithingwolf, lukas.boersma, m3mataei, madie.weirdo, malchowta, marianewell141, moonrise11, mrs.elizabeth.may, mymail2017, perry.t.jackson, pottsbavim, precioustheamazing, rainbowgiraffe46, rankfall15, reereefeefee, robertogiamp, sandyponce_06, scottpetrovic, sierranikim777, silent.soldier, sinkuupump, Smac_Art, t.s.o.mcd, taylorlocket0asters, temperaterenegade, thomasazalea, tinor, toastzombie18, trailton, truegadgetmaker, vampdawn23, vixipereo, vortexthewolf, wafflekidii2002, wb0ncp, windchimes098, wwwhalocraft, yo.chan, zulmaguasch
Priority: NOR    
Version: 3.0 Alpha   
Target Milestone: ---   
Platform: Microsoft Windows   
OS: Microsoft Windows   
Latest Commit: Version Fixed In: 3.3.0-rc.1

Description Dimi 2016-03-16 12:29:40 UTC
Krita version: krita3-prealpha3-9694dac

The canvas doesn't update when OpenGL is activated. It only shows the changes if I do something that forces it to redraw the canvas, like changing the windows size or activating wrap around mode. It's difficult to use Krita for animation without the OpenGL features. I also frequently use the wraparound mode, so deactivating OpenGL is a bad workaround.

I'm on Windows 10 and my gpu is an Intel HD 3000. I tried using all the drivers available, from old ones to the latest and even unofficial ones. It doesn't make a difference.

The last Krita version that behaved as expected was krita_2.9.10.1ae_beta_x64. 

Reproducible: Always

Steps to Reproduce:
1.Activate OpenGL
2.try to draw on canvas

Actual Results:  
Canvas doesn't update.

Expected Results:  
Normal behavior.

Windows 10
Intel HD 3000
Tried every driver available.
Comment 1 wolthera 2016-03-16 14:07:21 UTC
Thank you for the report, this might have to wait for the same fix that OSX is waiting for...
Comment 2 Dimi 2016-03-16 14:11:57 UTC
Sure, no problem. Since I've read somewhere that it could be a driver problem, I tried to test every driver available to my configuration, but I guess it's not that simple...
Comment 3 Halla Rempt 2016-03-16 17:51:56 UTC
Hm, I don't think this is the problem where Intel drivers need to be explicitly told to enable deprecated functions, because that gives a completely black screen & should be fixed in the 3rd pre-alpha build.
Comment 4 Dimi 2016-04-19 20:14:31 UTC
This is issue still persists in the most recent version.
Comment 5 Dimi 2016-04-19 22:09:16 UTC
Just discovered that the latest 32 bit version works as expected on my 64 bit OS.
Comment 6 Scott Petrovic 2016-05-07 15:49:28 UTC
Do the latest builds of the 64-bit version work. There have been some fixes with OpenGL and input that have happened since your last message. It may have resolved this issue.
Comment 7 Dimi 2016-05-09 19:48:53 UTC
(In reply to Scott Petrovic from comment #6)
> Do the latest builds of the 64-bit version work. There have been some fixes
> with OpenGL and input that have happened since your last message. It may
> have resolved this issue.

Just tried with the latest version and it's the same. 64 bit version doesn't work with OpenGL turned on. 32 bit works as expected.
Comment 8 sinkuupump 2016-05-22 02:06:45 UTC
https://www.kickstarter.com/projects/krita/krita-2016-lets-make-text-and-vector-art-awesome/posts/1582415
This problem still occurs with the latest x64 build on my Windows10 machine.

# krita-opengl.txt
Intel, Intel(R) HD Graphics 3000, 3.1.0 - Build 9.17.10.4229
Comment 9 Scott Petrovic 2016-05-22 11:28:39 UTC
I am not sure I'd this helps, but I know Windows 10 doesn't support older Intel HD cards. In other words, Intel doesn't have drivers for that card on Windows 10. This is the case with my Intel HD card.  I also get the canvas not updating.The problem goes away on Windows 7, at least for mine
Comment 10 Halla Rempt 2016-05-22 13:31:23 UTC
Ah... If that's the case, then there's nothing we can do. I guess the only possible solution is to use the 32 bits builds, because those can work with the 32 bits drivers that might still be available.
Comment 11 Halla Rempt 2017-04-14 18:29:46 UTC
*** Bug 375295 has been marked as a duplicate of this bug. ***
Comment 12 Halla Rempt 2017-04-14 18:31:00 UTC
*** Bug 360725 has been marked as a duplicate of this bug. ***
Comment 13 Halla Rempt 2017-04-14 18:32:25 UTC
*** Bug 378485 has been marked as a duplicate of this bug. ***
Comment 14 Halla Rempt 2017-04-14 18:32:44 UTC
*** Bug 378129 has been marked as a duplicate of this bug. ***
Comment 15 Halla Rempt 2017-04-14 18:33:42 UTC
*** Bug 378049 has been marked as a duplicate of this bug. ***
Comment 16 Halla Rempt 2017-04-14 18:35:29 UTC
*** Bug 378048 has been marked as a duplicate of this bug. ***
Comment 17 Halla Rempt 2017-04-14 18:35:54 UTC
*** Bug 377793 has been marked as a duplicate of this bug. ***
Comment 18 Halla Rempt 2017-04-14 18:36:20 UTC
*** Bug 377785 has been marked as a duplicate of this bug. ***
Comment 19 Halla Rempt 2017-04-14 18:37:12 UTC
*** Bug 377780 has been marked as a duplicate of this bug. ***
Comment 20 Halla Rempt 2017-04-14 18:39:24 UTC
*** Bug 374267 has been marked as a duplicate of this bug. ***
Comment 21 Halla Rempt 2017-04-14 18:39:47 UTC
*** Bug 374126 has been marked as a duplicate of this bug. ***
Comment 22 Halla Rempt 2017-04-14 18:42:07 UTC
*** Bug 374122 has been marked as a duplicate of this bug. ***
Comment 23 Halla Rempt 2017-04-14 18:43:03 UTC
*** Bug 372735 has been marked as a duplicate of this bug. ***
Comment 24 Halla Rempt 2017-04-14 18:44:31 UTC
*** Bug 368363 has been marked as a duplicate of this bug. ***
Comment 25 Halla Rempt 2017-04-14 18:46:14 UTC
*** Bug 363822 has been marked as a duplicate of this bug. ***
Comment 26 Halla Rempt 2017-04-14 18:46:50 UTC
Let's reopen for now, because this is the head bug for task https://phabricator.kde.org/T5883
Comment 27 Halla Rempt 2017-04-14 18:48:43 UTC
*** Bug 360723 has been marked as a duplicate of this bug. ***
Comment 28 Halla Rempt 2017-04-14 18:49:34 UTC
*** Bug 358376 has been marked as a duplicate of this bug. ***
Comment 29 Halla Rempt 2017-04-14 18:50:23 UTC
*** Bug 358160 has been marked as a duplicate of this bug. ***
Comment 30 Halla Rempt 2017-04-17 08:50:02 UTC
*** Bug 378859 has been marked as a duplicate of this bug. ***
Comment 31 Halla Rempt 2017-04-18 11:09:53 UTC
*** Bug 378916 has been marked as a duplicate of this bug. ***
Comment 32 Halla Rempt 2017-04-18 13:48:48 UTC
*** Bug 378721 has been marked as a duplicate of this bug. ***
Comment 33 Halla Rempt 2017-04-30 18:41:44 UTC
*** Bug 379383 has been marked as a duplicate of this bug. ***
Comment 34 Halla Rempt 2017-05-09 09:58:28 UTC
*** Bug 379657 has been marked as a duplicate of this bug. ***
Comment 35 Halla Rempt 2017-05-09 09:58:31 UTC
*** Bug 379650 has been marked as a duplicate of this bug. ***
Comment 36 Halla Rempt 2017-05-15 07:04:22 UTC
*** Bug 379829 has been marked as a duplicate of this bug. ***
Comment 37 Halla Rempt 2017-05-22 17:35:04 UTC
*** Bug 380093 has been marked as a duplicate of this bug. ***
Comment 38 Halla Rempt 2017-05-25 11:13:52 UTC
*** Bug 380173 has been marked as a duplicate of this bug. ***
Comment 39 Halla Rempt 2017-06-04 12:01:37 UTC
*** Bug 380811 has been marked as a duplicate of this bug. ***
Comment 40 Halla Rempt 2017-06-05 07:18:22 UTC
*** Bug 380447 has been marked as a duplicate of this bug. ***
Comment 41 Halla Rempt 2017-06-05 11:44:54 UTC
*** Bug 380418 has been marked as a duplicate of this bug. ***
Comment 42 Halla Rempt 2017-06-06 09:32:42 UTC
*** Bug 379061 has been marked as a duplicate of this bug. ***
Comment 43 Halla Rempt 2017-06-16 08:28:28 UTC
*** Bug 381251 has been marked as a duplicate of this bug. ***
Comment 44 Halla Rempt 2017-06-21 21:02:50 UTC
*** Bug 381504 has been marked as a duplicate of this bug. ***
Comment 45 Halla Rempt 2017-06-24 07:47:53 UTC
*** Bug 381588 has been marked as a duplicate of this bug. ***
Comment 46 Halla Rempt 2017-06-28 16:33:07 UTC
*** Bug 381260 has been marked as a duplicate of this bug. ***
Comment 47 Halla Rempt 2017-07-20 08:14:04 UTC
*** Bug 382529 has been marked as a duplicate of this bug. ***
Comment 48 Halla Rempt 2017-08-13 13:18:52 UTC
*** Bug 383382 has been marked as a duplicate of this bug. ***
Comment 49 webaccounts 2017-08-13 13:22:50 UTC
unsubscribe


Am 13.08.2017 um 15:18 schrieb Boudewijn Rempt:
> https://bugs.kde.org/show_bug.cgi?id=360601
> 
> Boudewijn Rempt <boud@valdyas.org> changed:
> 
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                   CC|                            |windchimes098@gmail.com
> 
> --- Comment #48 from Boudewijn Rempt <boud@valdyas.org> ---
> *** Bug 383382 has been marked as a duplicate of this bug. ***
>
Comment 50 Halla Rempt 2017-08-25 16:03:59 UTC
*** Bug 384012 has been marked as a duplicate of this bug. ***
Comment 51 Halla Rempt 2017-08-26 09:38:25 UTC
We've got a new test build that uses a different display technology on Windows, bypassing buggy drivers. Please help us by testing it and giving feedback in the survey:

https://krita.org/en/item/angle-and-windows-ink-a-new-test-version-of-krita-for-windows/
Comment 52 Alvin Wong 2017-08-27 06:47:40 UTC
*** Bug 384061 has been marked as a duplicate of this bug. ***
Comment 53 Alvin Wong 2017-08-27 07:00:10 UTC
*** Bug 384065 has been marked as a duplicate of this bug. ***
Comment 54 Halla Rempt 2017-08-27 13:30:23 UTC
*** Bug 384073 has been marked as a duplicate of this bug. ***
Comment 55 Alvin Wong 2017-09-02 06:39:46 UTC
*** Bug 384274 has been marked as a duplicate of this bug. ***
Comment 56 Alvin Wong 2017-09-10 17:23:55 UTC
Git commit 0b2344049c23c75809a4c55da667c18e2ed5c6a6 by Alvin Wong.
Committed on 10/09/2017 at 17:19.
Pushed by alvinwong into branch 'master'.

Merge branch 'alvin/T6696-opengl-angle'

This adds canvas rendering with Direct3D11 via ANGLE on Windows.

ANGLE is a library which translates OpenGL ES rendering functions to
other hardware rendering APIs, including Direct3D. It is supported by
the Windows build of Qt.

This aims to improve the compatibility of the OpenGL canvas with buggy
Windows Intel drivers by allowing the use of the Direct3D11 rendering
backend of ANGLE.

Krita can still be used with a Qt build without dynamic OpenGL support,
but it will only be able to use native desktop OpenGL. To enable ANGLE,
`ext_qt` will need to be rebuilt.

CCMAIL: kimageshop@kde.org
Maniphest Tasks: T5883, T6696, T6728


https://commits.kde.org/krita/0b2344049c23c75809a4c55da667c18e2ed5c6a6
Comment 57 Alvin Wong 2017-09-11 13:07:10 UTC
*** Bug 384592 has been marked as a duplicate of this bug. ***
Comment 58 Alvin Wong 2017-09-12 13:20:50 UTC
Git commit 5bcb3b2dbb78108caed24a5b311e73e4c389b95b by Alvin Wong.
Committed on 12/09/2017 at 13:14.
Pushed by alvinwong into branch 'krita/3.3'.

Merge branch 'alvin/T6976-angle-3.3' into krita/3.3

This adds canvas rendering with Direct3D11 via ANGLE on Windows.

ANGLE is a library which translates OpenGL ES rendering functions to
other hardware rendering APIs, including Direct3D. It is supported by
the Windows build of Qt.

This aims to improve the compatibility of the OpenGL canvas with buggy
Windows Intel drivers by allowing the use of the Direct3D11 rendering
backend of ANGLE.

Krita can still be used with a Qt build without dynamic OpenGL support,
but it will only be able to use native desktop OpenGL. To enable ANGLE,
`ext_qt` will need to be rebuilt. `ext_qt` target on Windows is also
upgraded to Qt 5.9.1, and to build it with ANGLE properly one would need
to use mingw-w64 7.1 and have Windows 10 SDK installed.

CCMAIL: kimageshop@kde.org
Maniphest Tasks: T5883, T6696, T6728, T6976


https://commits.kde.org/krita/5bcb3b2dbb78108caed24a5b311e73e4c389b95b
Comment 59 Halla Rempt 2017-09-14 07:20:39 UTC
*** Bug 384683 has been marked as a duplicate of this bug. ***
Comment 60 Halla Rempt 2017-09-14 07:21:37 UTC
*** Bug 384684 has been marked as a duplicate of this bug. ***
Comment 61 Halla Rempt 2017-09-14 07:21:58 UTC
*** Bug 384685 has been marked as a duplicate of this bug. ***
Comment 62 Halla Rempt 2017-09-14 07:22:28 UTC
*** Bug 384686 has been marked as a duplicate of this bug. ***
Comment 63 Halla Rempt 2017-09-14 07:25:15 UTC
*** Bug 384688 has been marked as a duplicate of this bug. ***
Comment 64 Alvin Wong 2017-09-17 06:04:59 UTC
*** Bug 384781 has been marked as a duplicate of this bug. ***
Comment 65 wolthera 2017-09-17 14:48:49 UTC
*** Bug 384795 has been marked as a duplicate of this bug. ***
Comment 66 EAHM 2017-09-17 21:52:29 UTC
ok so this is using angle.  The only issue I have seen is that the section of images doesnot go beyond the wraparound...

image:
http://elizabethmayadventures.weebly.com/uploads/1/0/1/4/101464084/screenshot-2017-09-17-16-46-50_orig.png
Comment 67 Alvin Wong 2017-09-18 16:08:51 UTC
Git commit 6dd9baf2eb17b7cb140e916a502ed7398e236582 by Alvin Wong.
Committed on 18/09/2017 at 16:07.
Pushed by alvinwong into branch 'krita/3.3'.

Filter specific Intel driver versions to prefer ANGLE

Known Intel driver builds between 4636 and 4729 (exclusive) exhibits the
GUI offset bug under OpenGL.

See https://communities.intel.com/thread/116003
Maniphest Tasks: T5883

M  +39   -4    libs/ui/opengl/kis_opengl.cpp

https://commits.kde.org/krita/6dd9baf2eb17b7cb140e916a502ed7398e236582
Comment 68 Alvin Wong 2017-09-18 16:08:51 UTC
Git commit 222ff9101eed0af2fe02a581b269b220cb625dce by Alvin Wong.
Committed on 18/09/2017 at 16:07.
Pushed by alvinwong into branch 'master'.

Filter specific Intel driver versions to prefer ANGLE

Known Intel driver builds between 4636 and 4729 (exclusive) exhibits the
GUI offset bug under OpenGL.

See https://communities.intel.com/thread/116003
Maniphest Tasks: T5883

M  +39   -4    libs/ui/opengl/kis_opengl.cpp

https://commits.kde.org/krita/222ff9101eed0af2fe02a581b269b220cb625dce
Comment 69 Alvin Wong 2017-09-21 16:31:40 UTC
*** Bug 384931 has been marked as a duplicate of this bug. ***
Comment 70 Alvin Wong 2017-09-21 16:35:45 UTC
Any issues related to Intel graphics on Windows should have been worked around in 3.3.0-rc.1: https://krita.org/en/item/krita-3-3-0-first-release-candidate/

If you encounter any other issues with Intel graphics with 3.3.0 or later, please open a new bug report and include the information found in Help->Show information for bug reports.
Comment 71 Halla Rempt 2017-09-27 07:09:05 UTC
*** Bug 385116 has been marked as a duplicate of this bug. ***
Comment 72 Halla Rempt 2017-09-27 07:10:49 UTC
*** Bug 385124 has been marked as a duplicate of this bug. ***
Comment 73 Halla Rempt 2017-09-27 11:51:08 UTC
*** Bug 385134 has been marked as a duplicate of this bug. ***
Comment 74 Halla Rempt 2017-10-05 15:59:31 UTC
*** Bug 385403 has been marked as a duplicate of this bug. ***
Comment 75 Halla Rempt 2017-10-11 07:29:14 UTC
*** Bug 385568 has been marked as a duplicate of this bug. ***
Comment 76 Halla Rempt 2017-10-24 07:11:40 UTC
*** Bug 386131 has been marked as a duplicate of this bug. ***
Comment 77 Halla Rempt 2017-10-26 08:09:54 UTC
*** Bug 386189 has been marked as a duplicate of this bug. ***
Comment 78 Halla Rempt 2017-10-31 08:40:23 UTC
*** Bug 386371 has been marked as a duplicate of this bug. ***
Comment 79 Halla Rempt 2017-11-09 08:14:45 UTC
*** Bug 386667 has been marked as a duplicate of this bug. ***
Comment 80 Halla Rempt 2017-11-11 07:55:41 UTC
*** Bug 386733 has been marked as a duplicate of this bug. ***
Comment 81 Alvin Wong 2017-11-16 14:15:13 UTC
*** Bug 386970 has been marked as a duplicate of this bug. ***
Comment 82 Halla Rempt 2017-11-17 07:35:27 UTC
*** Bug 387003 has been marked as a duplicate of this bug. ***
Comment 83 Halla Rempt 2017-11-20 09:51:06 UTC
*** Bug 387138 has been marked as a duplicate of this bug. ***
Comment 84 Halla Rempt 2017-11-21 13:37:31 UTC
*** Bug 378382 has been marked as a duplicate of this bug. ***
Comment 85 Halla Rempt 2017-11-26 12:51:04 UTC
*** Bug 376682 has been marked as a duplicate of this bug. ***
Comment 86 Halla Rempt 2017-11-28 06:28:57 UTC
*** Bug 387381 has been marked as a duplicate of this bug. ***
Comment 87 Halla Rempt 2017-12-23 17:29:22 UTC
*** Bug 388176 has been marked as a duplicate of this bug. ***
Comment 88 Halla Rempt 2017-12-26 10:21:03 UTC
*** Bug 388231 has been marked as a duplicate of this bug. ***
Comment 89 Halla Rempt 2018-01-04 09:21:44 UTC
*** Bug 388512 has been marked as a duplicate of this bug. ***
Comment 90 Halla Rempt 2018-01-05 08:54:25 UTC
*** Bug 388546 has been marked as a duplicate of this bug. ***
Comment 91 Halla Rempt 2018-01-07 09:14:41 UTC
*** Bug 388634 has been marked as a duplicate of this bug. ***
Comment 92 Halla Rempt 2018-01-10 22:15:39 UTC
*** Bug 388797 has been marked as a duplicate of this bug. ***
Comment 93 Halla Rempt 2018-01-17 09:40:52 UTC
*** Bug 389089 has been marked as a duplicate of this bug. ***
Comment 94 Halla Rempt 2018-02-11 12:05:26 UTC
*** Bug 390242 has been marked as a duplicate of this bug. ***