Bug 379657 - Creating new canvas makes Krita crash
Summary: Creating new canvas makes Krita crash
Status: RESOLVED DUPLICATE of bug 360601
Alias: None
Product: krita
Classification: Unclassified
Component: OpenGL Canvas (show other bugs)
Version: unspecified
Platform: Microsoft Windows Microsoft Windows
: NOR critical
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-09 09:24 UTC by moonrise11
Modified: 2017-05-12 11:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
A backtrace of crashes (19.14 KB, text/plain)
2017-05-09 09:24 UTC, moonrise11
Details

Note You need to log in before you can comment on or make changes to this bug.
Description moonrise11 2017-05-09 09:24:07 UTC
Created attachment 105415 [details]
A backtrace of crashes

I used various versions of Krita and this crash appeared on all of them (even on the newest version) for a year or more. If I have OpenGL enabled and try to create new Canvas, the program crashes. There isn't any problem when I open already existing file.
Comment 1 Halla Rempt 2017-05-09 09:52:23 UTC
See  https://docs.krita.org/KritaFAQ#Krita_starts_with_a_black_or_blank_canvas_and_nothing_changes_when_you_try_to_draw.2Fshows_a_black_or_blank_screen_on_my_Windows_system_with_an_Intel_GPU -- please update your intel display driver. You have version 10.18.10.3574, current versions start with 15.
Comment 2 Halla Rempt 2017-05-09 09:58:28 UTC

*** This bug has been marked as a duplicate of bug 360601 ***
Comment 3 MichalG 2017-05-12 11:14:00 UTC
With latest version of Krita (pre-alpha 4.0) it started working again (without OpenGL). Oh yeah so far so good! :D
It was downloaded from:
https://ci.appveyor.com/project/alvinhochun/krita-packaging/build/artifacts