Bug 360725 - [INTEL] Krita crashes when I click OK to close the preference window
Summary: [INTEL] Krita crashes when I click OK to close the preference window
Status: RESOLVED DUPLICATE of bug 360601
Alias: None
Product: krita
Classification: Unclassified
Component: OpenGL Canvas (show other bugs)
Version: 3.0 Alpha
Platform: Microsoft Windows Microsoft Windows
: NOR crash
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-19 05:34 UTC by tokiedian
Modified: 2017-04-14 18:31 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
what is written in the crush dump of this crush by WER analyzed by AppCrashView (37.26 KB, text/plain)
2016-04-27 17:11 UTC, tokiedian
Details
its wer file (73.65 KB, application/octet-stream)
2016-04-27 17:15 UTC, tokiedian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tokiedian 2016-03-19 05:34:52 UTC
Krita crashes when I click OK to close the preference while it has any document on my PC which has intel graphics (CPU: Intel core i5-3230m, No GPU)

Reproducible: Always

Steps to Reproduce:
1. Use Krita pre on computer which uses Intel graphics
2. Enable OpenGL on the preference window and click ok to close it
3. Open or Create a document
4. Setting>Configure Krita and open the preference window
5. click "OK" to close the window

Actual Results:  
Krita crashes

Expected Results:  
The preference window is closed

When krita crashes in this way, debugview shows any lines. 
Your configuration just before the crash is applied when you reboot krita after the crash.
Comment 1 omiya 2016-03-19 16:44:45 UTC
Reproduced on Krita 3.0 Pre-alpha 3 appimage running on openSUSE 42.1. I use Celeron G1610 with HD Graphics.
Comment 2 Halla Rempt 2016-03-19 19:08:39 UTC
Hi,

I cannot reproduce this on my sp3, so I'm beginning to suspect that this might be another issue with Krita and Japanese Windows....
Comment 3 Halla Rempt 2016-03-22 15:03:04 UTC
Hi Jumpei, do you also have a version of Krita build from source running on opensuse where you can reproduce the issue? If so, could you attach a backtrace?
Comment 4 omiya 2016-03-23 14:24:53 UTC
Sorry but I misread the steps tokiedian wrote; In my case Krita crashes if I turn on OpenGL when a document is opened, but it doesn't if OpenGL has been enabled before opening a document.

Boudewijn: I haven't built it from the source yet, but I think I'll take a look at it.
Comment 5 omiya 2016-04-02 10:49:05 UTC
I'd report that the crash became irreproducible after I applied driver update in order to build Krita from the source.. (sorry for confusion)
Comment 6 Halla Rempt 2016-04-02 11:12:56 UTC
Okay, thanks!
Comment 7 tokiedian 2016-04-11 10:20:45 UTC
I confirmed this bug still occurs in 2.99.89
Comment 8 Halla Rempt 2016-04-15 06:34:12 UTC
Could you please also try with this experimental build?

http://valdyas.org/~boud/krita-3.0-Alpha-master-d236382-x64.zip

It must be some interaction between a Japanese version of Windows and our code, but I cannot figure it out. Maybe this build made with a different compiler circumvents the issue...
Comment 9 tokiedian 2016-04-16 01:58:10 UTC
I confirmed the bug doesn't happen in this build!
Comment 10 Halla Rempt 2016-04-16 06:44:56 UTC
Great!
Comment 11 tokiedian 2016-04-23 19:42:59 UTC
I found this bug still occurs on 3.0 alpha git 5bd8323 for Win 64 bit.
And could you tell me how to use a debug build for Win? I can't find any debugging information when I use it.
Comment 12 tokiedian 2016-04-24 22:10:21 UTC
On investigation, I found this bug is reproduced not on Win 7 but on Win 8.1...
Comment 13 tokiedian 2016-04-27 17:11:36 UTC
Created attachment 98644 [details]
what is written in the crush dump of this crush by WER analyzed by AppCrashView

I succeeded to get a code of crush dump of this bug by Windows Error Reporting with AppCrashView: http://www.nirsoft.net/utils/app_crash_view.html
It could be a help for this bug...
Comment 14 tokiedian 2016-04-27 17:15:03 UTC
Created attachment 98645 [details]
its wer file

I also add the raw wer file...
Comment 15 tokiedian 2016-04-29 05:36:02 UTC
Ah... I found the reason why this crush happens on my computer: I used Intel® HD Graphics Driver Ver.10.18.10.3621 provided by FUJITSU, which hasn't updated it since 2014/06/24. I downloaded the latest version from Intel official, update it manually and the crush won't happen...

Holly f**k FUJITSU.
Comment 16 Halla Rempt 2017-04-14 18:31:00 UTC

*** This bug has been marked as a duplicate of bug 360601 ***