Bug 379650 - Krita seriously crashes in latest stable version (WIN10 PRO)
Summary: Krita seriously crashes in latest stable version (WIN10 PRO)
Status: RESOLVED DUPLICATE of bug 360601
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: 3.1.3
Platform: Microsoft Windows Microsoft Windows
: NOR crash
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-09 07:55 UTC by MichalG
Modified: 2017-05-09 13:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MichalG 2017-05-09 07:55:20 UTC
This is a crash log that has happened since last alpha/beta/stable versions of KRITA 3.1.3 on one of my WINDOWS systems (WIN10 64-bit with INTEL gfx-card that has latest drivers installed):


"Error occurred on Tuesday, May 9, 2017 at 09:27:25.

krita.exe caused an Access Violation at location 00007FFF4A6D5FE0 in module libkritaimage.dll Reading from location FFFFFFFF9142EF20.

AddrPC           Params
00007FFF4A6D5FE0 0000000000000000 00007FFF4A6D60D6 00000000006819C0  libkritaimage.dll!cblas_xerbla
00007FFF4A6D417A 0000000000000000 0000000000000000 00000000006819C0  libkritaimage.dll!cblas_xerbla
00007FFF4A6D4A05 0000000002D82301 0000000000000001 00000000A5EDF8A0  libkritaimage.dll!cblas_xerbla
00007FFF4A811856 0000000000000000 0000000080000000 00000000A5EDF8A0  libkritaimage.dll!operator+=<QStringBuilder<QString, char [5]>, QString>
00007FFF4A544C4C 0000000000000001 00000000A5B76F10 00000000A5B76F30  libkritaimage.dll!KisUpdateTimeMonitor::instance
00007FFF4A554331 00000000A5F9ECB1 00000000688990A7 00000000A603F640  libkritaimage.dll!KisImage::notifyProjectionUpdated
0000000068A2EBCA 00000000A5D01A08 000000006889D51A 0000000000000000  Qt5Core.dll!QMetaObject::activate
00007FFF4A662D90 0000000000000010 00000000A704FDD0 00000000A603F640  libkritaimage.dll!KisUpdaterContext::qt_static_metacall
0000000068A2EBCA 00000000A5B76190 00000000000000F0 0000000000000003  Qt5Core.dll!QMetaObject::activate
00007FFF4A6FE905 0000000000000000 0000000068B4E4DC 0000000000000010  libkritaimage.dll!KisUpdateJobItem::run
000000006889BEC9 00000000A603F5E0 00000000A5B78110 000000000A6E7280  Qt5Core.dll!QThreadPoolPrivate::startThread
000000006889DB6C 00000000031FEA70 0000000000000000 0000000000000000  Qt5Core.dll!QThread::setTerminationEnabled
00007FFF768BB2BA 00007FFF76910670 000000000A6E7280 0000000000000000  msvcrt.dll!_beginthreadex
00007FFF768BB38C 0000000000000000 0000000000000000 0000000000000000  msvcrt.dll!_endthreadex
00007FFF76A38364 0000000000000000 0000000000000000 0000000000000000  KERNEL32.DLL!BaseThreadInitThunk
00007FFF77A270D1 0000000000000000 0000000000000000 0000000000000000  ntdll.dll!RtlUserThreadStart

krita.exe
ntdll.dll   	6.2.14393.479
KERNEL32.DLL	6.2.14393.0
KERNELBASE.dll	6.2.14393.1066
apphelp.dll 	6.2.14393.0
msvcrt.dll  	7.0.14393.0
libkritaui.dll
libkritawidgetutils.dll
libKF5I18n.dll
Qt5Core.dll 	5.6.1.0
Qt5Gui.dll  	5.6.1.0
Qt5Widgets.dll	5.6.1.0
ADVAPI32.dll	6.2.14393.0
USER32.dll  	6.2.14393.576
sechost.dll 	6.2.14393.0
win32u.dll  	6.2.14393.51
RPCRT4.dll  	6.2.14393.82
GDI32.dll   	6.2.14393.206
ole32.dll   	6.2.14393.1066
gdi32full.dll	6.2.14393.1066
combase.dll 	6.2.14393.953
ucrtbase.dll	6.2.14393.0
libkritaglobal.dll
bcryptPrimitives.dll	6.2.14393.0
libkritaplugin.dll
SHELL32.dll 	6.2.14393.1066
cfgmgr32.dll	6.2.14393.0
windows.storage.dll	6.2.14393.1066
libKF5ConfigCore.dll
powrprof.dll	6.2.14393.0
libKF5ConfigGui.dll
libKF5CoreAddons.dll
shlwapi.dll 	6.2.14393.0
kernel.appcore.dll	6.2.14393.0
shcore.dll  	6.2.14393.953
profapi.dll 	6.2.14393.0
WS2_32.dll  	6.2.14393.206
libKF5GuiAddons.dll
libKF5ItemViews.dll
libKF5WidgetsAddons.dll
libKF5WindowSystem.dll
Qt5PrintSupport.dll	5.6.1.0
Qt5Xml.dll  	5.6.1.0
libintl.DLL 	0.18.0.0
libkritacolor.dll
libkritaflake.dll
libkritaimage.dll
comdlg32.dll	6.2.14393.479
libkritalibbrush.dll
libkritaodf.dll
libkritapigment.dll
libkritapsd.dll
libkritastore.dll
libkritaundo2.dll
libkritaversion.dll
libkritawidgets.dll
libexiv2.dll
libKF5Completion.dll
PSAPI.DLL   	6.2.14393.0
Qt5Network.dll	5.6.1.0
Qt5Multimedia.dll	5.6.1.0
MPR.dll     	6.2.14393.0
libHalf.dll
libpng16.dll
OPENGL32.dll	6.2.14393.0
NETAPI32.dll	6.2.14393.0
USERENV.dll 	6.2.14393.0
iconv.dll
WINSPOOL.DRV	6.2.14393.953
Qt5Svg.dll  	5.6.1.0
COMCTL32.dll	5.82.14393.447
libfftw3-3.dll
Qt5Concurrent.dll	5.6.1.0
libKF5Archive.dll
libexpat.dll
libz.dll    	1.2.8.0
DNSAPI.dll  	6.2.14393.953
IPHLPAPI.DLL	6.2.14393.953
NSI.dll     	6.2.14393.0
GLU32.dll   	6.2.14393.0
DDRAW.dll   	6.2.14393.953
bcrypt.dll  	6.2.14393.576
NETUTILS.DLL	6.2.14393.0
DCIMAN32.dll	6.2.14393.0
LOGONCLI.DLL	6.2.14393.0
SAMCLI.DLL  	6.2.14393.0
IMM32.DLL   	6.2.14393.0
qwindows.dll	5.6.1.0
OLEAUT32.dll	6.2.14393.1066
msvcp_win.dll	6.2.14393.0
WINMM.dll   	6.2.14393.0
WINMMBASE.dll	6.2.14393.0
uxtheme.dll 	6.2.14393.0
dwmapi.dll  	6.2.14393.206
ig7icd64.dll	10.18.10.4425
igdusc64.dll	10.18.10.4425
WTSAPI32.dll	6.2.14393.0
kimg_exr.dll
libIlmImf.dll
libIex.dll
libIlmThread.dll
libImath.dll
kimg_kra.dll
kimg_ora.dll
kimg_pcx.dll
kimg_pic.dll
kimg_psd.dll
kimg_ras.dll
kimg_rgb.dll
kimg_tga.dll
kimg_xcf.dll
qdds.dll    	5.6.1.0
qgif.dll    	5.6.1.0
qicns.dll   	5.6.1.0
qico.dll    	5.6.1.0
qjpeg.dll   	5.6.1.0
qsvg.dll    	5.6.1.0
qtiff.dll   	5.6.1.0
qwbmp.dll   	5.6.1.0
qwebp.dll   	5.6.1.0
MSCTF.dll   	6.2.14393.953
clbcatq.dll 	2001.12.10941.16384
dataexchange.dll	6.2.14393.206
dcomp.dll   	6.2.14393.0
d3d11.dll   	6.2.14393.953
dxgi.dll    	6.2.14393.953
twinapi.appcore.dll	6.2.14393.1066
exchndl.dll 	0.8.1.0
mgwhelp.dll 	0.8.1.0
VERSION.dll 	6.2.14393.0
dbghelp.dll 	6.3.9600.17298
wintab32.dll	1.0.5.8
CRYPTBASE.DLL	6.2.14393.0
Wacom_Tablet.dll	6.3.17.3
PROPSYS.dll 	7.0.14393.0
LINKINFO.dll	6.2.14393.0
kritalcmsengine.dll
liblcms2.dll
krita_colorspaces_extensions.dll
kritachalkpaintop.dll
libkritalibpaintop.dll
kritacolorsmudgepaintop.dll
kritacurvepaintop.dll
kritadefaultpaintops.dll
kritadeformpaintop.dll
kritadynapaintop.dll
kritaexperimentpaintop.dll
kritafilterop.dll
kritagridpaintop.dll
kritahairypaintop.dll
kritahatchingpaintop.dll
kritaparticlepaintop.dll
kritaroundmarkerpaintop.dll
kritasketchpaintop.dll
kritaspraypaintop.dll
kritatangentnormalpaintop.dll
kritablurfilter.dll
kritacolorsfilters.dll
kritaconvolutionfilters.dll
kritadodgeburn.dll
kritaembossfilter.dll
kritaexample.dll
kritaextensioncolorsfilters.dll
kritafastcolortransferfilter.dll
kritagradientmap.dll
kritahalftone.dll
kritaimageenhancement.dll
kritaindexcolors.dll
kritalevelfilter.dll
kritanoisefilter.dll
kritanormalize.dll
kritaoilpaintfilter.dll
kritaphongbumpmap.dll
kritapixelizefilter.dll
kritaposterize.dll
kritaraindropsfilter.dll
kritarandompickfilter.dll
kritaroundcornersfilter.dll
kritasmalltilesfilter.dll
kritasobelfilter.dll
kritathreshold.dll
kritaunsharpfilter.dll
kritawavefilter.dll
SspiCli.dll 	6.2.14393.576
krita_shape_text.dll
libkritatextlayout.dll
libkritatext.dll
krita_flaketools.dll
krita_karbontools.dll
krita_tool_basicflakes.dll
libkritabasicflakes.dll
krita_shape_vector.dll
libkritavectorimage.dll
krita_shape_artistictext.dll
krita_shape_paths.dll
kritacolorgenerator.dll
kritapatterngenerator.dll
kritadefaulttools.dll
libboost_system-mgw51-mt-1_61.dll
kritarulerassistanttool.dll
kritaselectiontools.dll
kritatoolcrop.dll
kritatooldyna.dll
kritatoollazybrush.dll
kritatoolpolygon.dll
kritatoolpolyline.dll
kritatooltext.dll
kritatooltransform.dll
kritaanimationdocker.dll
krita_docker_defaults.dll
kritaartisticcolorselector.dll
kritachanneldocker.dll
kritacolorselectorng.dll
qsvgicon.dll	5.6.1.0
kritacolorslider.dll
kritacompositiondocker.dll
kritadefaultdockers.dll
kritadigitalmixer.dll
kritagriddocker.dll
kritahistogramdocker.dll
kritahistorydocker.dll
kritaimagedocker.dll
kritalutdocker.dll
libOpenColorIO.dll
kritaoverviewdocker.dll
kritapalettedocker.dll
kritapatterndocker.dll
kritapresetdocker.dll
kritapresethistory.dll
kritasmallcolorselector.dll
kritaspecificcolorselector.dll
kritatasksetdocker.dll
edputil.dll 	6.2.14393.0
kritaanimationrenderer.dll
kritaclonesarray.dll
kritacolorrange.dll
kritacolorspaceconversion.dll
kritagmic.dll
libgomp_64-1.dll
kritahistogram.dll
kritaimagesize.dll
kritaimagesplit.dll
kritalayergroupswitcher.dll
kritalayersplit.dll
kritametadataeditor.dll
kritamodifyselection.dll
kritaoffsetimage.dll
kritaresourcemanager.dll
kritarotateimage.dll
kritaseparatechannels.dll
kritashearimage.dll
kritawaveletdecompose.dll
WININET.dll 	11.0.14393.1066
iertutil.dll	11.0.14393.1066
ondemandconnroutehelper.dll	6.2.14393.351
winhttp.dll 	6.2.14393.953
mswsock.dll 	6.2.14393.0
WINNSI.DLL  	6.2.14393.0
urlmon.dll  	11.0.14393.1066
rasadhlp.dll	6.2.14393.0
fwpuclnt.dll	6.2.14393.0

Windows 6.2.9200
DrMingw 0.8.1"
Comment 1 Halla Rempt 2017-05-09 08:14:13 UTC
Though the crash seems to be in a maths library, it's a very weird backtrace. I've seen this backtrace reported by one or two other people, but, of course, I don't experience it myself on any of my windows test systems.

Does it also crash if you disable opengl? And could you please tell me the exact version of the intel opengl driver -- check it in the Device Manager application, since that gives Intel's numbering, the settings system info gives Microsoft's numbering.
Comment 2 MichalG 2017-05-09 08:48:03 UTC
Of course Intel sucks at its drivers as on another computer at home I have Nvidia's 1060 and Krita works flawlessly.

As for INTEL drivers (which is the latest probably): x.x.x.4425 (Graphics) and 10.1.1.14 (Chipset). I cannot see OpenGL's version there.

It is WIN 10 64-bit, 4 GB RAM, i5-3470 @3.20 Ghz processor

When I disable OpenGL, Krita hangs(up) and there is no response from the program... :(
Comment 3 Halla Rempt 2017-05-09 09:58:31 UTC
I know now where to look in the crash log for the intel driver version. It's:

ig7icd64.dll	10.18.10.4425
igdusc64.dll	10.18.10.4425

Current drivers start with 15; so this is very likely the problem from this faq:
https://docs.krita.org/KritaFAQ#Krita_starts_with_a_black_or_blank_canvas_and_nothing_changes_when_you_try_to_draw.2Fshows_a_black_or_blank_screen_on_my_Windows_system_with_an_Intel_GPU

Please try to update your driver to the latest version.

*** This bug has been marked as a duplicate of bug 360601 ***
Comment 4 MichalG 2017-05-09 10:57:45 UTC
Well... I just can't update driver other than one that is latest. It said I have the newest driver. What can I do else?

The screenshot is here:
https://imagebin.ca/v/3LrdLaqNvSez
Comment 5 MichalG 2017-05-09 11:05:57 UTC
OK, I will try manually downloaded driver and reply here later...
Comment 6 Halla Rempt 2017-05-09 11:18:47 UTC
Um, that screenshot shows that it offers to download 15.33 for you?
Comment 7 Halla Rempt 2017-05-09 11:20:59 UTC
I'm actually going through the same utility and the same process on my old hd4000 laptop; that had the same driver you had, though for me, on that old thinkpad, no crashes were happening...
Comment 8 Halla Rempt 2017-05-09 11:22:14 UTC
Okay, even weirder... That 15.33 installer actually seems to install the 10.18 driver! I don't get Intel.
Comment 9 MichalG 2017-05-09 13:35:12 UTC
So... Drivers are updated (even manually), system was restarted, and then... Krita hangs-up after choosing selected canvas (when it is about to start after loading). 

Krita hangs-up no matter OpenGL is turned on or off. :(

Bad luck, I'm outta here...


P.S. Fortunately there are another machine with GTX1060 which 'likes' KRITA. :)