Bug 380447 - I am using Krita version 3.1.4, the problem is that when I draw on the canvas I can see the cursor but I can only see what I've drawn once I've clicked off of the canvas onto another area like the layers or the menu, it was working for quite a while befor
Summary: I am using Krita version 3.1.4, the problem is that when I draw on the canvas...
Status: RESOLVED DUPLICATE of bug 360601
Alias: None
Product: krita
Classification: Unclassified
Component: OpenGL Canvas (show other bugs)
Version: 3.1.4
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-02 03:55 UTC by M3
Modified: 2017-06-05 07:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
attachment-6765-0.html (2.75 KB, text/html)
2017-06-03 04:14 UTC, M3
Details

Note You need to log in before you can comment on or make changes to this bug.
Description M3 2017-06-02 03:55:47 UTC
I am using Krita version 3.1.4, the problem is that when I draw on the canvas I can see the cursor but I can only see what I've drawn once I've clicked off of the canvas onto another area like the layers or the menu, it was working for quite a while before this and now it isn't working. I am only having this problem on this program and not other drawing programs.
Comment 1 Halla Rempt 2017-06-02 09:31:09 UTC
Hi,

This is your problem, in all likelihood: 

https://docs.krita.org/KritaFAQ#Krita_starts_with_a_black_or_blank_canvas_and_nothing_changes_when_you_try_to_draw.2Fshows_a_black_or_blank_screen_on_my_Windows_system_with_an_Intel_GPU

We don't have access to a computer with a broken driver so we cannot make a workaround. Can you please tell us exactly which brand and model your computer is, which version of Windows, and if it's 10, whether you updated from Windows 7 and the version of the display driver.
Comment 2 M3 2017-06-03 04:14:49 UTC
Created attachment 105858 [details]
attachment-6765-0.html

it was my mistake that was an option for deactive opengl and when i
deactivated that it got fixed
thanks for you usefull application :)


M3

2017-06-02 14:01 GMT+04:30 Boudewijn Rempt <bugzilla_noreply@kde.org>:

> https://bugs.kde.org/show_bug.cgi?id=380447
>
> Boudewijn Rempt <boud@valdyas.org> changed:
>
>            What    |Removed                     |Added
> ------------------------------------------------------------
> ----------------
>              Status|UNCONFIRMED                 |NEEDSINFO
>                  CC|                            |boud@valdyas.org
>            Platform|Other                       |MS Windows
>           Component|Brush engine                |OpenGL Canvas
>                  OS|Windows CE                  |MS Windows
>          Resolution|---                         |WAITINGFORINFO
>
> --- Comment #1 from Boudewijn Rempt <boud@valdyas.org> ---
> Hi,
>
> This is your problem, in all likelihood:
>
> https://docs.krita.org/KritaFAQ#Krita_starts_with_a_
> black_or_blank_canvas_and_nothing_changes_when_you_try_
> to_draw.2Fshows_a_black_or_blank_screen_on_my_Windows_
> system_with_an_Intel_GPU
>
> We don't have access to a computer with a broken driver so we cannot make a
> workaround. Can you please tell us exactly which brand and model your
> computer
> is, which version of Windows, and if it's 10, whether you updated from
> Windows
> 7 and the version of the display driver.
>
> --
> You are receiving this mail because:
> You reported the bug.
Comment 3 Halla Rempt 2017-06-05 07:18:22 UTC
Hi,

Can you please still tell us exactly which brand and model your computer is, which version of Windows, and if it's 10, whether you updated from Windows 7 and the version of the display driver? We're trying to figure out whether there's a pattern, and whether it's possible to our hands on a known broken combination.

*** This bug has been marked as a duplicate of bug 360601 ***