Bug 378859 - crash on start - x64 on windows 7, intel HD 4000
Summary: crash on start - x64 on windows 7, intel HD 4000
Status: RESOLVED DUPLICATE of bug 360601
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: 3.1.2
Platform: Microsoft Windows Microsoft Windows
: NOR crash
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-17 06:04 UTC by webaccounts
Modified: 2017-04-17 08:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description webaccounts 2017-04-17 06:04:21 UTC
Current stable Krita 64 Windows crashes right on start without message on Win7-64 with all current updates.
Saw warning for intel igp on win10 on the website, so I configured nvidia gpu for krita.exe and this runs fine.

just updated the intel igp driver to 10.18.10.4425 from 04.04.2016, which seems to be the latest for HD 4000 gpu series. 
processor / gpu: http://ark.intel.com/products/65708


Windows Log:

Name der fehlerhaften Anwendung: krita.exe, Version: 0.0.0.0, Zeitstempel: 0x00000000
Name des fehlerhaften Moduls: ig7icd64.dll, Version: 10.18.10.4425, Zeitstempel: 0x5702a984
Ausnahmecode: 0xc0000005
Fehleroffset: 0x0000000000173f8a
ID des fehlerhaften Prozesses: 0x1378
Startzeit der fehlerhaften Anwendung: 0x01d2b6b90a5a7496
Pfad der fehlerhaften Anwendung: C:\Program Files\Krita (x64)\bin\krita.exe
Pfad des fehlerhaften Moduls: C:\Windows\system32\ig7icd64.dll
Berichtskennung: 481547b8-22ac-11e7-b592-00249b120919


is there a way to integrate a message (that does not use special gpu features) comming up in the first place, before starting the gpu-using krita? so the user can get the information that it´s probably the intel gpu´s fault, if krita does not start. for normal users it´s not obvious that there may be an option to configure the additional gpu.
Comment 1 Halla Rempt 2017-04-17 08:50:01 UTC
That message is present in 3.1.3-beta

You should also try to update your driver: the current driver is 15.33.43.4425.

We're collecting information about this issue in https://phabricator.kde.org/T5883, but it is a bug in Intel's driver code, not in Krita.

*** This bug has been marked as a duplicate of bug 360601 ***