Bug 368363 - OpenGL canvas remains blank with some driver/gpu combinations on Windows
Summary: OpenGL canvas remains blank with some driver/gpu combinations on Windows
Status: RESOLVED DUPLICATE of bug 360601
Alias: None
Product: krita
Classification: Unclassified
Component: OpenGL Canvas (show other bugs)
Version: 3.0.1 Beta
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
: 369015 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-06 22:59 UTC by ivan
Modified: 2017-04-25 12:41 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
blob.jpg (8.77 KB, image/png)
2017-04-15 03:08 UTC, Jeff H.
Details
blob.jpg (8.56 KB, image/png)
2017-04-15 03:08 UTC, Jeff H.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ivan 2016-09-06 22:59:16 UTC
Sometimes when i use krita the brush cursor dissapears and stops drawing, the only way that i can fix that was dissabling the opengl in the preferences.
The times when this happened was i change the brush or change a value in the brush settings.
I use Windows 8.1 and a intel integrated graphic, i don't now if this could affect in the canvas.


Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.Change the brush or a setting of the brush.


Actual Results:  
the canvas stop responding, i couldn't draw, or zoom etc.


Windows 8.1
x64
Intel HD Graphics.
ASUS X555lab
Comment 1 Jeff H. 2016-09-29 04:49:16 UTC
I have encountered this same bug. When attempting to draw with any brush on the canvas, the canvas does not update. When I change focus to a menu item or click the right mouse button, the canvas suddenly updates, showing all the strokes that were made.
Windows 10 on Intel I7 with 12GB RAM, NVIDIA Geforce GT540M w/1GB and Krita 3.0.1.1. This also occurred on the previous version of krita. Like the original poster, disabling OpenGL removes the problem.
Comment 2 Halla Rempt 2016-11-03 14:05:04 UTC
*** Bug 369015 has been marked as a duplicate of this bug. ***
Comment 3 Halla Rempt 2016-11-03 14:06:49 UTC
I've had several reports of this happening, mostly on systems with 2 graphics cards or intel video. It really seems to be dependent on the version of the video driver. There isn't much we can do: I haven't got a single test system where this happens :-(
Comment 4 Halla Rempt 2017-04-14 18:44:31 UTC
Can you please tell me the exact driver versoin and intel HD display chip version you have? We're trying to compile a list to see what's up.

*** This bug has been marked as a duplicate of bug 360601 ***
Comment 5 Jeff H. 2017-04-15 03:08:01 UTC
Created attachment 105028 [details]
blob.jpg

Here is the intel driver information but I have an NVIDIA GT540M on the system as well so I think that is what it should be using. Including the info for it as well. Thanks for following up on the bug and let me know if there's anything else I can provide to assist in identifying the problem.
Jeff H.



 

    On Friday, April 14, 2017 2:44 PM, Boudewijn Rempt <bugzilla_noreply@kde.org> wrote:
 

 https://bugs.kde.org/show_bug.cgi?id=368363

Boudewijn Rempt <boud@valdyas.org> changed:

          What    |Removed                    |Added
----------------------------------------------------------------------------
        Resolution|---                        |DUPLICATE
            Status|UNCONFIRMED                |RESOLVED

--- Comment #4 from Boudewijn Rempt <boud@valdyas.org> ---
Can you please tell me the exact driver versoin and intel HD display chip
version you have? We're trying to compile a list to see what's up.

*** This bug has been marked as a duplicate of bug 360601 ***
Comment 6 Jeff H. 2017-04-15 03:08:06 UTC
Created attachment 105029 [details]
blob.jpg
Comment 7 Halla Rempt 2017-04-25 12:41:34 UTC
Krita only uses the nvidia driver if you explicitly start it with that driver, using right-click on the executable, select display driver. At least, it's that way on my dual gpu device.

Your intel driver is indeed the outdated one with the know bug. Current is 15.something: https://downloadcenter.intel.com/product/81500/Intel-HD-Graphics-3000