Bug 363822 - krita doesn't display anything on the canvas until a few seconds after but the layer preview does.
Summary: krita doesn't display anything on the canvas until a few seconds after but th...
Status: RESOLVED DUPLICATE of bug 360601
Alias: None
Product: krita
Classification: Unclassified
Component: CPU Canvas (show other bugs)
Version: 3.0
Platform: Microsoft Windows Microsoft Windows
: NOR crash
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-02 00:38 UTC by pottsbavim
Modified: 2017-04-14 18:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pottsbavim 2016-06-02 00:38:13 UTC
I have just installed Krita 3.0. When I tested it by making a few strokes, the strokes I made did not appear on the canvas. However, the layer preview shows it just fine. The brushes also lags a lot.

Reproducible: Always

Steps to Reproduce:
1.Open Krita.
2.Start a new project.
3.Make brush strokes.

Actual Results:  
Brush doesn't move at once, not even at all. Nothing shows on the canvas but the layer preview shows the strokes you make.

Expected Results:  
The brush should move as you make strokes with your pen, the canvas should show those strokes.
Comment 1 Halla Rempt 2016-06-02 08:25:22 UTC
Hi,

Thanks for your report. Some questions:

* Can you confirm that you really did disable OpenGL in the settings dialog? 
* Is there are difference when you enable or disable Instant Preview in the view menu? 
* Does the selected brush preset make a difference?
* What is your video driver version?

Boudewijn
Comment 2 Halla Rempt 2016-11-03 13:31:34 UTC
I'm pretty sure that you're using an Intel GPU with one of the broken drivers. There's nothing we can do about; you can either try to update your system, or disable opengl.
Comment 3 Halla Rempt 2017-04-14 18:17:08 UTC
Please tell us exactly which brand and model of system you have, and which version of display chip and display driver you have. For the driver version, press the Windows key, then type "Device Manager", open the Device manager application and check the Display Adapter dialog.
Comment 4 Halla Rempt 2017-04-14 18:46:14 UTC

*** This bug has been marked as a duplicate of bug 360601 ***