Bug 385134 - GUI becomes blurry and scaled after opening an image
Summary: GUI becomes blurry and scaled after opening an image
Status: RESOLVED DUPLICATE of bug 360601
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: 3.2.1
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-27 11:14 UTC by Lukas Boersma
Modified: 2017-09-27 11:51 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Video demonstration of the UI becoming blurry after opening an image. (3.84 MB, video/mp4)
2017-09-27 11:14 UTC, Lukas Boersma
Details
Video demonstration of the UI becoming blurry after opening an image. (new codec for web browsers) (235.36 KB, video/mp4)
2017-09-27 11:20 UTC, Lukas Boersma
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Boersma 2017-09-27 11:14:19 UTC
Created attachment 108054 [details]
Video demonstration of the UI becoming blurry after opening an image.

When I open or create an image, the whole GUI of Krita becomes blurry and scaled (see the attached video). Before opening the first image, the GUI looks normal.

This only seems to affect the rendering, the mouse cursor still "hits" the GUI elements at their original positions (also demonstrated in the attached video).

I use Krita 3.2.1 on Windows 10. The same behaviour occurs on the latest nightly that I could find (4360147f).

If somebody can give me some hints on how to debug this, I would be willing to fix this and submit a patch.
Comment 1 Lukas Boersma 2017-09-27 11:20:42 UTC
Created attachment 108055 [details]
Video demonstration of the UI becoming blurry after opening an image. (new codec for web browsers)

Adding a new video with a codec supported by Firefox.
Comment 2 Halla Rempt 2017-09-27 11:51:08 UTC
This is not a bug in Krita, but in the driver for your intel HD620 chip. See https://communities.intel.com/thread/116003 . Intel has fixed this issue, but manufacturers are just now rolling out the broken driver, instead of the latest one.

We will release a version of Krita with a workaround this week. You can already test the release candidate: https://krita.org/en/item/krita-3-3-0-first-release-candidate/

*** This bug has been marked as a duplicate of bug 360601 ***