Bug 384073 - When New Document is made, file toolbar disappears, GUI is shifted up and left
Summary: When New Document is made, file toolbar disappears, GUI is shifted up and left
Status: RESOLVED DUPLICATE of bug 360601
Alias: None
Product: krita
Classification: Unclassified
Component: Usability (show other bugs)
Version: 3.2.1
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-27 12:49 UTC by fvig2001
Modified: 2017-08-27 13:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
File toolbar disappears buttons don't correspond to GUI. (142.61 KB, image/png)
2017-08-27 12:49 UTC, fvig2001
Details
before creating new document (125.66 KB, image/png)
2017-08-27 12:51 UTC, fvig2001
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fvig2001 2017-08-27 12:49:11 UTC
Created attachment 107538 [details]
File toolbar disappears buttons don't correspond to GUI.

After creation of new project, the file toolbar disappears and gui shifts up and left. Upper left button is file toolbar instead of what is displayed. Actual buttons are pixels lower than what is displayed on the screen. 

This is tested on Samsung Notebook 9 Pro on Win10 with Wintab driver installed, no modifications in settings of Krita.
Comment 1 fvig2001 2017-08-27 12:51:53 UTC
Created attachment 107539 [details]
before creating new document
Comment 2 fvig2001 2017-08-27 12:56:30 UTC
I am able to replicate this on 3.2.0 and this occurred directly after installation.
Comment 3 Halla Rempt 2017-08-27 13:30:23 UTC
That's a bug in a recent update of the Intel opengl driver, not in Krita. We've had reports like this before, and in order to avoid those hopelessly broken drivers, we've ported Krita to use ANGLE. Please test this build: 

https://krita.org/en/item/angle-and-windows-ink-a-new-test-version-of-krita-for-windows/

Note that this build is unstable: in order to use stable krita with those broken drivers, you will have to disable opengl in krita/settings/configure krita/display.

*** This bug has been marked as a duplicate of bug 360601 ***