Bug 383382 - Can't access parts of workspace/click on file items when a file is open
Summary: Can't access parts of workspace/click on file items when a file is open
Status: RESOLVED DUPLICATE of bug 360601
Alias: None
Product: krita
Classification: Unclassified
Component: OpenGL Canvas (show other bugs)
Version: 3.1.4
Platform: Microsoft Windows Microsoft Windows
: NOR major
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-10 21:39 UTC by Rebecca
Modified: 2017-08-13 13:18 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Picture of Krita with a blank file open. Row of file options at the top is cut off. (244.58 KB, image/png)
2017-08-10 21:39 UTC, Rebecca
Details
Krita with Hi-DPI support enabled (270.47 KB, image/png)
2017-08-12 18:26 UTC, Rebecca
Details
Krita after exiting the tab (131.95 KB, image/png)
2017-08-12 19:48 UTC, Rebecca
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rebecca 2017-08-10 21:39:03 UTC
Created attachment 107203 [details]
Picture of Krita with a blank file open. Row of file options at the top is cut off.

The Krita canvas/workspace looks/behaves normal when I first open the program, but when I open a file, I can't access the file options at the top of the screen or any buttons at the top (which means I can't change brush size/options/etc). Everything looks sized incorrectly for my screen and is cut off at the top and sides. 

I tried uninstalling and reinstalling Krita and it didn't fix the problem. Also tried updating my intel graphics drivers. Didn't have this problem before earlier this week. 

Windows 10, Dell XPS 15. Intel(R) Core(TM) i5-6200U.
Comment 1 Halla Rempt 2017-08-11 12:35:25 UTC
Hi Rebecca,

I've seen this reported on the forum, too.

I guess you got some kind of a windows update that broke stuff.

Logically, if Krita didn't change, an an issue appears, then it's not krita that broke, but something else. That's why uninstalling and reinstalling wouldn't help -- it won't ever help, even, because uninstalling and reinstalling means you're replacing the bits you had with exactly the same bits. It doesn't remove Krita's settings.

The settings, btw, you can reset: https://docs.krita.org/KritaFAQ#Resetting_Krita_configuration -- that might do something, though I doubt it.
Comment 2 Alvin Wong 2017-08-11 18:18:07 UTC
Hi,

I would really want to investigate this issue, so I would like to ask a few questions regarding your system and your Krita config:

1. At what scale level is your display set to? You can view this by right-clicking on the desktop, then choose "Display settings", and find the value under "Scale and layout". (My guess would be 150%.)
2. Are you currently on Windows 10 Version 1703? Were you on Version 1607 earlier when Krita still worked? (You can check the Windows Update history in Settings -> Update & Security -> Update history)
3. Does your laptop has only Intel integrated HD Graphics or does it also have an NVIDIA graphics card?
4.Do you have Hi-DPI support enabled in Krita? (Settings -> Configure Krita -> General -> Window) If you toggle it and restart Krita, what would be the behaviour of Krita? (It would help more to take a screenshot of the result.)
Comment 3 Rebecca 2017-08-12 18:25:40 UTC
Hi guys, thanks for the responses. @Boudewijn Rempt that would make sense because I did a BIOS update that Dell prompted this last week, and that was around the time Krita went wonky. 

@Alvin Wong--

1) Yep, it's at 150%, I just tried 125 and 100 and it didn't change anything in Krita (except, you know, make it smaller, haha). 
2) I'm currently on Windows 1703, but looking at my history it seems like I've had 1703 since as far back as May and Krita was fine then.
3) I just have Intel Graphics I'm pretty sure
4) Apparently I had it disabled, I turned it on and it definitely changed the look of Krita-- some of the buttons I didn't have access to before were working again but it's still sized wrong and I still don't have access to the file buttons (picture attached). 

Thanks again guys
Comment 4 Rebecca 2017-08-12 18:26:43 UTC
Created attachment 107237 [details]
Krita with Hi-DPI support enabled
Comment 5 Alvin Wong 2017-08-12 18:32:15 UTC
Thank you very much for your help. Would you be able to list all the Windows Updates performed after Krita last worked for you and before Krita started to not work?

(In reply to Rebecca from comment #3)
> Hi guys, thanks for the responses. @Boudewijn Rempt that would make sense
> because I did a BIOS update that Dell prompted this last week, and that was
> around the time Krita went wonky. 
> 
> @Alvin Wong--
> 
> 1) Yep, it's at 150%, I just tried 125 and 100 and it didn't change anything
> in Krita (except, you know, make it smaller, haha). 
> 2) I'm currently on Windows 1703, but looking at my history it seems like
> I've had 1703 since as far back as May and Krita was fine then.
> 3) I just have Intel Graphics I'm pretty sure
> 4) Apparently I had it disabled, I turned it on and it definitely changed
> the look of Krita-- some of the buttons I didn't have access to before were
> working again but it's still sized wrong and I still don't have access to
> the file buttons (picture attached). 
> 
> Thanks again guys
Comment 6 Halla Rempt 2017-08-12 18:43:09 UTC
I suspect the bios update... Though how that can make krita think its window size includes the window decoration instead of being inside it. Can you check another Qt application, Kate, to see if that does the same thing? https://kate-editor.org/get-it/
Comment 7 Halla Rempt 2017-08-12 18:44:51 UTC
Could it be related to https://bugreports.qt.io/browse/QTBUG-49523?jql=text%20~%20%22windows%20window%20size%20dell%22 -- also reported for an xps-15?
Comment 8 Alvin Wong 2017-08-12 18:51:01 UTC
(In reply to Boudewijn Rempt from comment #6)
> [...] krita think its window
> size includes the window decoration instead of being inside it.

Looking at the screenshots and seeing that the horizontal bounds exceeded the actual window size incl. decoration/frame, it would seem to be something else...


(In reply to Boudewijn Rempt from comment #7)
> Could it be related to
> https://bugreports.qt.io/browse/QTBUG-
> 49523?jql=text%20~%20%22windows%20window%20size%20dell%22 -- also reported
> for an xps-15?

Qt doesn't seem to be using the screen size though, it would be using the window client size as reported by the window manager.


@Rebecca Are you using an external monitor?
Comment 9 Alvin Wong 2017-08-12 19:27:17 UTC
Hi Rebecca,

Here's something more to test: If you create a new document and then close the tab, does the window content revert to normal? What if you then try to create another new document (by pressing Ctrl + N), does the window content shift and get cut off even more?
Comment 10 Rebecca 2017-08-12 19:48:11 UTC
Hi again--

No external monitor, just my laptop. (Also I realized I mistyped, it's an XPS13 not 15). 

I tried what you suggested @Alvin-- when I close the tab it sort of reverts to normal, but buttons are doubled, kind of? Attaching picture since it's hard to explain. 

I've realized also that the file menu buttons ARE clickable, just not visible. Everything is visually shifted "UP" but if I click where they're supposed to be, the function still works. Ex. to close the tab, I couldn't click the "X" I had to click a space or two down from the "X". I can change the opacity/size of brushes but I have to click below where the options for those are. 

Sorry if that's confusing, hard to explain or get a good screenshot of.
Comment 11 Rebecca 2017-08-12 19:48:57 UTC
Created attachment 107238 [details]
Krita after exiting the tab

Opening a new project after closing the tab just goes back to the same cut-off view from the start, also.
Comment 12 Halla Rempt 2017-08-12 19:51:35 UTC
Comment on attachment 107238 [details]
Krita after exiting the tab

Huh... Everything is shifted weirdly... It must be a really weird interaction between Qt and something in Windows or the Dell bios, because, well, there's no code in Krita that can explain this!
Comment 13 Alvin Wong 2017-08-12 20:14:18 UTC
@Rebecca

I should've asked this earlier... but if you disable OpenGL in Configure Krita -> Display, does it do the same?


I have a far-fetched hypothesis: When an OpenGL context is created, something somehow messed up the internal state of the window...
Comment 14 Rebecca 2017-08-12 20:23:00 UTC
Heyyyyy!!!!!! Disabling OpenGL fixed it! :D Everything displays normally including before/after opening a file or closing a tab. 

Thanks so much! Krita is my only real sketch program that I use so this had been really frustrating. Idk if that's a permanent solution but it works for now!
Comment 15 Alvin Wong 2017-08-12 20:27:36 UTC
Yeah, I'm glad that it works for you... but the actual bug is not really fixed...

So i would guess it's a bug with the latest Intel driver (again argh). If you somehow are able to install an older version it might work with OpenGL enabled (but Windows 10 wouldn't let you do this easily).

(Also, I would guess if you use any other applications that happen to use OpenGL there would be similar issues.)
Comment 16 Halla Rempt 2017-08-13 13:18:52 UTC
In any case, it's a not a bug in krita, so lets put it in the list of duplicates of our most duplicated bug report: 360601

*** This bug has been marked as a duplicate of bug 360601 ***