Bug 384781 - UI scales and desyncs to mouse's location when opening an image.
Summary: UI scales and desyncs to mouse's location when opening an image.
Status: RESOLVED DUPLICATE of bug 360601
Alias: None
Product: krita
Classification: Unclassified
Component: OpenGL Canvas (show other bugs)
Version: 3.2.1
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-16 23:11 UTC by claspectresource
Modified: 2017-09-17 06:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
From left to right, before opening, ui buggery, after closing an image. (940.06 KB, image/png)
2017-09-16 23:11 UTC, claspectresource
Details

Note You need to log in before you can comment on or make changes to this bug.
Description claspectresource 2017-09-16 23:11:46 UTC
Created attachment 107885 [details]
From left to right, before opening, ui buggery, after closing an image.

Has been occurring for a few days now.

Every time I try to open up an image, whether it be new or saved, the UI will resize itself disproportionately to the window size and become fuzzy. As well, the mouse will still register all the buttons in where they would be regularly, including the drop-down menus at the top which are visibly out of frame. 

This scaling issue fixes itself after closing the image, although it will still leave a graphical glitch in the section for the drop-down menus. Hovering over each selection will make them visible again, but in-between each button is still the leftover UI distortion.

Thank you for your time.
Comment 1 Alvin Wong 2017-09-17 06:04:59 UTC
This is a bug in the Intel display driver. Update the driver or disable opengl. See https://communities.intel.com/thread/116003

See also 
https://krita.org/en/item/angle-and-windows-ink-a-new-test-version-of-krita-for-windows/ for test packages that used direct3d on windows instead of opengl.

*** This bug has been marked as a duplicate of bug 360601 ***