Bug 380418 - GUI is out of alignment with the main Krita window once a document is opened
Summary: GUI is out of alignment with the main Krita window once a document is opened
Status: RESOLVED DUPLICATE of bug 360601
Alias: None
Product: krita
Classification: Unclassified
Component: Usability (show other bugs)
Version: 3.1.4
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-01 09:27 UTC by Steve
Modified: 2017-06-05 11:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screen showing problem (613.40 KB, image/png)
2017-06-01 09:27 UTC, Steve
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve 2017-06-01 09:27:47 UTC
Created attachment 105815 [details]
Screen showing problem

Hi,

My Krita has an issue when I open a recent file or create a new document.  As soon as I do this the Krita interface expands slightly pushing it outwards.  This means it no longer fits in the window.  The pull down menu's at the top of the screen disappear, however if I click in the place they are meant to be the menu will then display.  It also appears that the mouse is slightly out of sync when it is hovering over on screen.  

I have attached a screenshot.

Regards,
Steve
Comment 1 Halla Rempt 2017-06-01 09:46:00 UTC
Weird... I cannot explain this, but what are your windows display scaling settings? Does it still happen if you reset krita's configuration? (https://docs.krita.org/KritaFAQ#Resetting_Krita_configuration)
Comment 2 Steve 2017-06-01 10:04:51 UTC
My display scaling is set to 'Maintain Display Scaling'.

I tried resetting Krita but still had the same issue.

I am thinking I may try uninstalling and trying a previous version.
Comment 3 Halla Rempt 2017-06-01 10:07:43 UTC
Hm... Could you try with a different user? You can also just download the portable zip packages from download.kde.org: you can just unpack and run in place, no need to uninstall/reinstall.
Comment 4 Steve 2017-06-01 10:42:42 UTC
I grabbed the zip for 3.1.0 and ran that, but still have the same issue.

I am the only user on this laptop so cant try another user.

Bit of a strange problem.  Unfortunately it makes Krita pretty much unusable for me without the pointer syncing to the correct spot on the screen.

When I get a chance tomorrow I will try connecting to an external monitor and see what happens.
Comment 5 Halla Rempt 2017-06-01 12:18:14 UTC
You can make a second user account in Windows, I think?
Comment 6 Steve 2017-06-04 01:08:57 UTC
I have created a new account and Krita still has the same problem for the new user.
Comment 7 Halla Rempt 2017-06-05 07:19:24 UTC
Okay... That's puzzling. I don't know what to do, since this problem seems to be unique to your computer. I've never seen it before :-(
Comment 8 Steve 2017-06-05 09:01:01 UTC
I have resolved this by rolling back my Intel HD Graphics 530 driver to V20.19.15.4474.

Now all is back to normal.  Cheers for your help!
Comment 9 Halla Rempt 2017-06-05 11:44:54 UTC
Oh gosh... A fourth intel driver bug! We already had blank or black screen, updates only happening after clicking somewhere outside the canvas and a big crash when the shaders are compiled.

*** This bug has been marked as a duplicate of bug 360601 ***