Bug 270442 - kill dbus makes inportand things instable
Summary: kill dbus makes inportand things instable
Status: RESOLVED INTENTIONAL
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 264758 271127 272647 272791 276725 276884 278889 279962 280272 281616 282182 282572 283556 283761 283935 283945 284982 286944 297195 297773 298594 298751 301897 306037 307293 309928 309948 314311 314342 316149 316765 317172 318467 320220 325230 325687 326141 328478 329021 329712 330345 331777 331860 336418 341270 345884 355287 356258 359719 363463 364619 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-08 15:56 UTC by michel kollenhoven
Modified: 2021-01-09 16:09 UTC (History)
52 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (1.53 KB, text/plain)
2011-04-08 15:59 UTC, michel kollenhoven
Details
New crash information added by DrKonqi (1.58 KB, text/plain)
2011-11-05 20:16 UTC, Ali Rohman
Details
New crash information added by DrKonqi (4.02 KB, text/plain)
2012-05-26 21:37 UTC, Vadym Krevs
Details
New crash information added by DrKonqi (1.53 KB, text/plain)
2013-05-21 19:50 UTC, uc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description michel kollenhoven 2011-04-08 15:56:30 UTC
Application: kcminit ()
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
dbus sometimes gos to 100%(for one core) so i kill it and i use dbus-launch to restart the requierd apps

note kde was/is running.

switching to vt12(pressing ctrl-alt-f12 (both right) from a virtualbox machine crashed it.

as this is not the root of my problem what is the propper way to restasrt the bus session so apps keep on working? i not just relog.

still i dont think the entire session should depend on dbus(crash when dbus craches)
(problems apps: kLOUNCER(not start apps get sig15), empathy, chrome, vlc, vbox, thisapp)

sorry for the nonspesifficness,

Thanks
p.s.monday i will  update the bug or create a new one if i can blame a app(if it hits)


disclamer: app is application in the widest cense, sorry form my english no spellcheck here

-- Backtrace:
Application: KCMInit (kcminit), signal: Aborted
[KCrash Handler]
#6  0x00007f6dc35ffba5 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f6dc36036b0 in abort () at abort.c:92
#8  0x00007f6dc20e0864 in qt_message_output (msgType=QtFatalMsg, buf=<value optimized out>) at global/qglobal.cpp:2259
#9  0x00007f6dc30c043d in QDebug::~QDebug (this=0x7fff4377a900, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#10 0x00007f6dc31b052b in KApplicationPrivate::init (this=0x13bda90, GUIenabled=true) at ../../kdeui/kernel/kapplication.cpp:513
#11 0x00007f6dc31b1bb9 in KApplication::KApplication (this=0x7fff4377aa70, GUIenabled=<value optimized out>) at ../../kdeui/kernel/kapplication.cpp:351
#12 0x00007f6dc39545d5 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kcminit/main.cpp:268
#13 0x00007f6dc35ead8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff4377ad18) at libc-start.c:226
#14 0x0000000000400669 in _start ()

This bug may be a duplicate of or related to bug 246404.

Possible duplicates by query: bug 246404.

Reported using DrKonqi
Comment 1 michel kollenhoven 2011-04-08 15:59:01 UTC
Created attachment 58712 [details]
New crash information added by DrKonqi

kcminit () on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0

acsecly the same 

in case youll need it 

Thanks and let me know

-- Backtrace (Reduced):
#9  0x00007fab0ee0a43d in QDebug::~QDebug (this=0x7fffc0486150, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#10 0x00007fab0eefa52b in KApplicationPrivate::init (this=0x22ddbe0, GUIenabled=true) at ../../kdeui/kernel/kapplication.cpp:513
#11 0x00007fab0eefbbb9 in KApplication::KApplication (this=0x7fffc04862c0, GUIenabled=<value optimized out>) at ../../kdeui/kernel/kapplication.cpp:351
#12 0x00007fab0f69e5d5 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kcminit/main.cpp:268
#13 0x00007fab0f334d8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffc0486568) at libc-start.c:226
Comment 2 Christoph Feck 2011-04-23 16:01:10 UTC
*** Bug 271127 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2011-05-07 16:49:54 UTC
*** Bug 272647 has been marked as a duplicate of this bug. ***
Comment 4 Dominik Haumann 2011-06-29 07:23:33 UTC
*** Bug 276725 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Feck 2011-07-11 02:52:20 UTC
*** Bug 272791 has been marked as a duplicate of this bug. ***
Comment 6 Christophe Giboudeaux 2011-07-13 14:32:47 UTC
*** Bug 276884 has been marked as a duplicate of this bug. ***
Comment 7 Aaron J. Seigo 2011-07-13 18:39:39 UTC
dbus is a runtime _requirement_ of the desktop; i don't see that changing. if we move to something other than dbus, then this bug will quietly resolve itself (and simply relocate to that $somethingElse) .. but as long as we rely on dbus for critical items, this will remain and i don't see the point of keeping a report open for something that will not get addressed.
Comment 8 Christoph Feck 2011-07-31 00:12:12 UTC
*** Bug 278889 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Feck 2011-09-08 13:03:40 UTC
*** Bug 281616 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Feck 2011-09-08 13:04:03 UTC
*** Bug 279962 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Feck 2011-09-17 10:23:09 UTC
*** Bug 282182 has been marked as a duplicate of this bug. ***
Comment 12 Christoph Feck 2011-09-22 20:17:16 UTC
*** Bug 282572 has been marked as a duplicate of this bug. ***
Comment 13 Dominik Haumann 2011-10-08 21:10:05 UTC
*** Bug 280272 has been marked as a duplicate of this bug. ***
Comment 14 Dominik Haumann 2011-10-08 21:10:12 UTC
*** Bug 283556 has been marked as a duplicate of this bug. ***
Comment 15 Dominik Haumann 2011-10-08 21:12:47 UTC
*** Bug 264758 has been marked as a duplicate of this bug. ***
Comment 16 Christoph Feck 2011-10-14 01:02:14 UTC
*** Bug 283945 has been marked as a duplicate of this bug. ***
Comment 17 Christoph Feck 2011-10-14 01:03:22 UTC
*** Bug 283935 has been marked as a duplicate of this bug. ***
Comment 18 Oliver Diers 2011-10-23 11:48:38 UTC
Hallo all, have the same effect with KDE 4.7 with Suse 11.3

Does anybody have a fix?
Comment 19 András Manţia 2011-10-24 14:10:38 UTC
I agree with Aaron. Dbus is a requirement for KDE (and not only) applications, so killing dbus from under the app (or not starting a session bus) will cause weird behavior and crashes.
Comment 20 Dominik Haumann 2011-10-26 20:44:12 UTC
*** Bug 283761 has been marked as a duplicate of this bug. ***
Comment 21 Dominik Haumann 2011-10-26 20:44:18 UTC
*** Bug 284982 has been marked as a duplicate of this bug. ***
Comment 22 Ali Rohman 2011-11-05 20:16:57 UTC
Created attachment 65272 [details]
New crash information added by DrKonqi

ktraderclient (0.0) on KDE Platform 4.7.2 (4.7.2) using Qt 4.8.0

When i update system specially X11, Mesa, Qt, from automatic update, update proses seem complete. But kde crash when logout and startup.

-- Backtrace (Reduced):
#6  0x0000003883e362a5 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x0000003883e37bbb in __GI_abort () at abort.c:91
[...]
#9  0x0000003f8f96af6d in ~QDebug (this=0x7fff75024200, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:85
#10 QDebug::~QDebug (this=0x7fff75024200, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:81
#11 0x0000003f8fa521ab in KApplicationPrivate::init (this=0xb3d500, GUIenabled=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:516
Comment 23 Christoph Feck 2011-11-19 01:25:49 UTC
*** Bug 286944 has been marked as a duplicate of this bug. ***
Comment 24 Christoph Feck 2011-11-19 01:25:58 UTC
Sure, D-Bus should not be killed, but instead of crashing, KDE should restart the D-Bus daemon, or at least exit gracefully.

Related bugs are:

Applications crash when started as root: bug 282182.
Applications crash when started from cron: bug 286944.
Comment 25 Christoph Feck 2012-04-01 22:12:43 UTC
*** Bug 297195 has been marked as a duplicate of this bug. ***
Comment 26 Peter Penz 2012-04-09 13:00:04 UTC
*** Bug 297773 has been marked as a duplicate of this bug. ***
Comment 27 Dominik Haumann 2012-04-23 16:43:05 UTC
*** Bug 298594 has been marked as a duplicate of this bug. ***
Comment 28 Dominik Haumann 2012-04-25 08:57:35 UTC
*** Bug 298751 has been marked as a duplicate of this bug. ***
Comment 29 Vadym Krevs 2012-05-26 21:37:35 UTC
Created attachment 71391 [details]
New crash information added by DrKonqi

akonadi_maildispatcher_agent (4.8) on KDE Platform 4.8.3 (4.8.3) "release 504" using Qt 4.8.1

- What I was doing when the application crashed:

Updated to latest KDE from openSUSE OBS and restarted KDE. Kontact autostarted, then all of a sudden the akonadi resource started asking for password, then it crashed.

-- Backtrace (Reduced):
#6  0x00007f3a65428d95 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f3a6542a2ab in __GI_abort () at abort.c:93
[...]
#9  0x00007f3a688aa9b4 in QDebug::~QDebug (this=0x7ffff580c8d0, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:85
#10 0x00007f3a68803064 in Akonadi::AgentBasePrivate::delayedInit (this=0x816030) at /usr/src/debug/kdepimlibs-4.8.3/akonadi/agentbase.cpp:288
#11 0x00007f3a6886137a in Akonadi::AgentBase::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdepimlibs-4.8.3/build/akonadi/agentbase.moc:97
Comment 30 Jekyll Wu 2012-08-30 16:58:49 UTC
*** Bug 306037 has been marked as a duplicate of this bug. ***
Comment 31 Christoph Feck 2012-09-24 00:27:15 UTC
*** Bug 307293 has been marked as a duplicate of this bug. ***
Comment 32 Jekyll Wu 2012-11-12 04:43:20 UTC
*** Bug 309928 has been marked as a duplicate of this bug. ***
Comment 33 Frank Reininghaus 2012-11-12 09:02:36 UTC
*** Bug 309948 has been marked as a duplicate of this bug. ***
Comment 34 Jekyll Wu 2013-02-03 11:39:24 UTC
*** Bug 314342 has been marked as a duplicate of this bug. ***
Comment 35 Jekyll Wu 2013-02-03 11:41:00 UTC
*** Bug 301897 has been marked as a duplicate of this bug. ***
Comment 36 Jekyll Wu 2013-02-03 11:41:03 UTC
*** Bug 314311 has been marked as a duplicate of this bug. ***
Comment 37 Christoph Feck 2013-03-05 11:28:27 UTC
*** Bug 316149 has been marked as a duplicate of this bug. ***
Comment 38 Dominik Haumann 2013-03-15 09:28:13 UTC
*** Bug 314342 has been marked as a duplicate of this bug. ***
Comment 39 Dominik Haumann 2013-03-15 09:28:25 UTC
*** Bug 316765 has been marked as a duplicate of this bug. ***
Comment 40 Jekyll Wu 2013-03-24 06:00:12 UTC
*** Bug 317172 has been marked as a duplicate of this bug. ***
Comment 41 Christoph Feck 2013-04-16 22:16:24 UTC
*** Bug 318467 has been marked as a duplicate of this bug. ***
Comment 42 Dominik Wezel 2013-04-17 07:12:43 UTC
Hi
Can somebody please remove me (dominik@wezel-mueggler.org) from the CC list?  I didn't find a way to do it mayself.  Thanks!
Comment 43 glad08 2013-04-17 09:25:32 UTC
In upper part of page check "Remove me from the CC list " and press "Save changes"
Comment 44 uc 2013-05-21 19:50:25 UTC
Created attachment 80004 [details]
New crash information added by DrKonqi

kwrite (4.10.2 "release 1") on KDE Platform 4.10.2 "release 1" using Qt 4.8.4

- What I was doing when the application crashed:

In openSuse 12.3 and KDE 4, went to SU in terminal.  Typed "kwrite" which started but crashed immediately.

-- Backtrace (Reduced):
#9  0x00007f1ad76aba06 in QDebug::~QDebug (this=0x7fff9d149a10, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:85
#10 0x00007f1ad77889d7 in KApplicationPrivate::init (this=0xc95ee0, GUIenabled=GUIenabled@entry=true) at /usr/src/debug/kdelibs-4.10.2/kdeui/kernel/kapplication.cpp:516
#11 0x00007f1ad77899c8 in KApplication::KApplication (this=0x7fff9d149dd0, GUIenabled=true) at /usr/src/debug/kdelibs-4.10.2/kdeui/kernel/kapplication.cpp:352
[...]
#13 0x00007f1ad8abd05f in kdemain () from /usr/lib64/libkdeinit4_kwrite.so
[...]
#15 0x0000000000400761 in _start ()
Comment 45 Christoph Feck 2013-06-15 22:08:40 UTC
*** Bug 320220 has been marked as a duplicate of this bug. ***
Comment 46 Aaron J. Seigo 2013-06-15 22:50:54 UTC
I seriously disagree with the idea that the session should somehow be resistant to DBus going away. It is a core component that must be relied on. It's a little like saying that the session should remain running even if the kernel OOPSes. Some things are beyond the scope of reality, and this, imho, is one of them.
Comment 47 Christoph Feck 2013-09-24 11:51:37 UTC
*** Bug 325230 has been marked as a duplicate of this bug. ***
Comment 48 Thomas Lübking 2013-10-06 10:11:41 UTC
*** Bug 325687 has been marked as a duplicate of this bug. ***
Comment 49 Jekyll Wu 2013-10-18 03:20:48 UTC
*** Bug 326141 has been marked as a duplicate of this bug. ***
Comment 50 Christoph Feck 2013-12-20 13:24:29 UTC
*** Bug 328478 has been marked as a duplicate of this bug. ***
Comment 51 Christoph Feck 2013-12-20 13:24:45 UTC
*** Bug 329021 has been marked as a duplicate of this bug. ***
Comment 52 Jekyll Wu 2014-01-24 10:59:47 UTC
*** Bug 330345 has been marked as a duplicate of this bug. ***
Comment 53 Jekyll Wu 2014-01-24 10:59:49 UTC
*** Bug 329712 has been marked as a duplicate of this bug. ***
Comment 54 Jekyll Wu 2014-03-10 08:48:01 UTC
*** Bug 331777 has been marked as a duplicate of this bug. ***
Comment 55 Jekyll Wu 2014-03-10 09:10:28 UTC
*** Bug 331860 has been marked as a duplicate of this bug. ***
Comment 56 Dominik Haumann 2014-06-19 10:33:35 UTC
*** Bug 336418 has been marked as a duplicate of this bug. ***
Comment 57 Milian Wolff 2014-11-26 12:53:17 UTC
*** Bug 341270 has been marked as a duplicate of this bug. ***
Comment 58 Frank Reininghaus 2015-04-11 17:23:58 UTC
*** Bug 345884 has been marked as a duplicate of this bug. ***
Comment 59 Christoph Feck 2015-12-03 14:49:46 UTC
*** Bug 355287 has been marked as a duplicate of this bug. ***
Comment 60 Christoph Feck 2015-12-03 23:02:11 UTC
*** Bug 356258 has been marked as a duplicate of this bug. ***
Comment 61 Christoph Feck 2016-05-25 11:07:01 UTC
*** Bug 363463 has been marked as a duplicate of this bug. ***
Comment 62 Christoph Feck 2016-06-26 04:17:14 UTC
*** Bug 364619 has been marked as a duplicate of this bug. ***
Comment 63 Nate Graham 2017-09-08 20:00:07 UTC
*** Bug 359719 has been marked as a duplicate of this bug. ***
Comment 64 Justin Zobel 2020-12-17 05:31:30 UTC
Thank you for the crash report.

As it has been a while since this was reported, can you please test and confirm if this issue is still occurring or if this bug report can be marked as resolved.

I have set the bug status to "needsinfo" pending your response, please change back to "reported" or "resolved/worksforme" when you respond, thank you.
Comment 65 CK 2020-12-17 09:18:35 UTC
never had happen since KDE5 release
Comment 66 Bug Janitor Service 2021-01-01 04:34:25 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 67 Christoph Feck 2021-01-09 16:09:35 UTC
I guess killing the D-Bus session is still not supported, but killing system services isn't a supported operation anyway.