Bug 282572 - starting konqueror as root from command line causes crash
Summary: starting konqueror as root from command line causes crash
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-22 18:53 UTC by mondkugl
Modified: 2011-09-22 20:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mondkugl 2011-09-22 18:53:25 UTC
Application: konqueror (4.6.00 (4.6.0) "release 6")
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.6-0.7-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

hal9001:/home/jr # konqueror 
konqueror(12008): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 

KCrash: Application 'konqueror' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
sock_file=/root/.kde4/socket-hal9001/kdeinit4__0

[1]+  Angehalten              konqueror

session terminates

The crash can be reproduced every time.

-- Backtrace:
Application: Konqueror (konqueror), signal: Aborted
[KCrash Handler]
#6  0x00007f4975f4dab5 in raise () from /lib64/libc.so.6
#7  0x00007f4975f4efb6 in abort () from /lib64/libc.so.6
#8  0x00007f4973a7d8a4 in qt_message_output (msgType=<value optimized out>, buf=<value optimized out>) at global/qglobal.cpp:2282
#9  0x00007f497467530e in QDebug::~QDebug (this=0x7fffd9c328e0, __in_chrg=<value optimized out>) at /usr/include/QtCore/qdebug.h:85
#10 0x00007f497460f182 in KApplicationPrivate::init (this=<value optimized out>, GUIenabled=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:514
#11 0x00007f4974610279 in KApplication::KApplication (this=0x7fffd9c32ce0, GUIenabled=true) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:352
#12 0x00007f49762c3b2a in ?? () from /usr/lib64/libkdeinit4_konqueror.so
#13 0x00007f497633c141 in kdemain () from /usr/lib64/libkdeinit4_konqueror.so
#14 0x00007f4975f39bfd in __libc_start_main () from /lib64/libc.so.6
#15 0x0000000000400699 in _start ()

Possible duplicates by query: bug 282182, bug 279962, bug 278889, bug 276884, bug 276048.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-09-22 20:17:16 UTC

*** This bug has been marked as a duplicate of bug 270442 ***