Bug 279962 - KDialog-1.0 crash when starting a KDE session
Summary: KDialog-1.0 crash when starting a KDE session
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 1.0
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-12 12:23 UTC by Dominik
Modified: 2011-09-08 13:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominik 2011-08-12 12:23:05 UTC
Application: kdialog (1.0)
KDE Platform Version: 4.6.3 (4.6.3) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.34-gentoo-r12-02b i686
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:

Whenever I start a new KDE session (session manager: start with an empty session) I get this crash TWICE.  I used to play around with KDialog, and some of the dialogs were open when I logged out of KDE, but then I changed the session manager setting to "start with an empty session", which did not help, against all expectations.  I still have crashing kdialogs when logging into KDE as this particular user.

The crash can be reproduced every time.

-- Backtrace:
Application: KDialog (kdialog), signal: Aborted
[KCrash Handler]
#7  0xb78b5424 in __kernel_vsyscall ()
#8  0xb5cebd09 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0xb5ced1bc in abort () at abort.c:92
#10 0xb6a6777e in qt_message_output (msgType=QtFatalMsg, buf=0x80f1e60 "kdialog(28751): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) \n") at global/qglobal.cpp:2282
#11 0xb706b947 in QDebug::~QDebug (this=0xbfb861a0, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#12 0xb719d483 in KApplicationPrivate::init (this=0x80d2158, GUIenabled=true) at /var/tmp/portage/kde-base/kdelibs-4.6.3-r2/work/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:518
#13 0xb719f13f in KApplication::KApplication (this=0xbfb863d8, GUIenabled=true) at /var/tmp/portage/kde-base/kdelibs-4.6.3-r2/work/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:352
#14 0x08052d99 in main (argc=11, argv=0xbfb86b04) at /var/tmp/portage/kde-base/kdialog-4.6.3/work/kdialog-4.6.3/kdialog/kdialog.cpp:866

Possible duplicates by query: bug 278889, bug 276884, bug 272647, bug 270442.

Reported using DrKonqi
Comment 1 Dominik 2011-08-12 18:34:36 UTC
I solved the problem like this:
rm -rf ~/.kde4

Not the best solution kmaybe, but the show must go on.
Comment 2 Christoph Feck 2011-09-08 13:04:03 UTC

*** This bug has been marked as a duplicate of bug 270442 ***