Bug 331777 - kwrite crashed after opening file in home folder as root
Summary: kwrite crashed after opening file in home folder as root
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kate
Classification: Applications
Component: kwrite (show other bugs)
Version: 3.12.1
Platform: Debian stable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-03-05 18:10 UTC by Jakob Janzen
Modified: 2014-03-10 08:48 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jakob Janzen 2014-03-05 18:10:56 UTC
Application: kwrite (4.12.1)
KDE Platform Version: 4.12.1
Qt Version: 4.8.6
Operating System: Linux 3.13.5 x86_64
Distribution: SolydXK

-- Information about the crash:
- What I was doing when the application crashed:

opened konsole, typed 'su', confirmed password.
typed 'cd ~/.kde/share/config'.
typed 'kwrite kwinrc' to examine file -> kwrite crashed

The crash can be reproduced every time.

-- Backtrace:
Application: KWrite (kwrite), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#5  0x00007fa85fbed1d5 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#6  0x00007fa85fbf0388 in __GI_abort () at abort.c:90
#7  0x00007fa85d3c8c52 in qt_message_output(QtMsgType, char const*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007fa85eb318e9 in ?? () from /usr/lib/libkdeui.so.5
#9  0x00007fa85ec09958 in ?? () from /usr/lib/libkdeui.so.5
#10 0x00007fa85ec0a332 in KApplication::KApplication(bool) () from /usr/lib/libkdeui.so.5
#11 0x00007fa85ff78ba8 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwrite.so
#12 0x00007fa85ff774ee in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwrite.so
#13 0x00007fa85fbd9995 in __libc_start_main (main=0x4006d0, argc=2, ubp_av=0x7fff63c8bff8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff63c8bfe8) at libc-start.c:276
#14 0x00000000004006fe in _start ()

Possible duplicates by query: bug 331379, bug 330345, bug 326141, bug 322845, bug 318467.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-03-10 08:48:01 UTC
> opened konsole, typed 'su', confirmed password.

Don't do it that way.  Instead, run 'kdesu kwrite <file> " as normal user.

*** This bug has been marked as a duplicate of bug 270442 ***