Bug 325230 - Kwrite crash started from su command nohup kwrite &
Summary: Kwrite crash started from su command nohup kwrite &
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: 3.10.5
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-09-24 09:27 UTC by Ya'akov
Modified: 2013-09-24 11:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ya'akov 2013-09-24 09:27:51 UTC
Application: kate (3.10.5)
KDE Platform Version: 4.10.5 "release 1"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.16-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Started kwrite from root command terminal - nohup kwrite &
Immediate crash

The crash can be reproduced every time.

-- Backtrace:
Application: Kate (kate), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f3a0810e3d5 in raise () from /lib64/libc.so.6
#7  0x00007f3a0810f858 in abort () from /lib64/libc.so.6
#8  0x00007f3a05f96c54 in qt_message_output (msgType=<optimized out>, buf=<optimized out>) at global/qglobal.cpp:2323
#9  0x00007f3a067d80b6 in QDebug::~QDebug (this=0x7fffb94443d0, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:85
#10 0x00007f3a068b5087 in KApplicationPrivate::init (this=0x2382380, GUIenabled=GUIenabled@entry=true) at /usr/src/debug/kdelibs-4.10.5/kdeui/kernel/kapplication.cpp:516
#11 0x00007f3a068b6078 in KApplication::KApplication (this=0x7fffb9444a60, GUIenabled=true) at /usr/src/debug/kdelibs-4.10.5/kdeui/kernel/kapplication.cpp:352
#12 0x00007f3a06d04874 in KateApp::KateApp(KCmdLineArgs*) () from /usr/lib64/libkateinterfaces.so.4
#13 0x00007f3a0848baf8 in kdemain () from /usr/lib64/libkdeinit4_kate.so
#14 0x00007f3a080faa15 in __libc_start_main () from /lib64/libc.so.6
#15 0x0000000000400761 in _start ()

This bug may be a duplicate of or related to bug 270442.

Possible duplicates by query: bug 324579, bug 322845, bug 318467, bug 316765, bug 314342.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-09-24 11:51:37 UTC
Use kdesu or manually make sure your root user has a DBus session.

*** This bug has been marked as a duplicate of bug 270442 ***