Bug 283945 - crash from su terminal
Summary: crash from su terminal
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 1.7
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-13 21:23 UTC by raludom
Modified: 2011-10-14 01:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description raludom 2011-10-13 21:23:40 UTC
Application: dolphin (1.7)
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.4
Operating System: Linux 3.1.0-rc7-3-desktop x86_64
Distribution: "openSUSE 12.1 Beta 1 (x86_64)"

-- Information about the crash:
linux-jjcv:~ # dolphin
dolphin(23445)/kdeui (kdelibs): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 
KCrash: Application 'dolphin' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
sock_file=/root/.kde4/socket-linux-jjcv.site/kdeinit4__0

[2]+  Stopped                 dolphin


  was running su terminal

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Aborted
[KCrash Handler]
#6  0x00007faad40aad25 in raise () from /lib64/libc.so.6
#7  0x00007faad40ac23b in abort () from /lib64/libc.so.6
#8  0x00007faad111b9e4 in qt_message_output (msgType=<optimized out>, buf=<optimized out>) at global/qglobal.cpp:2291
#9  0x00007faad1b7464d in ~QDebug (this=0x7fffb916a650, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:85
#10 QDebug::~QDebug (this=0x7fffb916a650, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:81
#11 0x00007faad1c5d2fb in KApplicationPrivate::init (this=0x67d940, GUIenabled=<optimized out>) at /usr/src/debug/kdelibs-4.7.1/kdeui/kernel/kapplication.cpp:516
#12 0x00007faad1c5e378 in KApplication::KApplication (this=0x7fffb916a8d0, GUIenabled=true) at /usr/src/debug/kdelibs-4.7.1/kdeui/kernel/kapplication.cpp:352
#13 0x00007faad443a80e in DolphinApplication::DolphinApplication (this=0x7fffb916a8d0) at /usr/src/debug/kde-baseapps-4.7.1/dolphin/src/dolphinapplication.cpp:32
#14 0x00007faad445174f in kdemain (argc=1, argv=0x7fffb916adb8) at /usr/src/debug/kde-baseapps-4.7.1/dolphin/src/main.cpp:79
#15 0x00007faad409723d in __libc_start_main () from /lib64/libc.so.6
#16 0x0000000000400681 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 283935, bug 282182, bug 279962, bug 278889, bug 276884.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-10-14 01:02:14 UTC

*** This bug has been marked as a duplicate of bug 270442 ***