Bug 325687 - Kwin becomes unstable and crashes in 4.11.2
Summary: Kwin becomes unstable and crashes in 4.11.2
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 4.11.2
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-10-06 01:41 UTC by Maxim Therrien
Modified: 2013-10-08 00:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Therrien 2013-10-06 01:41:13 UTC
Application: kwin (4.11.2)
KDE Platform Version: 4.11.2
Qt Version: 4.8.5
Operating System: Linux 3.7.10-1.16-default i686
Distribution: "openSUSE 12.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
I was playing Minecraft, then it started having more and more lagspikes. After a while, Kwin crashed, also taking the taskbars. Then I went into my nVidia settings and saw my GPU was constantly spiking, even after stopping the game. I opened the case, and stuck a fan in there (reason why I could report). I think it is important as it can break hardware. KDE 4.11.2, freshly updated, problem happened in the few hours following. nVidia GeForce 8600 GT GPU, on OpenSuSE 12.3.

-- Backtrace:
Application: KWin (kwin), signal: Aborted
Using host libthread_db library "/lib/libthread_db.so.1".
[KCrash Handler]
#7  0xb7763430 in __kernel_vsyscall ()
#8  0xb74078cf in raise () from /lib/libc.so.6
#9  0xb74091b3 in abort () from /lib/libc.so.6
#10 0xb5cd9e6e in qt_message_output (msgType=QtFatalMsg, buf=0x95cadc8 "kwin(2402)/kdeui (kdelibs): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) ") at global/qglobal.cpp:2323
#11 0xb6a1db28 in QDebug::~QDebug (this=0xbff5c094, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:85
#12 0xb6b19f8c in KApplicationPrivate::init (this=0x95522a0, GUIenabled=GUIenabled@entry=true) at /usr/src/debug/kdelibs-4.11.2/kdeui/kernel/kapplication.cpp:516
#13 0xb6b1b010 in KApplication::KApplication (this=0xbff5c828, GUIenabled=true) at /usr/src/debug/kdelibs-4.11.2/kdeui/kernel/kapplication.cpp:352
#14 0xb75f5c33 in KWin::Application::Application (this=0xbff5c828) at /usr/src/debug/kde-workspace-4.11.2/kwin/main.cpp:311
#15 0xb75f7cec in kdemain (argc=1, argv=0xbff5c914) at /usr/src/debug/kde-workspace-4.11.2/kwin/main.cpp:573
#16 0x080485bb in main (argc=1, argv=0xbff5c914) at /usr/src/debug/kde-workspace-4.11.2/build/kwin/kwin_dummy.cpp:3

Possible duplicates by query: bug 318467, bug 314342, bug 306037, bug 301897, bug 298391.

Reported using DrKonqi
Comment 1 Thomas Lübking 2013-10-06 10:11:41 UTC
kwin cannot "take the taskbars" - that's a different process.
also is the dbus daemon which died and caused (this) segfault in kapplication - as probably the crash in plasma desktop.

it's maybe caused by the overheat, but i suspect a general unstability here - causing the follow-up crashes.

did the update only update kde?
did you reboot after the update?
was kwin actually still running when the "gpu was spiking"?
do you refer to the gpu temperature by this?

*** This bug has been marked as a duplicate of bug 270442 ***
Comment 2 Maxim Therrien 2013-10-08 00:03:05 UTC
I only updated KDE
I rebooted after the update
KWin didn't seem to be working when my GPU was heating up.
When I sais "took the taskbar", I meant the taskbars disappeared, but the Plasma cashews were still present and working. My GPU went up to 80 C.