Bug 272647 - KDialog crashes every time I wanted to start it
Summary: KDialog crashes every time I wanted to start it
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 1.0
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-06 21:12 UTC by Unknown
Modified: 2012-12-06 03:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2011-05-06 21:12:43 UTC
Application: kdialog (1.0)
KDE Platform Version: 4.6.3 (4.6.3)
Qt Version: 4.7.3
Operating System: Linux 2.6.37.6-0.5-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

If I try to start KDialog, I got this crash.
It's all the same if I start with "kdialog hi" or "kdialog --passivepopup hi".

The crash can be reproduced every time.

-- Backtrace:
Application: KDialog (kdialog), signal: Aborted
[KCrash Handler]
#6  0x00007fc43045dab5 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007fc43045efb6 in abort () at abort.c:92
#8  0x00007fc4319cd924 in qt_message_output (msgType=<value optimized out>, buf=<value optimized out>) at global/qglobal.cpp:2282
#9  0x00007fc4325c8bae in QDebug::~QDebug (this=0x7fffab3b0480, __in_chrg=<value optimized out>) at /usr/include/QtCore/qdebug.h:85
#10 0x00007fc432562932 in KApplicationPrivate::init (this=<value optimized out>, GUIenabled=<value optimized out>) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:516
#11 0x00007fc432563a29 in KApplication::KApplication (this=0x7fffab3b06d0, GUIenabled=true) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:352
#12 0x000000000040c0af in main (argc=3, argv=0x7fffab3b2058) at /usr/src/debug/kdebase-4.6.3/kdialog/kdialog.cpp:866

Possible duplicates by query: bug 270442, bug 246404.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-05-07 16:49:54 UTC

*** This bug has been marked as a duplicate of bug 270442 ***
Comment 2 Adam Porter 2012-12-06 03:35:18 UTC
How is this a dupe of 270442?  That bug is about DBUS and 100% CPU usage and other unrelated stuff.

I just upgraded from KDE 4.9.2 to KDE 4.9.3 and suddenly kdialog crashes every time I use it.  DBUS is not running at 100% CPU.