Bug 363463 - xdg-mime crashes when run from another user (kdesu konsole)
Summary: xdg-mime crashes when run from another user (kdesu konsole)
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-05-24 11:24 UTC by deviatov
Modified: 2016-05-25 14:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description deviatov 2016-05-24 11:24:45 UTC
Application: ktraderclient (0.0)
KDE Platform Version: 4.14.16 (Compiled from sources)
Qt Version: 4.8.6
Operating System: Linux 4.0.9-gentoo-gnu20160422 x86_64
Distribution: "NAME=Gentoo"

-- Information about the crash:
- What I was doing when the application crashed:

first, I typed (as the normal user)
kdesu -u rostislav_www -n -c konsole &
then, in the new terminal:
xdg-mime query default application/pdf

-- Backtrace:
Application: KTraderClient (ktraderclient), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
84	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x00007f5253608217 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:55
#7  0x00007f525360966a in __GI_abort () at abort.c:89
#8  0x00007f5253d398f4 in qt_message_output (msgType=<optimized out>, buf=<optimized out>) at /usr/src/debug/dev-qt/qtcore-4.8.6-r2/qt-everywhere-opensource-src-4.8.6/src/corelib/global/qglobal.cpp:2359
#9  0x00007f52548934a9 in QDebug::~QDebug (this=0x7ffed73248b0, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#10 0x00007f52548eb91a in KApplicationPrivate::init (this=0x1986300, GUIenabled=GUIenabled@entry=false) at /usr/src/debug/kde-base/kdelibs-4.14.16/kdelibs-4.14.16/kdeui/kernel/kapplication.cpp:516
#11 0x00007f52548ec29b in KApplication::KApplication (this=0x7ffed7324c10, GUIenabled=false) at /usr/src/debug/kde-base/kdelibs-4.14.16/kdelibs-4.14.16/kdeui/kernel/kapplication.cpp:352
#12 0x00000000004019de in main (argc=5, argv=0x7ffed7324d48) at /usr/src/debug/kde-apps/ktraderclient-15.08.3/ktraderclient-15.08.3/ktraderclient/ktraderclient.cpp:43

Possible duplicates by query: bug 357541.

Reported using DrKonqi
Comment 1 Christoph Feck 2016-05-25 11:07:01 UTC
You also need to start a dbus session for the new user.

*** This bug has been marked as a duplicate of bug 270442 ***
Comment 2 deviatov 2016-05-25 14:19:49 UTC
I've tried to start dbus as follows:
first, I typed (as the normal user)
kdesu -u rostislav_www -n -c konsole & 
then, in the new terminal: 
dbus-launch
xdg-mime query default application/pdf 

The same crash (with the same backtrace).

Am I doing something wrong? (Maybe, I should start dbus somewhat differently?)