Bug 286944 - kdialog crashes when invoked via cron
Summary: kdialog crashes when invoked via cron
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 1.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-18 17:27 UTC by Courage
Modified: 2011-11-19 01:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Courage 2011-11-18 17:27:00 UTC
Application: kdialog (1.0)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-13-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I have setup a cronjob to check my mail via getmail. If a specific mail label is found I use kdialog to show me a notification.

Almost Everytime such an event occurs I get the notificaton but also a crash report from kde...

-- Backtrace:
Application: KDialog (kdialog), signal: Aborted
[KCrash Handler]
#7  0x006d2416 in __kernel_vsyscall ()
#8  0x01e69c8f in raise () from /lib/i386-linux-gnu/libc.so.6
#9  0x01e6d2b5 in abort () from /lib/i386-linux-gnu/libc.so.6
#10 0x0211c4a6 in qt_message_output (msgType=QtFatalMsg, buf=0x93b9708 "kdialog(26221)/kdeui (kdelibs): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) ") at global/qglobal.cpp:2315
#11 0x00a27880 in ~QDebug (this=0xbfea2848, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#12 QDebug::~QDebug (this=0xbfea2848, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qdebug.h:81
#13 0x00b2cca6 in KApplicationPrivate::init (this=0x92fd5b0, GUIenabled=true) at ../../kdeui/kernel/kapplication.cpp:516
#14 0x00b2de34 in KApplication::KApplication (this=0xbfea2a04, GUIenabled=true) at ../../kdeui/kernel/kapplication.cpp:352
#15 0x08050913 in main (argc=) at ../../kdialog/kdialog.cpp:892

Possible duplicates by query: bug 283935, bug 282182, bug 279962, bug 278889, bug 276884.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-11-19 01:25:49 UTC

*** This bug has been marked as a duplicate of bug 270442 ***