Bug 330345 - kate crashes when ran from a remote machine
Summary: kate crashes when ran from a remote machine
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: 3.11.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-23 22:26 UTC by Paulo Casanova
Modified: 2014-01-24 10:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paulo Casanova 2014-01-23 22:26:38 UTC
Application: kate (3.11.3)
KDE Platform Version: 4.11.3
Qt Version: 4.8.4
Operating System: Linux 3.11.0-15-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:

1. KDE is up and running with my user on my computer.
2. From another computer (e.g., another laptop) I ssh into my computer and do:
export DISPLAY=:0
kate

3. kate crashes and I see the crash reporting assistance on my KDE screen.

This also happens if I run other KDE programs such as kdialog and also happens if I run them from some shell which has not been run from within KDE (say, I do ctrl+alt+F1).

The crash can be reproduced every time.

-- Backtrace:
Application: Kate (kate), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f4ccae22f77 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007f4ccae265e8 in __GI_abort () at abort.c:90
#8  0x00007f4cc8cc4912 in qt_message_output (msgType=<optimized out>, buf=0xa5b8c8 "kate(21274)/kdeui (kdelibs): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) ") at global/qglobal.cpp:2347
#9  0x00007f4cc94faa89 in QDebug::~QDebug (this=0x7fff3b552b60, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#10 0x00007f4cc95d2b48 in KApplicationPrivate::init (this=0x9c2600, GUIenabled=GUIenabled@entry=true) at ../../kdeui/kernel/kapplication.cpp:516
#11 0x00007f4cc95d3532 in KApplication::KApplication (this=0x7fff3b552e90, GUIenabled=true) at ../../kdeui/kernel/kapplication.cpp:352
#12 0x00007f4cc9a25964 in KateApp::KateApp (this=0x7fff3b552e90, args=0x8e97e0) at ../../../kate/app/kateapp.cpp:52
#13 0x00007f4ccb1b9745 in kdemain (argc=<optimized out>, argv=<optimized out>) at ../../../kate/app/katemain.cpp:376
#14 0x00007f4ccae0dde5 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=1, ubp_av=0x7fff3b553018, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff3b553008) at libc-start.c:260
#15 0x00000000004006fe in _start ()

Possible duplicates by query: bug 326141, bug 322845, bug 318467, bug 316765, bug 314342.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-24 10:59:47 UTC

*** This bug has been marked as a duplicate of bug 270442 ***