Bug 280272 - Kwrite Crash
Summary: Kwrite Crash
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kate
Classification: Applications
Component: kwrite (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-17 13:38 UTC by James
Modified: 2011-10-08 21:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James 2011-08-17 13:38:16 UTC
Application: kwrite (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38.6-26.rc1.fc15.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:

I called kwrite from the konsole. 

- Custom settings of the application:

From the konsole, I had su as root when I made the call. I do not have this issue if i run kwrite as the current user.

The crash can be reproduced every time.

-- Backtrace:
Application: KWrite (kwrite), signal: Aborted
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x00007fe9dd44d415 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007fe9dd44ed2b in abort () at abort.c:92
#8  0x00007fe9de744a84 in qt_message_output (msgType=<optimized out>, buf=<optimized out>) at global/qglobal.cpp:2282
#9  0x00007fe9e0060b5d in ~QDebug (this=0x7ffff661f7b0, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:85
#10 QDebug::~QDebug (this=0x7ffff661f7b0, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:81
#11 0x00007fe9e0145c93 in KApplicationPrivate::init (this=0xbf64c0, GUIenabled=true) at /usr/src/debug/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:516
#12 0x00007fe9e0146cd8 in KApplication::KApplication (this=0x7ffff661f9f0, GUIenabled=true) at /usr/src/debug/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:352
#13 0x00007fe9e1931cf6 in KWriteApp::KWriteApp (this=0x7ffff661f9f0, m_args=0xb7cc60) at /usr/src/debug/kdebase-4.6.2/kwrite/kwriteapp.cpp:31
#14 0x00007fe9e192e9ec in kdemain (argc=1, argv=<optimized out>) at /usr/include/QtCore/qbytearray.h:383
#15 0x00007fe9dd43843d in __libc_start_main (main=0x400730 <main(int, char**)>, argc=1, ubp_av=0x7ffff66204d8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff66204c8) at libc-start.c:226
#16 0x0000000000400761 in _start ()

Reported using DrKonqi
Comment 1 Dominik Haumann 2011-08-17 15:27:42 UTC
The backtrace does not contain any useful information. Since /usr/src/debug/kdelibs looks like it's compiled from sources, it's probably a broken KDE installation. Hence, close. Sorry...
Comment 2 Dominik Haumann 2011-10-08 21:10:05 UTC

*** This bug has been marked as a duplicate of bug 270442 ***