Bug 326141 - Crash kate on root
Summary: Crash kate on root
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: 3.10.5
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-10-17 15:36 UTC by Rems Leveille
Modified: 2013-10-18 03:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rems Leveille 2013-10-17 15:36:26 UTC
Application: kate (3.10.5)
KDE Platform Version: 4.10.5 (Compiled from sources)
Qt Version: 4.8.4
Operating System: Linux 3.8.0-31-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:Trying to open Kate as root crash evrytime and ask me to reopen but does not work

-- Backtrace:
Application: Kate (kate), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0x00007fcaf5713037 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007fcaf5716698 in __GI_abort () at abort.c:90
#8  0x00007fcaf35c85c2 in qt_message_output (msgType=<optimized out>, buf=0x26db048 "kate(27337)/kdeui (kdelibs): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) ") at global/qglobal.cpp:2347
#9  0x00007fcaf3df5a76 in QDebug::~QDebug (this=0x7ffff190ee60, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#10 0x00007fcaf3ed19e7 in KApplicationPrivate::init (this=0x2625460, GUIenabled=GUIenabled@entry=true) at ../../kdeui/kernel/kapplication.cpp:516
#11 0x00007fcaf3ed29d8 in KApplication::KApplication (this=0x7ffff190f4f0, GUIenabled=true) at ../../kdeui/kernel/kapplication.cpp:352
#12 0x00007fcaf431c524 in KateApp::KateApp (this=0x7ffff190f4f0, args=0x25a88a0) at ../../../kate/app/kateapp.cpp:52
#13 0x00007fcaf5aa97b8 in kdemain (argc=2, argv=<optimized out>) at ../../../kate/app/katemain.cpp:378
#14 0x00007fcaf56fdea5 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=2, ubp_av=0x7ffff190f678, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff190f668) at libc-start.c:260
#15 0x0000000000400701 in _start ()

Possible duplicates by query: bug 322845, bug 318467, bug 316765, bug 314342.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-10-18 01:50:48 UTC
Did you run "su" then 'kate' ?   Then don't.  KDE Applications requires dbus session available, while su doesn't care about dbus session ( nothing wrong with it) .  Run "kdesu kate" as normal user.

*** This bug has been marked as a duplicate of bug 270422 ***
Comment 2 Jekyll Wu 2013-10-18 03:20:48 UTC

*** This bug has been marked as a duplicate of bug 270442 ***