Bug 355287 - calligraauthor crash on start when open from a screen
Summary: calligraauthor crash on start when open from a screen
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: calligraauthor
Classification: Applications
Component: general (show other bugs)
Version: 2.9.7
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: Gopalakrishna Bhat
Keywords: drkonqi
Depends on:
Reported: 2015-11-13 12:59 UTC by Mathieu Jobin
Modified: 2015-12-03 14:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Mathieu Jobin 2015-11-13 12:59:37 UTC
Application: calligraauthor (2.9.7)
KDE Platform Version: 4.14.13
Qt Version: 4.8.6
Operating System: Linux 4.2.0-16-generic x86_64
Distribution: Ubuntu 15.10

-- Information about the crash:
- What I was doing when the application crashed:
tried to open calligraauthor for the first time.
tried twice.
realized I was opening it from a screen session I open from a previous X session.
calligraauthor succesfully open from krunner

I guess this is a minor issue, but i think an error message should be presented to the user as to what exactly could not be found instead of just crashing out.

thanks for your awesome work on all KDE software.

The crash can be reproduced every time.

-- Backtrace:
Application: Calligra Author (calligraauthor), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f7750335267 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:55
#7  0x00007f7750336eca in __GI_abort () at abort.c:89
#8  0x00007f774e9a2ed5 in qt_message_output (msgType=<optimized out>, buf=0x16cf4f8 "author(31673)/kdeui (kdelibs): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) ") at global/qglobal.cpp:2386
#9  0x00007f774c20295c in QDebug::~QDebug (this=0x7fff85d8a7e0, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#10 0x00007f774c2e8b4a in KApplicationPrivate::init (this=0x165d7c0, GUIenabled=GUIenabled@entry=true) at ../../kdeui/kernel/kapplication.cpp:516
#11 0x00007f774c2e9542 in KApplication::KApplication (this=0x7fff85d8ab00, GUIenabled=true) at ../../kdeui/kernel/kapplication.cpp:352
#12 0x00007f775003dca8 in KoApplication::KoApplication (this=0x7fff85d8ab00, nativeMimeType=...) at /build/calligra-ld8dSW/calligra-2.9.7/libs/main/KoApplication.cpp:132
#13 0x00007f77506cba14 in kdemain (argc=<optimized out>, argv=<optimized out>) at /build/calligra-ld8dSW/calligra-2.9.7/words/part/author/main.cpp:41
#14 0x00007f7750320a40 in __libc_start_main (main=0x4006e0 <main(int, char**)>, argc=1, argv=0x7fff85d8ac48, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff85d8ac38) at libc-start.c:289
#15 0x0000000000400719 in _start ()

Possible duplicates by query: bug 333347.

Reported using DrKonqi
Comment 1 Christoph Feck 2015-12-03 14:49:46 UTC
Did you try to run as root? If not, which desktop environment are you using? KDE applications require a working D-Bus session.

*** This bug has been marked as a duplicate of bug 270442 ***