Bug 276884 - Crash opening a program in a dual monitor setup
Summary: Crash opening a program in a dual monitor setup
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Contacts resource (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Tobias Koenig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-01 12:42 UTC by Stefanos
Modified: 2011-07-13 14:32 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefanos 2011-07-01 12:42:18 UTC
Application: akonadi_contacts_resource (0.1)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed: Started up Labview 2010SP1

- Unusual behavior I noticed: The Labview windows flipped some times between the two screens I use (one laptop screen and an external extending the desktop to the right) and then there was a black screen and a restart. The Taskbar moved on the second screen after the restart!

The crash can be reproduced every time.

-- Backtrace:
Application: Akonadi Resource (akonadi_contacts_resource), signal: Aborted
[KCrash Handler]
#7  0x0089f416 in __kernel_vsyscall ()
#8  0x07620e71 in raise () from /lib/i386-linux-gnu/libc.so.6
#9  0x0762434e in abort () from /lib/i386-linux-gnu/libc.so.6
#10 0x005153ba in qt_message_output (msgType=QtFatalMsg, buf=0x84983f8 "akonadi_contacts_resource_5(2255): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) \n") at global/qglobal.cpp:2282
#11 0x00e4f88b in QDebug::~QDebug (this=0xbfa97610, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#12 0x00f4603b in KApplicationPrivate::init (this=0x8487838, GUIenabled=true) at ../../kdeui/kernel/kapplication.cpp:516
#13 0x00f46fe7 in KApplication::KApplication (this=0xbfa976c0, GUIenabled=true) at ../../kdeui/kernel/kapplication.cpp:352
#14 0x080521ae in init<ContactsResource> (argc=) at /usr/include/akonadi/resourcebase.h:179
#15 main (argc=) at ../../../resources/contacts/contactsresource.cpp:519

Possible duplicates by query: bug 272647, bug 270442, bug 246404.

Reported using DrKonqi
Comment 1 Christophe Marin 2011-07-13 14:32:47 UTC

*** This bug has been marked as a duplicate of bug 270442 ***