Bug 278889 - KCminit crash when after manually killing DBus-daemon which was hung at 100% CPU
Summary: KCminit crash when after manually killing DBus-daemon which was hung at 100% CPU
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-30 21:58 UTC by Johan Persson
Modified: 2011-07-31 00:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johan Persson 2011-07-30 21:58:32 UTC
Application: kcminit ()
KDE Platform Version: 4.6.4 (4.6.4)
Qt Version: 4.7.3
Operating System: Linux 2.6.37.6-0.5-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
After manually bein forced to kill DBus-dameon since it was at 100% CPU and blocking everything else to be launched in KDE a number of problems terted to appear. Even aftar a relaunch of Dbus things did not work and forces a restart of KDE to get back to normal. 

One thing unusual before this crash was that the HP-printer systray had Python hung at 100% 

Then after killing the systray for HP printer I received this crash.

-- Backtrace:
Application: KCMInit (kcminit), signal: Aborted
[KCrash Handler]
#7  0xffffe424 in __kernel_vsyscall ()
#8  0xb764c8df in raise () from /lib/libc.so.6
#9  0xb764e220 in abort () from /lib/libc.so.6
#10 0xb6b5aa7a in qt_message_output (msgType=QtFatalMsg, buf=0x80d2bc0 "kcminit(17872): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) \n") at global/qglobal.cpp:2282
#11 0xb7518f50 in QDebug::~QDebug (this=0xbff41800, __in_chrg=<value optimized out>) at /usr/include/QtCore/qdebug.h:85
#12 0xb74a4500 in KApplicationPrivate::init (this=0x80c4620, GUIenabled=true) at /usr/src/debug/kdelibs-4.6.4/kdeui/kernel/kapplication.cpp:516
#13 0xb74a56e4 in KApplication::KApplication (this=0xbff41900, GUIenabled=true) at /usr/src/debug/kdelibs-4.6.4/kdeui/kernel/kapplication.cpp:352
#14 0xb779292d in kdemain (argc=2, argv=0xbff41a44) at /usr/src/debug/kdebase-workspace-4.6.4/kcminit/main.cpp:260
#15 0x0804860b in main (argc=2, argv=0xbff41a44) at /usr/src/debug/kdebase-workspace-4.6.4/build/kcminit/kcminit_dummy.cpp:3

This bug may be a duplicate of or related to bug 270442.

Possible duplicates by query: bug 276884, bug 272647, bug 270442, bug 246404.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-07-31 00:12:12 UTC

*** This bug has been marked as a duplicate of bug 270442 ***