Bug 246404 - KDE Daemon crash
Summary: KDE Daemon crash
Status: RESOLVED NOT A BUG
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
: 266032 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-08-01 08:45 UTC by xenfiles
Modified: 2011-04-19 16:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xenfiles 2010-08-01 08:45:51 UTC
Application: kded4 ($Id: kded.cpp 1031637 2009-10-05 16:58:19Z lunakl $)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 2"
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
KDE Daemon crash everytime I use as root the folloing command:
kded4 --check

The crash can be reproduced every time.

 -- Backtrace:
Application: KDE Daemon (kded4), signal: Aborted
[KCrash Handler]
#6  0xffffe424 in __kernel_vsyscall ()
#7  0xb77167ff in raise () from /lib/libc.so.6
#8  0xb7718140 in abort () from /lib/libc.so.6
#9  0xb6a6576a in qt_message_output (msgType=QtFatalMsg, buf=0x810c008 "kded(22862): Session bus not found \n") at global/qglobal.cpp:2266
#10 0xb7244450 in QDebug::~QDebug (this=0xbfbe78d0, __in_chrg=<value optimized out>) at /usr/include/QtCore/qdebug.h:85
#11 0xb71e0b31 in KApplicationPrivate::init (this=0x8096180, GUIenabled=true) at /usr/src/debug/kdelibs-4.4.4/kdeui/kernel/kapplication.cpp:501
#12 0xb71e1d14 in KApplication::KApplication (this=0xbfbe7a5c, GUIenabled=true) at /usr/src/debug/kdelibs-4.4.4/kdeui/kernel/kapplication.cpp:343
#13 0xb785d12a in kdemain (argc=2, argv=0xbfbe7bb4) at /usr/src/debug/kdelibs-4.4.4/kded/kded.cpp:895
#14 0x0804860b in main (argc=2, argv=0xbfbe7bb4) at /usr/src/debug/kdelibs-4.4.4/build/kded/kded4_dummy.cpp:3

Reported using DrKonqi
Comment 1 Nicolas L. 2010-08-02 10:43:24 UTC
what if you use su -   to access root ?
Comment 2 xenfiles 2010-08-02 12:26:58 UTC
(In reply to comment #1)
> what if you use su -   to access root ?

The same......
Comment 3 David Faure 2010-10-21 13:42:47 UTC
The message is clear, though:
kded(22862): Session bus not found

It's not finding the D-BUS session bus, which is logical, if you don't have one running. Why are you running a KDE application as root, rather than as the logged in user?

I don't see a valid use case here, closing.
Comment 4 Dominik Haumann 2011-04-19 16:59:42 UTC
*** Bug 266032 has been marked as a duplicate of this bug. ***