Bug 306037 - kdialog crash
Summary: kdialog crash
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 1.0
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-30 16:30 UTC by Jon Nelson
Modified: 2012-08-30 16:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Nelson 2012-08-30 16:30:28 UTC
Application: kdialog (1.0)
KDE Platform Version: 4.8.4 (4.8.4) "release 2"
Qt Version: 4.8.1
Operating System: Linux 3.4.6-1.1-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
I'm not exactly sure what's going on here, but after update to openSUSE 12.2 (from 12.1), kdialog is crashy.

The crash can be reproduced every time.

-- Backtrace:
Application: KDialog (kdialog), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f4c45918d25 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f4c4591a1a8 in __GI_abort () at abort.c:91
#8  0x00007f4c46eda9a4 in qt_message_output (msgType=<optimized out>, buf=<optimized out>) at global/qglobal.cpp:2252
#9  0x00007f4c4795f7c6 in QDebug::~QDebug (this=0x7fff5c609e70, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:85
#10 0x00007f4c47a3bd87 in KApplicationPrivate::init (this=0xf6c6c0, GUIenabled=GUIenabled@entry=true) at /usr/src/debug/kdelibs-4.8.4/kdeui/kernel/kapplication.cpp:516
#11 0x00007f4c47a3cd58 in KApplication::KApplication (this=0x7fff5c60a540, GUIenabled=true) at /usr/src/debug/kdelibs-4.8.4/kdeui/kernel/kapplication.cpp:352
#12 0x000000000040ad86 in ?? ()
#13 0x00007f4c45905455 in __libc_start_main (main=0x409900, argc=6, ubp_av=0x7fff5c60a7b8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff5c60a7a8) at libc-start.c:226
#14 0x000000000040e3b1 in _start ()

Possible duplicates by query: bug 283935.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-08-30 16:58:49 UTC

*** This bug has been marked as a duplicate of bug 270442 ***