Bug 284982 - kwrite segfault
Summary: kwrite segfault
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kate
Classification: Applications
Component: kwrite (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-26 06:43 UTC by Pavel ALexeev (aka Pahan-Hubbitus)
Modified: 2011-10-26 20:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel ALexeev (aka Pahan-Hubbitus) 2011-10-26 06:43:42 UTC
Application: kwrite (4.7.2 (4.7.2))
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.8.0
Operating System: Linux 3.1.0-0.rc10.git0.1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
Start kwrite from screen GNU session. May be some environment variable had missing.

The crash can be reproduced every time.

-- Backtrace:
Application: KWrite (kwrite), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x000000350ee362a5 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x000000350ee37bbb in __GI_abort () at abort.c:91
#8  0x000000351ae71464 in qt_message_output (msgType=<optimized out>, buf=<optimized out>) at global/qglobal.cpp:2255
#9  0x000000333a36afcd in ~QDebug (this=0x7ffff0d81e00, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:85
#10 QDebug::~QDebug (this=0x7ffff0d81e00, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:81
#11 0x000000333a45222b in KApplicationPrivate::init (this=0x24faab0, GUIenabled=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:516
#12 0x000000333a4532c8 in KApplication::KApplication (this=0x7ffff0d82030, GUIenabled=true) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:352
#13 0x00000033390120b6 in KWriteApp::KWriteApp (this=0x7ffff0d82030, m_args=0x245d240) at /usr/src/debug/kate-4.7.2/kwrite/kwriteapp.cpp:31
#14 0x000000333900ed7c in kdemain (argc=5, argv=<optimized out>) at /usr/src/debug/kate-4.7.2/kwrite/kwritemain.cpp:678
#15 0x000000350ee2169d in __libc_start_main (main=0x400730 <main(int, char**)>, argc=5, ubp_av=0x7ffff0d82b18, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff0d82b08) at libc-start.c:226
#16 0x0000000000400761 in _start ()

This bug may be a duplicate of or related to bug 270442.

Possible duplicates by query: bug 283935, bug 283761, bug 264758.

Reported using DrKonqi
Comment 1 Dominik Haumann 2011-10-26 20:44:18 UTC

*** This bug has been marked as a duplicate of bug 270442 ***