Bug 264758 - Kwrite crashed during startup
Summary: Kwrite crashed during startup
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdecore (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-29 16:57 UTC by armedis
Modified: 2011-10-08 21:12 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.16 KB, text/plain)
2011-10-08 17:52 UTC, David Charles Pyle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description armedis 2011-01-29 16:57:48 UTC
Application: kwrite (4.4.5 (KDE 4.4.5))
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-27-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
KDE logged in.
Opened a console.
- sux
- kwrite /etc/apt/source.list
-> crash

The same happens when I start an "xTerm-Session"
Opened a console
- sux
- xterm
- kwrite ... bla
-> crash

The crash can be reproduced every time.

 -- Backtrace:
Application: KWrite (kwrite), signal: Aborted
[KCrash Handler]
#5  0x00007f75055bea75 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#6  0x00007f75055c25c0 in *__GI_abort () at abort.c:92
#7  0x00007f75030a4844 in qt_message_output (msgType=QtFatalMsg, buf=<value optimized out>) at global/qglobal.cpp:2250
#8  0x00007f7504749a1d in ~QDebug (this=0x7fffaa95cf50, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#9  0x00007f75048224ad in KApplicationPrivate::init (this=0x1437390, GUIenabled=<value optimized out>) at ../../kdeui/kernel/kapplication.cpp:501
#10 0x00007f7504823c29 in KApplication (this=0x7fffaa95d0a0, GUIenabled=<value optimized out>) at ../../kdeui/kernel/kapplication.cpp:343
#11 0x00007f75059206d6 in KWriteApp (this=0xfb9, m_args=0x13c1040) at ../../../apps/kwrite/kwriteapp.cpp:31
#12 0x00007f750591bd58 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../apps/kwrite/kwritemain.cpp:689
#13 0x00007f75055a9c4d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fffaa95db58) at libc-start.c:226
#14 0x00000000004006b9 in _start ()

This bug may be a duplicate of or related to bug 238681.

Possible duplicates by query: bug 246404, bug 241944, bug 238681, bug 237928.

Reported using DrKonqi
Comment 1 Christoph Cullmann 2011-07-10 14:20:07 UTC
If at all, this is a kdelibs issue. KWrite is just a normal KApplication and does no weired stuff.
Comment 2 David Charles Pyle 2011-10-08 17:52:56 UTC
Created attachment 64342 [details]
New crash information added by DrKonqi

kwrite (4.7.2 (4.7.2)) on KDE Platform 4.7.2 (4.7.2) using Qt 4.8.0

- What I was doing when the application crashed:

Ran the following command line in Konsole:
su -c kwrite /etc/pulse/daemon.conf

- Unusual behavior I noticed:

Sound was not working properly previously so was working on improving the situation.

Got all sorts of errors involving D-bus and kde-libs previously while running this a few times before. Below is what I got in the terminal window:

kwrite(9502)/kdeui (kdelibs): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 
KCrash: Application 'kwrite' crashing...
KCrash: Attempting to start /usr/libexec/kde4/drkonqi from kdeinit
sock_file=/root/.kde/socket-Sci-Fi/kdeinit4__0
Warning: connect() failed: : No such file or directory
KCrash: Attempting to start /usr/libexec/kde4/drkonqi directly
drkonqi(9503)/kdeui (kdelibs): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 
[dcpyle@Sci-Fi ~]$ su -c 'kwrite /etc/pulse/default.pa'
Password: 
kwrite(9513)/kdeui (kdelibs): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 
KCrash: Application 'kwrite' crashing...
KCrash: Attempting to start /usr/libexec/kde4/drkonqi from kdeinit
sock_file=/root/.kde/socket-Sci-Fi/kdeinit4__0
Warning: connect() failed: : No such file or directory
KCrash: Attempting to start /usr/libexec/kde4/drkonqi directly
drkonqi(9514)/kdeui (kdelibs): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 
[dcpyle@Sci-Fi ~]$ (dbus-launch)
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-JGqZpGbB6D,guid=9b0f579c06dc7e882deb557100006ac3
DBUS_SESSION_BUS_PID=9525
[dcpyle@Sci-Fi ~]$ su -c 'kwrite /etc/pulse/default.pa'
Password: 
kwrite(9531)/kdeui (kdelibs): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 
KCrash: Application 'kwrite' crashing...
KCrash: Attempting to start /usr/libexec/kde4/drkonqi from kdeinit
sock_file=/root/.kde/socket-Sci-Fi/kdeinit4__0
Warning: connect() failed: : No such file or directory
KCrash: Attempting to start /usr/libexec/kde4/drkonqi directly
drkonqi(9532)/kdeui (kdelibs): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 
[dcpyle@Sci-Fi ~]$ export $(dbus-launch)
[dcpyle@Sci-Fi ~]$ su -c 'kwrite /etc/pulse/default.pa'
Password: 
kwrite(9543)/kdeui (kdelibs): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 
KCrash: Application 'kwrite' crashing...
KCrash: Attempting to start /usr/libexec/kde4/drkonqi from kdeinit
sock_file=/root/.kde/socket-Sci-Fi/kdeinit4__0
Warning: connect() failed: : No such file or directory
KCrash: Attempting to start /usr/libexec/kde4/drkonqi directly
drkonqi(9544)/kdeui (kdelibs): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 
[dcpyle@Sci-Fi ~]$ sudo kwrite /etc/pulse/default.pa
[sudo] password for dcpyle: 
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kbuildsycoca4 running...
kbuildsycoca4(9580) KConfigGroup::readXdgListEntry: List entry Actions in "ServiceMenus/krename_dir_rec.desktop" is not compliant with XDG standard (missing trailing semicolon). 
kbuildsycoca4(9580) KConfigGroup::readXdgListEntry: List entry Actions in "ServiceMenus/krename_all_nonrec.desktop" is not compliant with XDG standard (missing trailing semicolon). 
kbuildsycoca4(9580)/kdecore (services) KServicePrivate::init: The desktop entry file "/usr/share/applications/kde/kresources.desktop" has Type= "Application" but also has a X-KDE-Library key. This works for now, but makes user-preference handling difficult, so support for this might be removed at some point. Consider splitting it into two desktop files. 
kbuildsycoca4(9580)/kdecore (services) KServicePrivate::init: The desktop entry file "/usr/share/applications/fedora-LabPlot.desktop" has Type= "Application" but also has a X-KDE-Library key. This works for now, but makes user-preference handling difficult, so support for this might be removed at some point. Consider splitting it into two desktop files.

-- Backtrace (Reduced):
#6  0x0000003239e36435 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x0000003239e37d4b in __GI_abort () at abort.c:91
[...]
#9  0x0000003249d6afcd in ~QDebug (this=0x7fff55f16400, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:85
#10 QDebug::~QDebug (this=0x7fff55f16400, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:81
#11 0x0000003249e5222b in KApplicationPrivate::init (this=0x1fecdc0, GUIenabled=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:516
Comment 3 Dominik Haumann 2011-10-08 21:12:47 UTC

*** This bug has been marked as a duplicate of bug 270442 ***