Bug 276725 - Kate crashes when opening a file
Summary: Kate crashes when opening a file
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-29 05:22 UTC by Javantea
Modified: 2011-06-29 07:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Javantea 2011-06-29 05:22:21 UTC
Application: kate (3.6.2)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.39 x86_64
Distribution: "Gentoo Base System release 2.0.2"

-- Information about the crash:
- What I was doing when the application crashed:

I ran "kate dns1s.txt" while kate was already running. dns1s.txt is a 9MB log file. Dr Konqi came up and I submitted this bug report. I will attempt to reproduce this bug with this file.

-- Backtrace:
Application: Kate (kate), signal: Aborted
[KCrash Handler]
#6  0x00007fd66c6e3165 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007fd66c6e4580 in abort () at abort.c:92
#8  0x00007fd66a56e3bc in qt_message_output (msgType=QtFatalMsg, buf=<value optimized out>) at global/qglobal.cpp:2282
#9  0x00007fd66ad6927c in QDebug::~QDebug (this=0x7fff1650ca00, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#10 0x00007fd66ae6c992 in KApplicationPrivate::init (this=<value optimized out>, GUIenabled=true) at /var/tmp/portage/kde-base/kdelibs-4.6.2-r3/work/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:518
#11 0x00007fd66ae6e149 in KApplication::KApplication (this=0x7fff1650cbd0, GUIenabled=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.6.2-r3/work/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:352
#12 0x00007fd66b2cc746 in KateApp::KateApp (this=0x496c, args=0x24c4880) at /var/tmp/portage/kde-base/kate-4.6.2/work/kate-4.6.2/kate/app/kateapp.cpp:52
#13 0x00007fd66ca10958 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /var/tmp/portage/kde-base/kate-4.6.2/work/kate-4.6.2/kate/app/katemain.cpp:373
#14 0x00007fd66c6cfbbd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff1650e168) at libc-start.c:226
#15 0x00000000004006c9 in _start ()

Possible duplicates by query: bug 272793, bug 272647, bug 270442, bug 266032, bug 246404.

Reported using DrKonqi
Comment 1 Javantea 2011-06-29 05:27:28 UTC
This is reproducible and may be caused by lack of valid dbus session in GNU screen.

kate dns1s.txt
Qt: Session management error: Could not open network socket
kate(19195): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 

KCrash: Application 'kate' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
sock_file=/home/jvoss/.kde4/socket-ASLinWS01/kdeinit4__0
[1]   Exit 253                kate dns1s.txt

[2]+  Stopped                 kate dns1s.txt
Comment 2 Javantea 2011-06-29 05:30:06 UTC
This also affects gwenview.

gwenview dns1s.txt 
Qt: Session management error: Could not open network socket
gwenview(19234): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 

KCrash: Application 'gwenview' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
sock_file=/home/jvoss/.kde4/socket-ASLinWS01/kdeinit4__0

[1]+  Stopped                 gwenview dns1s.txt

-- Backtrace:
Application: Gwenview (gwenview), signal: Aborted
[KCrash Handler]
#6  0x00007f9c86629165 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f9c8662a580 in abort () at abort.c:92
#8  0x00007f9c887b53bc in qt_message_output (msgType=QtFatalMsg, buf=<value optimized out>) at global/qglobal.cpp:2282
#9  0x00007f9c87f4927c in QDebug::~QDebug (this=0x7fff9210fb40, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#10 0x00007f9c8804c992 in KApplicationPrivate::init (this=<value optimized out>, GUIenabled=true) at /var/tmp/portage/kde-base/kdelibs-4.6.2-r3/work/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:518
#11 0x00007f9c8804dfd9 in KApplication::KApplication (this=0x7fff9210fc90, GUIenabled=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.6.2-r3/work/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:352
#12 0x0000000000440dee in main (argc=<value optimized out>, argv=<value optimized out>) at /var/tmp/portage/kde-base/gwenview-4.6.2/work/gwenview-4.6.2/gwenview/app/main.cpp:129
Comment 3 Dominik Haumann 2011-06-29 07:21:55 UTC
Then something is probably wrong with your system. It's certainly not Kate issue, hence, close.
Comment 4 Dominik Haumann 2011-06-29 07:23:33 UTC
Are you doing that as root?

*** This bug has been marked as a duplicate of bug 270442 ***