Bug 309948 - su-invoked dolphin explorer crashes
Summary: su-invoked dolphin explorer crashes
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 1.7
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-12 08:23 UTC by jmon
Modified: 2012-11-12 09:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jmon 2012-11-12 08:23:55 UTC
Application: dolphin (1.7)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.10-1.16-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I was in a second-instance tab of KDE's konsole:
joshuag@linux:~/Documents> su
Password: 
su: incorrect password
joshuag@linux:~/Documents> su
Password: 
linux:/home/joshuag/Documents # dolphin
dolphin(4386)/kdeui (kdelibs): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 
KCrash: Application 'dolphin' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
sock_file=/root/.kde4/socket-linux/kdeinit4__0

[1]+  Stopped                 dolphin
linux:/home/joshuag/Documents # dolphin
dolphin(28951)/kdeui (kdelibs): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 
KCrash: Application 'dolphin' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
sock_file=/root/.kde4/socket-linux/kdeinit4__0
[1]   Exit 253                dolphin

[2]+  Stopped                 dolphin

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Aborted
[KCrash Handler]
#6  0x00007f2483eabd95 in raise () from /lib64/libc.so.6
#7  0x00007f2483ead2ab in abort () from /lib64/libc.so.6
#8  0x00007f2480f169f4 in qt_message_output (msgType=<optimized out>, buf=<optimized out>) at global/qglobal.cpp:2291
#9  0x00007f248197062d in ~QDebug (this=0x7fff512ed690, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:85
#10 QDebug::~QDebug (this=0x7fff512ed690, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:81
#11 0x00007f2481a592bb in KApplicationPrivate::init (this=0x6cddd0, GUIenabled=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:516
#12 0x00007f2481a5a338 in KApplication::KApplication (this=0x7fff512ed910, GUIenabled=true) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:352
#13 0x00007f248423d80e in ?? () from /usr/lib64/libkdeinit4_dolphin.so
#14 0x00007f248425476f in kdemain () from /usr/lib64/libkdeinit4_dolphin.so
#15 0x00007f2483e9823d in __libc_start_main () from /lib64/libc.so.6
#16 0x0000000000400681 in _start ()

This bug may be a duplicate of or related to bug 270442.

Possible duplicates by query: bug 309928, bug 307311, bug 306037, bug 301897, bug 297773.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2012-11-12 09:02:36 UTC
Thanks for the bug report! This lookes like a problem which has been reported already.

*** This bug has been marked as a duplicate of bug 270442 ***