Bug 331860 - Crash on logout of KDE
Summary: Crash on logout of KDE
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kdevelop
Classification: Applications
Component: general (show other bugs)
Version: 4.5.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-03-07 20:43 UTC by Andrew Udvare
Modified: 2014-03-10 09:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Udvare 2014-03-07 20:43:53 UTC
Application: kdevelop (4.5.2)
KDE Platform Version: 4.12.2 (Compiled from sources)
Qt Version: 4.8.5
Operating System: Linux 3.10.25-gentoo x86_64
Distribution: "NAME=Gentoo"

-- Information about the crash:
- What I was doing when the application crashed:
Restarted X manually with /etc/init.d/xdm accidentally, then re-logged in from KDM and on start up KDevelop could not resume its previous state. Instead it crashed.

-- Backtrace:
Application: KDevelop (kdevelop), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  0x00007fd0d1eb2535 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007fd0d1eb39b8 in __GI_abort () at abort.c:90
#8  0x00007fd0d323d834 in qt_message_output (msgType=<optimized out>, buf=<optimized out>) at global/qglobal.cpp:2323
#9  0x00007fd0d381efd6 in QDebug::~QDebug (this=0x7fffd43ffe30, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#10 0x00007fd0d38fb2f7 in KApplicationPrivate::init (this=0x7f81a0, GUIenabled=GUIenabled@entry=true) at /var/tmp/portage/kde-base/kdelibs-4.12.2/work/kdelibs-4.12.2/kdeui/kernel/kapplication.cpp:516
#11 0x00007fd0d38fc2e8 in KApplication::KApplication (this=0x7fffd4400420, GUIenabled=true) at /var/tmp/portage/kde-base/kdelibs-4.12.2/work/kdelibs-4.12.2/kdeui/kernel/kapplication.cpp:352
#12 0x000000000040c264 in KDevelopApplication (GUIenabled=true, this=0x7fffd4400420) at /var/tmp/portage/dev-util/kdevelop-4.5.2/work/kdevelop-4.5.2/app/main.cpp:76
#13 main (argc=4, argv=0x7fffd44007b8) at /var/tmp/portage/dev-util/kdevelop-4.5.2/work/kdevelop-4.5.2/app/main.cpp:227

Possible duplicates by query: bug 318467.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-03-10 09:10:28 UTC
> #10 0x00007fd0d38fb2f7 in KApplicationPrivate::init (this=0x7f81a0, GUIenabled=GUIenabled@entry=true) at /var/tmp/portage/kde-base/kdelibs-4.12.2/work/kdelibs-4.12.2/kdeui/kernel/kapplication.cpp:516

That line implies your session dbus is not (correctly) running

*** This bug has been marked as a duplicate of bug 270442 ***