Bug 317172 - Nepomuk occupy CPU and crash "continually"
Summary: Nepomuk occupy CPU and crash "continually"
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Nepomuk Bugs Coordination
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-22 09:19 UTC by ono
Modified: 2013-03-24 06:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ono 2013-03-22 09:19:10 UTC
Application: nepomukservicestub (0.1.0)
KDE Platform Version: 4.10.1
Qt Version: 4.8.2
Operating System: Linux 3.2.0-32-generic x86_64
Distribution: Linux Mint 13 Maya

-- Information about the crash:
- What I was doing when the application crashed:
I left my computer unused for about 2.5 hours. When I come back, all I found is my plasma crash (Plasma has crashed four times in a row in these four days...And all of them seemed to occur randomly), all of the windows' title bars disappeared, displaying was broken. After a while, KDE seemed to restart itself. 

Then,  the KDE bug report's window "Application: Nepomuk Service Stub (nepomukservicestub), signal: Aborted" popuped "CONTINUALLY", even if I close it, it popup another same one. I have close about 20 times in total.

- Unusual behavior I noticed:
Then,  the KDE bug report's window "Application: Nepomuk Service Stub (nepomukservicestub), signal: Aborted" popuped "CONTINUALLY", even if I close it, it popup another same one. I have close about 20 times in total.

These four days, KDE Plasma crashed 4 times, whenever it crashed, what I can do is `C-M-f1` and reboot, or if luckliy KDE would restart itself... After rebooting, CPU would be occupied for a long time:
kuanyui   6390 55.0  8.7 934752 531832 ?       SNl  16:43   3:49 /usr/bin/virtuoso-t +foreground +configfile /tmp/virtuoso_Cj5750.ini +w

I don't know if these phenomenon have any relations to each other, though...

The crash can be reproduced sometimes.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0x00007fae71dda425 in __GI_raise (sig=<optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007fae71dddb8b in __GI_abort () at abort.c:91
#8  0x00007fae742705db in qt_message_output (msgType=<optimized out>, buf=0x1664418 "nepomukfilewatch(6618)/kdeui (kdelibs): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) ") at global/qglobal.cpp:2284
#9  0x00007fae735895dd in ~QDebug (this=0x7fff521acd20, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#10 QDebug::~QDebug (this=0x7fff521acd20, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qdebug.h:81
#11 0x00007fae7367538b in KApplicationPrivate::init (this=0x1527950, GUIenabled=<optimized out>) at ../../kdeui/kernel/kapplication.cpp:516
#12 0x00007fae73676418 in KApplication::KApplication (this=0x7fff521ad000, GUIenabled=true) at ../../kdeui/kernel/kapplication.cpp:352
#13 0x0000000000403975 in ?? ()
#14 0x00007fae71dc576d in __libc_start_main (main=0x403470, argc=2, ubp_av=0x7fff521ad4c8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff521ad4b8) at libc-start.c:226
#15 0x0000000000404109 in _start ()

Possible duplicates by query: bug 314342, bug 306037, bug 301897.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-03-24 06:00:12 UTC
> #8  0x00007fae742705db in qt_message_output (msgType=<optimized out>, buf=0x1664418 "nepomukfilewatch(6618)/kdeui (kdelibs): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) ") at global/qglobal.cpp:2284

The backtrace shows that your session dbus  is not running.  All KDE applications tend to crash in that bad situation.

*** This bug has been marked as a duplicate of bug 270442 ***