Bug 271127 - kdesu crashes if no parameters specified
Summary: kdesu crashes if no parameters specified
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kdesu
Classification: Applications
Component: general (show other bugs)
Version: 1.0
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdesu bugs tracker
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-16 20:51 UTC by andreusand
Modified: 2011-04-23 16:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (1.28 KB, text/plain)
2011-04-16 20:59 UTC, andreusand
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreusand 2011-04-16 20:51:49 UTC
Application: kdesu (1.0)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-default i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
Entered just "kdesu" in console and crash happened. That's it

The crash can be reproduced every time.

-- Backtrace:
Application: KDE su (kdesu), signal: Aborted
[KCrash Handler]
#7  0xffffe430 in __kernel_vsyscall ()
#8  0xb60b78df in raise () from /lib/libc.so.6
#9  0xb60b9220 in abort () from /lib/libc.so.6
#10 0xb635fa2a in qt_message_output (msgType=QtFatalMsg, buf=0x8120100 "kdesu(11262): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) \n") at global/qglobal.cpp:2282
#11 0xb762dbb0 in QDebug::~QDebug (this=0xbf969930, __in_chrg=<value optimized out>) at /usr/include/QtCore/qdebug.h:85
#12 0xb75b93c0 in KApplicationPrivate::init (this=0x80c3ad0, GUIenabled=true) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:514
#13 0xb75ba5a4 in KApplication::KApplication (this=0xbf969a04, GUIenabled=true) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:352
#14 0x0805090e in _start ()

Possible duplicates by query: bug 270442, bug 246404, bug 240882.

Reported using DrKonqi
Comment 1 andreusand 2011-04-16 20:59:07 UTC
Created attachment 59052 [details]
New crash information added by DrKonqi

kdesu (1.0) on KDE Platform 4.6.00 (4.6.0) "release 6" using Qt 4.7.1

Correction: My Steps
1. opened Konsole
2. Entered su
3. any call to kdesu (with or without params) crashes

-- Backtrace (Reduced):
#11 0xb76d6bb0 in QDebug::~QDebug (this=0xbfe633b0, __in_chrg=<value optimized out>) at /usr/include/QtCore/qdebug.h:85
#12 0xb76623c0 in KApplicationPrivate::init (this=0x80c7370, GUIenabled=true) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:514
#13 0xb76635a4 in KApplication::KApplication (this=0xbfe63484, GUIenabled=true) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:352
#14 0x0805090e in _start ()
Comment 2 Christoph Feck 2011-04-23 16:01:10 UTC

*** This bug has been marked as a duplicate of bug 270442 ***