Bug 329712 - kwrite creashes when launched from su prompt
Summary: kwrite creashes when launched from su prompt
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kate
Classification: Applications
Component: kwrite (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-08 05:09 UTC by Landis
Modified: 2014-01-24 10:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Landis 2014-01-08 05:09:08 UTC
Application: kwrite (4.11.4)
KDE Platform Version: 4.11.4
Qt Version: 4.8.5
Operating System: Linux 3.7.10-1.24-desktop i686
Distribution: "openSUSE 12.3 (i586)"

-- Information about the crash:
konsole > user > su 
# kwrite /etc/aliases

kwrite crashe when i typed the above.
probably used wrong syntax

-- Backtrace:
Application: KWrite (kwrite), signal: Aborted
Using host libthread_db library "/lib/libthread_db.so.1".
[KCrash Handler]
#6  0xb7622245 in raise () from /lib/libc.so.6
#7  0xb7623ac3 in abort () from /lib/libc.so.6
#8  0xb5e09e6e in qt_message_output (msgType=QtFatalMsg, buf=0x8c12728 "kwrite(5940)/kdeui (kdelibs): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) ") at global/qglobal.cpp:2323
#9  0xb6f4bb28 in QDebug::~QDebug (this=0xbfd68a54, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:85
#10 0xb7047f8c in KApplicationPrivate::init (this=0x8ba3bf0, GUIenabled=GUIenabled@entry=true) at /usr/src/debug/kdelibs-4.11.4/kdeui/kernel/kapplication.cpp:516
#11 0xb7049010 in KApplication::KApplication (this=0xbfd68c64, GUIenabled=true) at /usr/src/debug/kdelibs-4.11.4/kdeui/kernel/kapplication.cpp:352
#12 0xb777d3a6 in ?? () from /usr/lib/libkdeinit4_kwrite.so
#13 0xb7779ab5 in kdemain () from /usr/lib/libkdeinit4_kwrite.so
#14 0x080485bb in ?? ()
#15 0xb760d525 in __libc_start_main () from /lib/libc.so.6
#16 0x080485e1 in _start ()

Possible duplicates by query: bug 328478, bug 326141, bug 325230, bug 324579, bug 322845.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-24 10:59:49 UTC
use '$ kdesu konsole' instead.

*** This bug has been marked as a duplicate of bug 270442 ***