Bug 318467 - KTraderClient constantly crashing when I run selenium tests
Summary: KTraderClient constantly crashing when I run selenium tests
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
Depends on:
Reported: 2013-04-16 21:32 UTC by Dima Ryazanov
Modified: 2013-04-16 22:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Dima Ryazanov 2013-04-16 21:32:52 UTC
Application: ktraderclient (0.0)
KDE Platform Version: 4.10.2
Qt Version: 4.8.4
Operating System: Linux 3.8.0-18-generic x86_64
Distribution: Ubuntu Raring Ringtail (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

I'm running selenium tests in Chrome. Every time a test finishes, I get the KTraderClient crash dialog. I don't know what KTraderClient is, but all the crash dialogs make it difficult to get anything done.

The crash can be reproduced every time.

-- Backtrace:
Application: KTraderClient (ktraderclient), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f2878a48037 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007f2878a4b698 in __GI_abort () at abort.c:90
#8  0x00007f287914d5c2 in qt_message_output (msgType=<optimized out>, buf=0x23be718 "ktraderclient(16597)/kdeui (kdelibs): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) ") at global/qglobal.cpp:2347
#9  0x00007f2879bc03c6 in QDebug::~QDebug (this=0x7fff1cf724b0, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#10 0x00007f2879c9c337 in KApplicationPrivate::init (this=0x23905a0, GUIenabled=GUIenabled@entry=false) at ../../kdeui/kernel/kapplication.cpp:516
#11 0x00007f2879c9d328 in KApplication::KApplication (this=0x7fff1cf72830, GUIenabled=false) at ../../kdeui/kernel/kapplication.cpp:352
#12 0x0000000000401882 in main (argc=5, argv=0x7fff1cf72968) at ../../ktraderclient/ktraderclient.cpp:43

This bug may be a duplicate of or related to bug 270442.

Possible duplicates by query: bug 314342, bug 306037, bug 301897.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-04-16 22:16:24 UTC
You probably have some Chromium plugin installed which links to the KDE frameworks. KDE requires a working session D-Bus.

*** This bug has been marked as a duplicate of bug 270442 ***